Newbie Guide

Posted on
Tue Dec 06, 2016 5:39 am
haavarda offline
User avatar
Posts: 635
Joined: Aug 18, 2012
Location: Norway

Newbie Guide

Thank you for this plugin. This looks very promising.
I started to play around with this. But I am not sure if I am doing it the right way.

After installing xcode and command line tools, I was able to install macports. And after that I installed homebridge, and homebridge-indigo. So far so good.

I was also able to run the command below and the folder came up with the expected files.
Code: Select all
mkdir -p ~/.homebridge
cp /opt/local/lib/node_modules/homebridge-indigo/sampleconfig.json ~/.homebridge/config.json
open ~/.homebridge


But now I am wandering. Do I need to do any more "manual" editing? Or can the rest be done with Homebridge Buddy?
I was able to add the homebridge device to the ios app, but no devices shows up. And by then it was quite late, so I had to leave it for the day.
When I checked this morning the plugin was in a start/restart cycle, so I just stopped it. Planing on giving it a new try this evening.

Any tips?

Håvard

Posted on
Tue Dec 06, 2016 7:07 am
Bollar offline
Posts: 511
Joined: Aug 11, 2013

Re: Newbie Guide

It looks like you're close. A couple of things:

- You need to have Homebridge running, either from the command line in Terminal, or as a daemon, as documented in the Homebridge instructions.
- If you haven't created a Homebridge-Buddy server device, do so now. That will let you manage and items to the config.json.

I believe that will complete your installation and populate your devices in HomeKit.

Also, note that Homebridge-buddy only starts/stops Homebridge if it's running as a daemon. If it's running from the command line, you need to start/stop it yourself.

Insteon / Z-Wave / Bryant Evolution Connex /Tesla / Roomba / Elk M1 / SiteSage / Enphase Enlighten / NOAA Alerts

Posted on
Tue Dec 06, 2016 9:02 am
Colorado4Wheeler offline
User avatar
Posts: 2688
Joined: Jul 20, 2009
Location: Colorado

Re: Newbie Guide

Thank you Bollar for guiding him in the right direction :) .

Haavarda, as Bollar said, please be sure to follow the instructions that Webdeck has laid out, which are really detailed, in getting Homebridge up and running first. I will be bundling Homebridge and Homebridge Indigo together with this plugin soon but we aren't there yet.

My Modest Contributions to Indigo:

HomeKit Bridge | Device Extensions | Security Manager | LCD Creator | Room-O-Matic | Smart Dimmer | Scene Toggle | Powermiser | Homebridge Buddy

Check Them Out Here

Posted on
Wed Dec 07, 2016 1:46 am
haavarda offline
User avatar
Posts: 635
Joined: Aug 18, 2012
Location: Norway

Re: Newbie Guide

Thank you. I was able to get it to work. Now starts the fun part on adding devices and building the system :) .
Is there any tips on strategy on rooms, names and so on? I ran in to a funny situation with my harmony off action group.

Hey Siri, Turn on Turn off TV :D

Håvard

Posted on
Wed Dec 07, 2016 6:07 am
Colorado4Wheeler offline
User avatar
Posts: 2688
Joined: Jul 20, 2009
Location: Colorado

Re: Newbie Guide

haavarda wrote:
Hey Siri, Turn on Turn off TV


LOL, I had a few of those too. As I've become more Siri-centric in my home I've changed the names of a lot of things so that Siri makes sense, i.e., "Hey Siri, turn off the kitchen"... "OK the kitchen are off". Hey Siri, learn grammar :lol: .

By the way, ask Siri to open the pod bay doors...

As for naming rooms, I mirrored what I did in Indigo mostly. Since we can't pre-define rooms before you use HomeKit, I just went through each device and assigned it to the proper room.

My Modest Contributions to Indigo:

HomeKit Bridge | Device Extensions | Security Manager | LCD Creator | Room-O-Matic | Smart Dimmer | Scene Toggle | Powermiser | Homebridge Buddy

Check Them Out Here

Posted on
Wed Dec 07, 2016 9:57 am
haavarda offline
User avatar
Posts: 635
Joined: Aug 18, 2012
Location: Norway

Re: Newbie Guide

I have a strange issue. One of my lights is not responding to commands. When I turn it on/off in iOS nothing happens. And nothing happens when I turn on or off the alias device as well. When I operate from the original zwave device it is working. Any ideas?


Sent from my iPhone using Tapatalk

Håvard

Posted on
Wed Dec 07, 2016 11:35 am
haavarda offline
User avatar
Posts: 635
Joined: Aug 18, 2012
Location: Norway

Re: Newbie Guide

I have been able to narrow it down a bit. When i create an alias for my fibaro relay it is not working to turn on or off. If I just include it as a normal device with the orginal name, it is working. So it has something to do with the alias function... Any tips?

Håvard

Posted on
Wed Dec 07, 2016 11:42 am
Colorado4Wheeler offline
User avatar
Posts: 2688
Joined: Jul 20, 2009
Location: Colorado

Re: Newbie Guide

It may be that the device doesn't answer to On/Off commands in a normal fashion. Please post the debug log and which device name for me to examine and I'll see if I can determine the issue.

My Modest Contributions to Indigo:

HomeKit Bridge | Device Extensions | Security Manager | LCD Creator | Room-O-Matic | Smart Dimmer | Scene Toggle | Powermiser | Homebridge Buddy

Check Them Out Here

Posted on
Wed Dec 07, 2016 12:26 pm
haavarda offline
User avatar
Posts: 635
Joined: Aug 18, 2012
Location: Norway

Re: Newbie Guide

Thanks for the quick reply.
How do I post the debug info, and do I expose any sensitive information?

Håvard

Posted on
Wed Dec 07, 2016 12:37 pm
Colorado4Wheeler offline
User avatar
Posts: 2688
Joined: Jul 20, 2009
Location: Colorado

Re: Newbie Guide

Menu -> Plugins -> EPS Homebridge Buddy -> Support Comprehensive Data Dump.

It's certainly possible, although unlikely, that sensitive information may be posted so if you want to just PM it to me that's fine.

My Modest Contributions to Indigo:

HomeKit Bridge | Device Extensions | Security Manager | LCD Creator | Room-O-Matic | Smart Dimmer | Scene Toggle | Powermiser | Homebridge Buddy

Check Them Out Here

Posted on
Wed Dec 07, 2016 12:48 pm
haavarda offline
User avatar
Posts: 635
Joined: Aug 18, 2012
Location: Norway

Re: Newbie Guide

I have sent you a PM with the requested data dump. Hope this helps :)

Håvard

Posted on
Wed Dec 07, 2016 3:06 pm
Colorado4Wheeler offline
User avatar
Posts: 2688
Joined: Jul 20, 2009
Location: Colorado

Re: Newbie Guide

I don't see anything in the debug that raises a red flag. Can you try reloading HBB and see if that works? If not then please do the following and post the results:

  • Go to the HBB plugin configuration in the menu and select Configure
  • Set the debug level to Thread
  • Clear your event log by clicking the button at the top
  • Try to toggle the HBB device on and off so the log can pick up what is going on
  • Post the log here or PM it to me
  • Return to step 1 and set your log back to normal

My Modest Contributions to Indigo:

HomeKit Bridge | Device Extensions | Security Manager | LCD Creator | Room-O-Matic | Smart Dimmer | Scene Toggle | Powermiser | Homebridge Buddy

Check Them Out Here

Posted on
Thu Dec 08, 2016 11:06 am
haavarda offline
User avatar
Posts: 635
Joined: Aug 18, 2012
Location: Norway

Re: Newbie Guide

I have sent you the requested logs. Lets hope this helps :)

Håvard

Posted on
Tue Dec 13, 2016 5:15 am
haavarda offline
User avatar
Posts: 635
Joined: Aug 18, 2012
Location: Norway

Re: Newbie Guide

I have the same issue with similar devices, as I have tested with several identical devices. But a work around is to create a wrapper device. Then it works...

Håvard

Posted on
Sat Dec 24, 2016 6:22 am
haavarda offline
User avatar
Posts: 635
Joined: Aug 18, 2012
Location: Norway

Re: Newbie Guide

I have updated to the latest version, but I am still seeing this "bug". Not able to use alias devices for my on/off light switches. Defining them as a wrapper is a work around.

Håvard

Who is online

Users browsing this forum: No registered users and 1 guest