Error with SecuritySpy/Cynical Plugin and HomeKit Bridge

Posted on
Mon Nov 16, 2020 8:24 pm
boisy offline
User avatar
Posts: 144
Joined: Jun 25, 2013

Error with SecuritySpy/Cynical Plugin and HomeKit Bridge

I'm trying to add a camera that I have under SecuritySpy 5 and the Cynical plugin to HomeKit Bridge. The camera server and camera are setup under Cynical and show up fine. However, when I add the camera to the HKB device, I get the following in the log:

Code: Select all
   HomeKit Bridge Error            Exception in plugin.buildServerConfigurationDict line 4526: need more than 1 value to unpack
                      CODE: ssServerId, ssCameraNum = ssDev.ownerProps["xaddress"].split("@")


The camera doesn't show up in the Home app.

Has anyone else seen this error?

Posted on
Mon Nov 16, 2020 9:02 pm
boisy offline
User avatar
Posts: 144
Joined: Jun 25, 2013

Re: Error with SecuritySpy/Cynical Plugin and HomeKit Bridge

Just following up. It turns out that I was adding the Cynical SecuritySpy's Server device when the above error occurred. Apparently I only need to add the actual Cynical SecuritySpy's Camera device.

With everything reset and restarted properly, the SecuritySpy camera is still not showing up in HomeKit. Shouldn't it just appear if it's in the list of HKB devices when I start the plugin?

Posted on
Mon Nov 16, 2020 9:36 pm
boisy offline
User avatar
Posts: 144
Joined: Jun 25, 2013

Re: Error with SecuritySpy/Cynical Plugin and HomeKit Bridge

Alright, after deleting my HKB device and reading it, I'm able to add the camera and see it. When I tap on it in the Home app, however, I see this error in the Indigo log:

Code: Select all
   Cynical SecuritySpy Error       BY 55320,83791 Error creating a JPEG image for camera "Backyard Northwest".


It looks to be an issue with the Cynical plugin.

Posted on
Tue Nov 17, 2020 6:08 am
boisy offline
User avatar
Posts: 144
Joined: Jun 25, 2013

Re: Error with SecuritySpy/Cynical Plugin and HomeKit Bridge

Well, I went further down the HKB video rabbit hole. From my Home app on my iPhone, I can see the camera. When I tap on it, I see the infinite round spinner which stays on for about 10 seconds until I get a "No Response. This camera is not responding".

Using 'ps' on my Mac running Indigo, I see ffmpeg is running:

Code: Select all
 5693   ??  R      0:07.06 ffmpeg -re -i http://myname:mypass@localhost:8000/++video?cameraNum=5&width=2688&height=1520 -map 0:0 -vcodec libx264 -pix_fmt yuv420p -r 20 -f rawvideo -tune zerolatency -vf scale=1280:720 -b:v 299k -bufsize 299k -payload_type 99 -ssrc 13157263 -f rtp -srtp_out_suite AES_CM_128_HMAC_SHA1_80 -srtp_out_params buCXQSTsv+1WFlXvS9D2o3A+ISIDtovBolf+11y2 srtp://192.168.0.151:51053?rtcpport=51053&localrtcpport=51053&pkt_size=1316


It appears that the Cynical SecuritySpy plugin is working ok. It also appears that HKB is successfully forking off ffmpeg. 192.168.0.151 is the IP address of my iPhone which is running the Home app. So why am I not able to see streaming video in the Home app?

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest