Feature Requests -- UDM Pro Support and backup file archival

Posted on
Thu Feb 27, 2020 8:19 am
kw123 offline
User avatar
Posts: 7031
Joined: May 12, 2013
Location: Dallas, TX

Re: Feature Requests -- UDM Pro Support and backup file arch

uniFiAP Error in Line 3909 has error=local variable 'ret' referenced before assignment Connection
uniFiAP Error error:>> <Response [401]> Reconnect

fixed in v .185, just posted

Posted on
Thu Feb 27, 2020 9:57 am
Korey offline
User avatar
Posts: 610
Joined: Jun 04, 2008
Location: Henderson, NV

Re: Feature Requests -- UDM Pro Support and backup file arch

I think we should all throw down and buy a UDM Pro for Karl and all his hard work!

Perhaps we could just PayPal if we had a PayPal address linked to a profile.

I'm good for a quick $50.00 even thou I don't have a UDM Pro.. yet!

Lets start to show our appreciation for all the developers hard work!

Forget a "Like" button and add a "Donate Button" :D

-------

Edit...

There is a way to donate! linked on the plugin store pages
Last edited by Korey on Thu Feb 27, 2020 12:09 pm, edited 1 time in total.

--
Korey

Posted on
Thu Feb 27, 2020 11:19 am
evansgo offline
Posts: 221
Joined: Nov 29, 2013

Re: Feature Requests -- UDM Pro Support and backup file arch

Hmm, that broke a bit..

Started plugin "uniFiAP 7.28.185"
uniFiAP testing if variable enableTimeTracking_UniFi is == on/off/print-option to enable/end/print time tracking of all functions and methods (option:'',calls,cumtime,pcalls,time)
uniFiAP myLogSet setting parameters -- logFileActive= ; logFile= /Library/Application Support/Perceptive Automation/Indigo 7.4/Preferences/Plugins/com.karlwachs.uniFiAP/plugin.log; debugLevel= []
uniFiAP Error error:>> <Response [401]> Reconnect
uniFiAP Error error:>> <Response [401]> Reconnect
uniFiAP Error error:>> <Response [401]> Reconnect
uniFiAP Error error:>> <Response [401]> Reconnect
uniFiAP Error error:>> <Response [401]> Reconnect
uniFiAP start runConcurrentThread, initializing loop settings and threads ..
uniFiAP Error error:>> <Response [401]> Reconnect
uniFiAP Error executeCMDOnController has error, no json object returned: Not Found

27 Feb 2020 at 21:18:34
uniFiAP Error executeCMDOnController has error, no json object returned: Not Found
uniFiAP initialized ... looping

Posted on
Thu Feb 27, 2020 11:29 am
evansgo offline
Posts: 221
Joined: Nov 29, 2013

Re: Feature Requests -- UDM Pro Support and backup file arch

durosity wrote:
evansgo wrote:
OK some progress :)
So I decided to take a gamble and install the UDM Pro firmware as I had read that even through it said pro only it would work. Well it does, you have to fully reset to factory defaults the UDM, but I am now on controller version 5.12.59 and FW 1.6.4.2306.


I’m amazed that worked.. but also quite impressed! How does the devices page look when you’re looking at the port settings for the switch, etc?


Sent from my iPhone using Tapatalk Pro



See screenshot
Attachments
Screen Shot 2020-02-27 at 21.28.42.png
Screen Shot 2020-02-27 at 21.28.42.png (284.41 KiB) Viewed 706 times

Posted on
Thu Feb 27, 2020 12:10 pm
durosity offline
User avatar
Posts: 3944
Joined: May 10, 2012
Location: Newcastle Upon Tyne, Ye Ol' England.

Re: Feature Requests -- UDM Pro Support and backup file arch

Interesting! I wonder why then that they have two separate firmwares when clearly the pro one will work on the non pro!


Sent from my iPhone using Tapatalk Pro

Computer says no.

Posted on
Thu Feb 27, 2020 1:08 pm
kw123 offline
User avatar
Posts: 7031
Joined: May 12, 2013
Location: Dallas, TX

Re: Feature Requests -- UDM Pro Support and backup file arch

Could you try curl setting in config.

Then set debug on

Copy the curl statements
And run individually in a terminal.

Karl


Sent from my iPhone using Tapatalk

Posted on
Thu Feb 27, 2020 10:42 pm
evansgo offline
Posts: 221
Joined: Nov 29, 2013

Re: Feature Requests -- UDM Pro Support and backup file arch

Sent you some info. Also at this point should the USG Active option be ticked or not? Not totally sure if its duplicating things...

Posted on
Fri Feb 28, 2020 1:14 am
evansgo offline
Posts: 221
Joined: Nov 29, 2013

Re: Feature Requests -- UDM Pro Support and backup file arch

[quote="durosity"]Interesting! I wonder why then that they have two separate firmwares when clearly the pro one will work on the non pro!


Not sure its all a bit of a mess with the UDM's at the moment. There are about three different versions of FW out for it. But I saw that someone had tried the pro FW and partly got it to work. So I backed up, did a full factory reset, tried it, restored setup and its been flawless, who knew :)

Posted on
Fri Feb 28, 2020 1:19 am
durosity offline
User avatar
Posts: 3944
Joined: May 10, 2012
Location: Newcastle Upon Tyne, Ye Ol' England.

Re: Feature Requests -- UDM Pro Support and backup file arch

evansgo wrote:
Not sure its all a bit of a mess with the UDM's at the moment. There are about three different versions of FW out for it. But I saw that someone had tried the pro FW and partly got it to work. So I backed up, did a full factory reset, tried it, restored setup and its been flawless, who knew :)


Yeah it has been a bit of a mess.. not just with firmwares but with the way they’ve communicated our features and if it will work with an external controller some day or if you’ll be able to host other sites.. they seemed to lose/remove a fair few of the regular staff in the forums over the course of them being available on EA...

Glad to hear it’s working though


Sent from my iPhone using Tapatalk Pro

Computer says no.

Posted on
Wed Apr 22, 2020 1:12 am
evansgo offline
Posts: 221
Joined: Nov 29, 2013

Re: Feature Requests -- UDM Pro Support and backup file arch

Morning Karl,

Are you in a position where you can log into my system by any chance? I'm at home all today / tomorrow (guess why!) so I wondered if we could pick up where we left off?

Mine is mostly working (with controller off), but getting a few regular errors

uniFiAP Error getMessages: forcing restart of listener for: dictLoop.exp @ SWdict after 192.168.10.1 sec without message180

uniFiAP Error plugin runConcurrentThread function returned or failed (will attempt again in 10 seconds)

Error unable to execute action -- com.karlwachs.utilities not found or installed


and it seems to drop the phones fairly regularly and report them as left. I have three AP's currently set up and I THINK that its loosing them when its on the main UDM and not on the other AP's.

Not sure if any of that helps :) but happy to test out anything...

Posted on
Wed Apr 22, 2020 8:29 am
kw123 offline
User avatar
Posts: 7031
Joined: May 12, 2013
Location: Dallas, TX

Re: Feature Requests -- UDM Pro Support and backup file arch

Let me know when it is good for you. I am just at home, only out for 2 30 min walks

Send me an email
To karlwachs me com


Sent from my iPhone using Tapatalk

Posted on
Wed Apr 22, 2020 10:34 pm
evansgo offline
Posts: 221
Joined: Nov 29, 2013

Re: Feature Requests -- UDM Pro Support and backup file arch

Morning Karl.

Quick report for you

Its mostly settled down, but just had this come through

uniFiAP Error getMessages: forcing restart of listener for: dictLoop.exp @ SWdict after 192.168.10.1 sec without message601
uniFiAP Warning getMessages: ListenProcess started for uType: SWdict; ip: 192.168.10.1 pid:7552


10 mins later
uniFiAP Error getMessages: forcing restart of listener for: dictLoop.exp @ APdict after 192.168.10.9 sec without message743
uniFiAP Warning getMessages: ListenProcess started for uType: APdict; ip: 192.168.10.9 pid:8164


and maybe 1/2 hour after we finished I also got a message about lowering the buffer, so I tried reducing it to 16k, nothing else since...


OK I have set read controller web page events to every 1 min and I have no more getMessages alerts

Posted on
Mon Apr 27, 2020 6:23 am
durosity offline
User avatar
Posts: 3944
Joined: May 10, 2012
Location: Newcastle Upon Tyne, Ye Ol' England.

Re: Feature Requests -- UDM Pro Support and backup file arch

I've not had this plugin setup for some time so excuse me if I've missed something obvious here. I've just updated to the new version released last night.. when I try to enable the 'UDM Active' box when saving the whole form goes red. If it's not selected it'll let me save. Any ideas?
Attachments
Screenshot 2020-04-27 at 13.15.23.png
Screenshot 2020-04-27 at 13.15.23.png (164.87 KiB) Viewed 203 times

Computer says no.

Posted on
Mon Apr 27, 2020 7:51 am
kw123 offline
User avatar
Posts: 7031
Joined: May 12, 2013
Location: Dallas, TX

Re: Feature Requests -- UDM Pro Support and backup file arch

yes I know, have that fix ready, but Gareth is still testing:
can not do proper curl login on UDM. Had it working, but not anymore.. need some direct online time
Code: Select all
16:56:43 Connection: /usr/bin/curl --insecure -c /tmp/unifiCookie -H "Content-Type: application/json" --data '{"username": "xxx", "strict": true, "password": "xxx"}' 'https://x.x.x.x:8443/api/login'

16:56:43 Connection: /usr/bin/curl --insecure -b /tmp/unifiCookie  --data '{"_limit": 45, "within": 999, "_sort": "+time"}'  -X PUT  'https://x.x.x.x:8443/api/s/default/stat/event'
2020-04-27 16:56:43.618   ERROR          Plugin.executeCMDOnController     Connection error: >>192.168.10.1<<
{"meta":{"rc":"error","msg":"api.err.LoginRequired"},"data":[]}


could you try v .191, on the plugin store and see if your login works?

Karl

Posted on
Sun May 03, 2020 8:26 am
evansgo offline
Posts: 221
Joined: Nov 29, 2013

Re: Feature Requests -- UDM Pro Support and backup file arch

durosity wrote:
I've not had this plugin setup for some time so excuse me if I've missed something obvious here. I've just updated to the new version released last night.. when I try to enable the 'UDM Active' box when saving the whole form goes red. If it's not selected it'll let me save. Any ideas?



You were really unlucky! That one was up for about 20 mins or less..... :D

Who is online

Users browsing this forum: No registered users and 1 guest