error running as service

Posted on
Fri Dec 16, 2016 11:29 am
Different Computers offline
User avatar
Posts: 1744
Joined: Jan 02, 2016
Location: East Coast

error running as service

I have homeBridge running fine manually. Followed the instructions for using launchd to start and keep it running, and I get this strange combination:

If I quit the manually running version, then try
Code: Select all
Office-Mini:Documents macadmin$ launchctl load -w ~/Library/LaunchAgents/com.webdeck.homebridge.plist
I get
Code: Select all
/Users/macadmin/Library/LaunchAgents/com.webdeck.homebridge.plist: service already loaded
even though searching Activity Monitor shows nothing named homebridge running.

The homeBridgeLog shows a single entry:
Code: Select all
path.js:8
    throw new TypeError('Path must be a string. Received ' +
    ^

TypeError: Path must be a string. Received undefined
    at assertPath (path.js:8:11)
    at Object.posix.join (path.js:479:5)
    at Function.User.storagePath (/opt/local/lib/node_modules/homebridge/lib/user.js:30:15)
    at Function.User.persistPath (/opt/local/lib/node_modules/homebridge/lib/user.js:38:25)
    at module.exports (/opt/local/lib/node_modules/homebridge/lib/cli.js:24:17)
    at Object.<anonymous> (/opt/local/lib/node_modules/homebridge/bin/homebridge:17:22)
    at Module._compile (module.js:409:26)
    at Object.Module._extensions..js (module.js:416:10)
    at Module.load (module.js:343:32)
    at Function.Module._load (module.js:300:12)
 


I'm at a loss. Is it notable that the homeBridge log shows no dates or times? Just checked and that log hasn't changed in more than a month. The entry above is from Nov 8.

SmartThings refugee, so happy to be on Indigo. 10.12.6 on an i5 MBP w/Harmony Hub, Hue, DomoPad, Dynamic URL, Device Extensions, HomeKit Bridge, MatplotLib, Plex, uniFAP, Wunderground, Nanoleaf, LED Simple Effects, Airfoil Pro, Grafana.

Posted on
Fri Dec 16, 2016 11:36 am
Different Computers offline
User avatar
Posts: 1744
Joined: Jan 02, 2016
Location: East Coast

Re: error running as service

I may have figured this out.

looks like the launchctl command was looking for runhomebridge and mine was named runhomebridge.sh. Duh.

Yup, now the homeBridgelog is populating!

SmartThings refugee, so happy to be on Indigo. 10.12.6 on an i5 MBP w/Harmony Hub, Hue, DomoPad, Dynamic URL, Device Extensions, HomeKit Bridge, MatplotLib, Plex, uniFAP, Wunderground, Nanoleaf, LED Simple Effects, Airfoil Pro, Grafana.

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest