Alpha Feedback Post

Posted on
Fri Oct 09, 2015 1:54 am
yassi offline
Posts: 396
Joined: Sep 06, 2015
Location: Germany

Re: Alpha Feedback Post

Hi Mike!

Wow, great news!
Can't wait for it, can I donate some bucks or a beer over Paypal? :lol:

Best,
yassi

Posted on
Sun Oct 11, 2015 9:41 am
yassi offline
Posts: 396
Joined: Sep 06, 2015
Location: Germany

Re: Alpha Feedback Post

Hi all,

first, I want to thank Mike for his great work!

I've downloaded the new version, is working, but sometimes I have errors in the Log.
I'm not sure why, Mike, can you have a look please when you have the time?

I've created two triggers to test it, both for my ATV1 (running XMBC).
Play Audio is true and play audio is false.
When playing should turn some mood lights, when paused should turn White.

Here is the error message:

---
11.10.2015 17:03:06
Trigger ATV1 Musik aus
Fibaro Light Manager Error Error in plugin execution ExecuteAction:

Traceback (most recent call last):
File "plugin.py", line 1080, in changeColour
<type 'exceptions.UnicodeEncodeError'>: 'ascii' codec can't encode character u'\xfc' in position 13: ordinal not in range(128)

Z-Wave sent "004 - Red" set brightness to 100
Z-Wave sent "004 - Green" set brightness to 100
Z-Wave sent "004 - Blue" set brightness to 100
Z-Wave sent "004 - White" set brightness to 100
Z-Wave sent "004 - Composite" set brightness to 100
Z-Wave received "Helligkeitssensor Wohnzimmer" sensor update to 15 lux
Trigger ATV1 Musik an
Fibaro Light Manager Error Error in plugin execution ExecuteAction:

Traceback (most recent call last):
File "plugin.py", line 1080, in changeColour
<type 'exceptions.UnicodeEncodeError'>: 'ascii' codec can't encode character u'\xfc' in position 13: ordinal not in range(128)

Z-Wave sent "004 - Red" set brightness to 40
Z-Wave sent "004 - Green" set brightness to 20
Z-Wave sent "004 - Blue" set brightness to 60
Z-Wave sent "004 - White" set brightness to 100
Z-Wave sent "004 - Composite" set brightness to 100
Z-Wave received "Temperatursensor Wohnzimmer" sensor update to 24.9 °C
Z-Wave received "004 - Composite" power load to 15.9 W

---

Best,
Yassi

Posted on
Sun Oct 11, 2015 2:00 pm
Chameleon offline
Posts: 611
Joined: Oct 04, 2014

Re: Alpha Feedback Post

Yep I know that error. It's found a character in a string like, an apostrophe or ê which is part of the extended ascii character set which indigo and python don't like. It's not a problem tho I can easily trap the error using a method Matt showed me. I'll do it in the morning.

Thanks for testing :D

Mike


Sent from my iPhone using Tapatalk

Posted on
Mon Oct 12, 2015 5:38 am
yassi offline
Posts: 396
Joined: Sep 06, 2015
Location: Germany

Re: Alpha Feedback Post

Hi Mike,

thanks for looking into it!

Yassi

Posted on
Tue Oct 13, 2015 11:56 am
yassi offline
Posts: 396
Joined: Sep 06, 2015
Location: Germany

Re: Alpha Feedback Post

Hi Mike, hi all,

just an update, the newest version (0.2.05) runs perfect.
Have no issues at all for the moment.
The errors which I had are gone!
And the new functions are great!

Mike, THX!!!

Best,
Yasmin

Posted on
Tue Oct 13, 2015 1:21 pm
Chameleon offline
Posts: 611
Joined: Oct 04, 2014

Re: Alpha Feedback Post

Great.... No problems... Let me know any ideas you have and I'll try to add them in :). Oh and I don't need payment... If it brings a smile to your daughter's face what other payment does a guy need? Mike


Sent from my iPhone using Tapatalk

Posted on
Wed Oct 14, 2015 11:09 am
yassi offline
Posts: 396
Joined: Sep 06, 2015
Location: Germany

Re: Alpha Feedback Post

Mike,

I appreciate this!

Would be cool to have some effects (blinking, moving lights) or something like this.
But this is not a must have, more important the plugin runs without errors ans it's stable.

Best,
Yassi

Posted on
Wed Oct 14, 2015 11:21 am
Chameleon offline
Posts: 611
Joined: Oct 04, 2014

Re: Alpha Feedback Post

Blinking is definitely on the agenda and a couple of special effects later this week :)


Sent from my iPhone using Tapatalk

Posted on
Wed Oct 14, 2015 11:22 am
Chameleon offline
Posts: 611
Joined: Oct 04, 2014

Re: Alpha Feedback Post

But I agree on stability


Sent from my iPhone using Tapatalk

Posted on
Wed Oct 14, 2015 8:57 pm
DaveL17 offline
User avatar
Posts: 5568
Joined: Aug 20, 2013
Location: Chicago, IL, USA

Re: Alpha Feedback Post

Just getting around to test driving the plugin. Been distracted working on a few updates myself. :D

Love the plugin Mike. It's coming along well. A couple things I noticed, however:

1. Because I live my life in the .../Plugins folder, I of course copied the RGBColours.txt file to the wrong folder. I wasn't paying attention. This resulted in an exception to the log:
Code: Select all
Traceback (most recent call last):
  File "plugin.py", line 1414, in colourPick
  File "plugin.py", line 131, in presetColours
<type 'exceptions.IOError'>: (2, 'No such file or directory', '/Library/Application Support/Perceptive Automation/Indigo 6/Preferences/Plugins/RGBColours.txt')
At a minimum, I think this would be a candidate for a trap, but I'd suggest a different route. You could make this file a component of the plugin package, and then you could get rid of the step requiring a separate install of the RGBcolours.txt file altogether. Then, if you later wanted to add more colors, you could update the file with the next plugin release.

2. I installed the plugin using an Indigo client that is not on the server machine and this doesn't work with one of the features of the plugin UI (the color picker.) No problem, but I'd suggest a note in the UI that alerts the user to the fact that the colour picker is going to appear on the server machine and not the client machine. I'm slow, so it took me a minute to figure this out.

3. It was a race to pick a color with the color picker. If I didn't pick very quickly, the plugin would timeout.

4. When I open the device configuration dialog, I get about 100 of these:
Code: Select all
Fibaro Light Manager            RGB
Fibaro Light Manager            RGB
Fibaro Light Manager            RGB
Fibaro Light Manager            RGB
Fibaro Light Manager            RGB
Fibaro Light Manager            RGB
I'd suggest getting rid of this logging, or at least adding a debug level to it.

5. There is no number 5.

6. You repeatedly misspelled the word "color". :D

Really nice job. Keeping it going Mike!
Dave

I came here to drink milk and kick ass....and I've just finished my milk.

[My Plugins] - [My Forums]

Posted on
Thu Oct 15, 2015 2:56 am
Chameleon offline
Posts: 611
Joined: Oct 04, 2014

Re: Alpha Feedback Post

DaveL17 wrote:
Just getting around to test driving the plugin. Been distracted working on a few updates myself. :D

Love the plugin Mike. It's coming along well. A couple things I noticed, however:

1. Because I live my life in the .../Plugins folder, I of course copied the RGBColours.txt file to the wrong folder. I wasn't paying attention. This resulted in an exception to the log:
Code: Select all
Traceback (most recent call last):
  File "plugin.py", line 1414, in colourPick
  File "plugin.py", line 131, in presetColours
<type 'exceptions.IOError'>: (2, 'No such file or directory', '/Library/Application Support/Perceptive Automation/Indigo 6/Preferences/Plugins/RGBColours.txt')
At a minimum, I think this would be a candidate for a trap, but I'd suggest a different route. You could make this file a component of the plugin package, and then you could get rid of the step requiring a separate install of the RGBcolours.txt file altogether. Then, if you later wanted to add more colors, you could update the file with the next plugin release.

2. I installed the plugin using an Indigo client that is not on the server machine and this doesn't work with one of the features of the plugin UI (the color picker.) No problem, but I'd suggest a note in the UI that alerts the user to the fact that the colour picker is going to appear on the server machine and not the client machine. I'm slow, so it took me a minute to figure this out.

3. It was a race to pick a color with the color picker. If I didn't pick very quickly, the plugin would timeout.

4. When I open the device configuration dialog, I get about 100 of these:
Code: Select all
Fibaro Light Manager            RGB
Fibaro Light Manager            RGB
Fibaro Light Manager            RGB
Fibaro Light Manager            RGB
Fibaro Light Manager            RGB
Fibaro Light Manager            RGB
I'd suggest getting rid of this logging, or at least adding a debug level to it.

5. There is no number 5.

6. You repeatedly misspelled the word "color". :D

Really nice job. Keeping it going Mike!
Dave



Thanks Dave - I really appreciate the detailed feedback and thanks for putting the time in :D

Some responses:

    1. Yep you're absolutely right that's exactly where the file should be. Funny thing is that I've literally just learnt how to do this in the iFindStuff plug in so starting from the next release I'm going to include the file in the plugin. My main issue was 'knowing' where the plugin had been installed so I could 'find' the file because I can't 100% guarantee that it's in the Indigo Folder - that much I did learn off iFindStuff on users' set ups. However, I know how to do that now :D

    2. Good point on the server v client and the picker. I'll make that change.

    3. The colour picker timeout is a problem I know but I can't find a way around it. I asked Matt & Jay and the response I got was essentially - 'the plugin has 10 seconds or it will timeout - sorry'. Ok I can see that's a limitation but there isn't any way that I can see to get around that issue. However, now you've reminded me I'll look at it again

    4. :oops: Old debugging log that I forgot to remove

    5. 'Mind if we call you Bruce to keep it simple?'

    6. You're right. I also noticed issues with organisation, rationalise, colourize... Maybe I should write a localisation routine for US/UK English as a standard plugin :D

There will probably be a new version later today. I'm also investigating making the plugin more generic. It could manage ANY RGB or RGBW zwave bulb - it just needs a slightly different approach to driving the change. If I can work that one out you'd be able to have Fibaro, Zipato and Phillips bulbs in the same system all linked together... I like that idea :D I'm working on understanding how to trigger the 'Set RGB Levels' dialog in a plugin and Matt/Jay are coming back to me on that.

Anyway... back to work :D

Regards

Mike

Posted on
Thu Oct 15, 2015 3:33 am
DaveL17 offline
User avatar
Posts: 5568
Joined: Aug 20, 2013
Location: Chicago, IL, USA

Re: Alpha Feedback Post

Good deal Mike, glad I'm able to help. Looking forward to seeing what this puppy can do.

Dave

I came here to drink milk and kick ass....and I've just finished my milk.

[My Plugins] - [My Forums]

Posted on
Thu Oct 15, 2015 7:23 am
yassi offline
Posts: 396
Joined: Sep 06, 2015
Location: Germany

Re: Alpha Feedback Post

Good observations Dave!

First I had the problem too but putting the RGB file in the plugin folder - didn't payed attentions to the instructions... :evil:

And agree too to 3 and 4.
Have them too.
But, I picked up colors from Mike's table, so for the moment was it ok.

@Mike: a general plugin for other lights will be really gorgeous, image all the guys with Zipato, Hue, and so on.
One plugin, lot of lights!

Have a nice day guys!
Yassi

Posted on
Thu Oct 15, 2015 12:09 pm
Chockymonster offline
Posts: 84
Joined: Jul 19, 2014
Location: Sandhurst, UK

Re: Alpha Feedback Post

I'm seeing an error in my logs every so often, I'm not 100% sure what's causing it though.

Code: Select all
  Z-Wave                          received "Alex Duetto" power load to 3.6 W
  Z-Wave                          received "Haydn Bed - Motion" status update is on
  Trigger                         Haydn under bed
  Action Group                    Haydn Reset
  Fibaro Light Manager Error      Error in plugin execution ExecuteAction:

Traceback (most recent call last):
  File "plugin.py", line 1649, in switchOn
<type 'exceptions.KeyError'>: key colourSelect not found in dict

  Z-Wave                          received "Haydn Bed - Luminance" sensor update to 1%
  Z-Wave                          received "Haydn Bed - Temperature" sensor update to 21.0 °C
  WUnderground                    Getting weather data for device: Current Weather
  Z-Wave                          received "Haydn Bed - Motion" status update is off
  Schedule                        Tado Information update
  Schedule                        Update Time
  Schedule                        Update Timers
  Schedule                        Update Coffee Machine timer
  Schedule                        Energy Usage
  Script                          rightNow             2015-10-15 18:30:01.154850
 


It seems to be when an action group fires that turns on an RGB controller using the plugin.

Posted on
Thu Oct 15, 2015 12:21 pm
Chameleon offline
Posts: 611
Joined: Oct 04, 2014

Re: Alpha Feedback Post

Chockymonster wrote:
I'm seeing an error in my logs every so often, I'm not 100% sure what's causing it though.

Code: Select all
  Z-Wave                          received "Alex Duetto" power load to 3.6 W
  Z-Wave                          received "Haydn Bed - Motion" status update is on
  Trigger                         Haydn under bed
  Action Group                    Haydn Reset
  Fibaro Light Manager Error      Error in plugin execution ExecuteAction:

Traceback (most recent call last):
  File "plugin.py", line 1649, in switchOn
<type 'exceptions.KeyError'>: key colourSelect not found in dict

  Z-Wave                          received "Haydn Bed - Luminance" sensor update to 1%
  Z-Wave                          received "Haydn Bed - Temperature" sensor update to 21.0 °C
  WUnderground                    Getting weather data for device: Current Weather
  Z-Wave                          received "Haydn Bed - Motion" status update is off
  Schedule                        Tado Information update
  Schedule                        Update Time
  Schedule                        Update Timers
  Schedule                        Update Coffee Machine timer
  Schedule                        Energy Usage
  Script                          rightNow             2015-10-15 18:30:01.154850
 


It seems to be when an action group fires that turns on an RGB controller using the plugin.


Quite right - hotfix being uploaded now 0.2.11

Who is online

Users browsing this forum: No registered users and 1 guest

cron