If you've already installed PILLOW but iTravel can't find it

Posted on
Sat Aug 27, 2016 10:21 am
Chameleon offline
Posts: 611
Joined: Oct 04, 2014

If you've already installed PILLOW but iTravel can't find it

If you follow the instructions on how to install PILLOW it implies that you can use sudo pip install PILLOW to get it working. However, this may or may not work for iTravel Indigo 6 uses Python 2.6 and pip might install PILLOW in the 2.7 library incorrectly.

If you've already installed PILLOW and iTravel can't find it you need to reinstall it under python 2.6.

First disable the plugin

Install pip2.6, if you don't already have it, is easy enough and you can read step by step instructions in this post: http://forums.indigodomo.com/viewtopic.php?f=171&t=16723

Now install PILLOW under python 2.6 by Opening a Terminal window (/Applications/Utilities/Terminal) and then at the $ prompt type sudo pip2.6 install PILLOW followed by ENTER

When the $ prompt returns (and it may take some time) type python2.6 (the 2.6 is very important)

You should get a response like:

Code: Select all
Mac-mini:~ Michael$ python2.6
--> NOTE NUMBER --> Python 2.6.9 [/u](unknown, Oct 23 2015, 19:19:20) (my comments added)
[GCC 4.2.1 Compatible Apple LLVM 7.0.0 (clang-700.0.59.5)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>>

Now try import suds
Now try import functools
Now try from suds.client import Client
Now try from functools import partial
Now try from PIL import Image

Code: Select all
>>>import suds
>>> from suds.client import Client
>>> import functools
>>> from functools import partial
>>> from PIL import Image
>>> exit()

and close the terminal window.[/list]

Now the plugin

You should be able to simply enable the plugin again and all should be good....

If you haven't downloaded version 0.2.21 you can get it from this link

https://www.dropbox.com/s/rjf1fp4xayj44t6/iTravel.indigoPlugin.zip?dl=1

It should now find the modules in the right places and run! Hopefully :)

Let me know how it goes!

This will install PILLOW in the right place and the issue should be resolved.



Now

Posted on
Thu Sep 01, 2016 12:18 pm
aderrington offline
Posts: 111
Joined: Feb 03, 2015

Re: If you've already installed PILLOW but iTravel can't fin

Hi,
I'm having some issues with installing PILLOW.

I'm currently getting the following error message:
----------------------------------------
Command "/System/Library/Frameworks/Python.framework/Versions/2.6/Resources/Python.app/Contents/MacOS/Python -u -c "import setuptools, tokenize;__file__='/private/tmp/pip-build-7G36ft/PILLOW/setup.py';exec(compile(getattr(tokenize, 'open', open)(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record /tmp/pip-hUE_Ga-record/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /private/tmp/pip-build-7G36ft/PILLOW/
Mac-mini:~ MacMini$


I get that when trying to install PILLOW
Mac-mini:~ MacMini$ sudo pip2.6 install PILLOW


Do you have any idea what might be causing the issue?

Thanks!
Andrew

Posted on
Fri Sep 02, 2016 2:34 am
Chameleon offline
Posts: 611
Joined: Oct 04, 2014

Re: If you've already installed PILLOW but iTravel can't fin

aderrington wrote:
Hi,
I'm having some issues with installing PILLOW.

I'm currently getting the following error message:
----------------------------------------
Command "/System/Library/Frameworks/Python.framework/Versions/2.6/Resources/Python.app/Contents/MacOS/Python -u -c "import setuptools, tokenize;__file__='/private/tmp/pip-build-7G36ft/PILLOW/setup.py';exec(compile(getattr(tokenize, 'open', open)(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record /tmp/pip-hUE_Ga-record/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /private/tmp/pip-build-7G36ft/PILLOW/
Mac-mini:~ MacMini$


I get that when trying to install PILLOW
Mac-mini:~ MacMini$ sudo pip2.6 install PILLOW


Do you have any idea what might be causing the issue?

Thanks!
Andrew


Two ideas to start with....

Upgrade pip2.6

This is a common error if pip is out of date...

Did you install pip2.6 or was it already on your system?

If it wasn't you may need to upgrade it first:

    sudo easy_install2.6 --upgrade pip2.6


Just use pip on it's own

Or just let your system sort it out... I've updated the software to be more flexible on which version of PILLOW it uses so this should also work fine...

    sudo pip install PILLOW


    Upgrade your plugin to the latest version 0.3.06 (at least) = see forum for link and details

Hopefully, 1 or 2 should work fine. If not let me know and we'll investigate further

Regards

Mike

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest