Issues connecting to new Plex Server

Posted on
Mon Dec 21, 2020 9:11 am
Busta999 offline
User avatar
Posts: 714
Joined: Mar 30, 2016
Location: Wales UK

Issues connecting to new Plex Server

The Plex Plugin stopped working some rime agar when I moved the Plex Library to its own iMac.

Now Christmas is upon us time to get back into Indigo and fix up all the things that have fallen over while I have been swamped for the last 12 months.

But unfortunately cannot get Indigo to connect to either the OLD Plex or the new Plex.

The Old one has almost nothing left on it. But is up and running.

In trying both Old and New - I have Copied and Pasted IP Addresses from Plex settings and username and password from my password vault and confirmed the username/password is correct.

But cannot get the Plex Plugin to connect at all

Code: Select all
2020-12-21 15:05:13.777   THREADDEBUG    Plugin.concurrentCommandProcessingThread Command queue has 4 command(s) waiting
2020-12-21 15:05:13.862   ERROR          Plugin.concurrentCommandProcessingThread Exception in background processing
Traceback (most recent call last):
  File "/Library/Application Support/Perceptive Automation/Indigo 7.4/Plugins/Plex Media Server Manager.indigoPlugin/Contents/Server Plugin/RPFramework/RPFrameworkRESTfulDevice.py", line 375, in concurrentCommandProcessingThread
    self.handleUnmanagedCommandInQueue(deviceHTTPAddress, command)
  File "/Library/Application Support/Perceptive Automation/Indigo 7.4/Plugins/Plex Media Server Manager.indigoPlugin/Contents/Server Plugin/plexMediaServerDevices.py", line 352, in handleUnmanagedCommandInQueue
    self.retrieveSecurityToken()
  File "/Library/Application Support/Perceptive Automation/Indigo 7.4/Plugins/Plex Media Server Manager.indigoPlugin/Contents/Server Plugin/plexMediaServerDevices.py", line 438, in retrieveSecurityToken
    responseObj = requests.post(u'https://plex.tv/users/sign_in.xml', headers=plexHeaders, auth=(self.indigoDevice.pluginProps.get(u'plexUsername', u''), self.indigoDevice.pluginProps.get(u'plexPassword', u'')))
  File "/Library/Application Support/Perceptive Automation/Indigo 7.4/IndigoPluginHost.app/Contents/Resources/PlugIns/requests/api.py", line 111, in post
    return request('post', url, data=data, json=json, **kwargs)
  File "/Library/Application Support/Perceptive Automation/Indigo 7.4/IndigoPluginHost.app/Contents/Resources/PlugIns/requests/api.py", line 57, in request
    return session.request(method=method, url=url, **kwargs)
  File "/Library/Application Support/Perceptive Automation/Indigo 7.4/IndigoPluginHost.app/Contents/Resources/PlugIns/requests/sessions.py", line 477, in request
    resp = self.send(prep, **send_kwargs)
  File "/Library/Application Support/Perceptive Automation/Indigo 7.4/IndigoPluginHost.app/Contents/Resources/PlugIns/requests/sessions.py", line 587, in send
    r = adapter.send(request, **kwargs)
  File "/Library/Application Support/Perceptive Automation/Indigo 7.4/IndigoPluginHost.app/Contents/Resources/PlugIns/requests/adapters.py", line 467, in send
    raise ConnectionError(err, request=request)
ConnectionError: ('Connection aborted.', error(54, 'Connection reset by peer'))
2020-12-21 15:05:13.864   DEBUG          Plugin.concurrentCommandProcessingThread Command thread ending processing


Anyone any idea why it is failing - or is a compatibility issue with Plex Version 1.21.1.3830

It would be nice to get this working again

Posted on
Tue Dec 22, 2020 6:37 am
Busta999 offline
User avatar
Posts: 714
Joined: Mar 30, 2016
Location: Wales UK

Re: Issues connecting to new Plex Server

I can authenticate using the same credentials into Plex client connecting to the same Plex Server.

Cutting and Pasting to ensure consistency.

So I know that the credentials are good, I know the IP and Port are good as I cut and pasted them from the Plex Server config.

I know there is network connectivity I can connect to the Plex Server from the Indigo Server.

Is it possible that the Plex Plugin just doesn't work anymore and I am banging my head against a wall?

Posted on
Wed Dec 23, 2020 3:11 pm
RogueProeliator offline
User avatar
Posts: 2474
Joined: Nov 13, 2012
Location: Baton Rouge, LA

Re: Issues connecting to new Plex Server

Is it possible that the Plex Plugin just doesn't work anymore and I am banging my head against a wall?

As far as I know it should be working fine... I haven't had mine on in about a month because I moved Plex servers as well and have been lazy. :-|

You entered the credentials that you use to login to the Plex.tv account, not a local server account, right?

Posted on
Wed Dec 23, 2020 3:12 pm
RogueProeliator offline
User avatar
Posts: 2474
Joined: Nov 13, 2012
Location: Baton Rouge, LA

Re: Issues connecting to new Plex Server

I have plans to do some updates to the Plex plugin at some point anyway, but I'll try to hook mine back up this evening and see if I run into any issues.

Posted on
Wed Dec 23, 2020 4:47 pm
Busta999 offline
User avatar
Posts: 714
Joined: Mar 30, 2016
Location: Wales UK

Re: Issues connecting to new Plex Server

Thanks, I’ll check again in the morning.

Spent a few hours trying different combinations.

Must admit, never occurred to me two types of Plex login.

Thanks for tip

Mike

Posted on
Wed Dec 23, 2020 10:03 pm
RogueProeliator offline
User avatar
Posts: 2474
Joined: Nov 13, 2012
Location: Baton Rouge, LA

Re: Issues connecting to new Plex Server

Must admit, never occurred to me two types of Plex login.

It has been a long while since I wrote the authentication portion of that, but IIRC people had some issues getting the API to recognize local authentication accounts, but the Plex.tv account worked fine every time. It does, unfortunately, tie you to having an active internet connection to start up the plugin (so it can obtain/validate the token), but afterwards no connection is necessary.

Adam

Posted on
Sun Dec 27, 2020 8:49 pm
RogueProeliator offline
User avatar
Posts: 2474
Joined: Nov 13, 2012
Location: Baton Rouge, LA

Re: Issues connecting to new Plex Server

but I'll try to hook mine back up this evening and see if I run into any issues.

I switched my plugin over to my new Plex server last night and it seemed to work just fine... I confirmed that I am using the Plex.tv authentication information. Were you able to try with those credentials?

Adam

Posted on
Mon Dec 28, 2020 3:02 am
Busta999 offline
User avatar
Posts: 714
Joined: Mar 30, 2016
Location: Wales UK

Re: Issues connecting to new Plex Server

I will spend some more time on this today.

But I am using the account with an email address for logging in, so not sure why it is complaining.

Thanks for confirming it is working and it is a local issue here.

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest

cron