Stumped on troubleshooting after an update to plugin

Posted on
Thu Mar 01, 2018 2:19 pm
Grognard offline
User avatar
Posts: 41
Joined: May 17, 2011
Location: Seabrook, TX

Stumped on troubleshooting after an update to plugin

I recently updated from a pre 1.1 version to the most current version, and got the following errors:
Code: Select all
Thingspeak Error                time data '2018-03-01T19:52:15+00:00' does not match format '%Y-%m-%dT%H:%M:%SZ'
Thingspeak Error                'int' object has no attribute 'get'


I disabled each device and reconfigured (via settings); I also tried updating channel info, but enabling a device still resulted in the same errors. I'm not sure precisely what steps to take next to troubleshoot this problem, apologies if I have missed something obvious.

Posted on
Thu Mar 01, 2018 3:57 pm
DaveL17 offline
User avatar
Posts: 5854
Joined: Aug 20, 2013
Location: Chicago, IL, USA

Re: Stumped on troubleshooting after an update to plugin

You haven't missed anything and I'm getting those errors too. It seems that ThingSpeak have updated the format of the timestamp they return and the standard datetime Python module can't handle the change very well (it has to do with timezones and the date/time information being naive or aware). What's odd is that the format of the data has been changing so sometimes the errors come through and sometimes they don't. No matter--I've now transitioned the plugin to use a different date/time module (dateutil) which is more robust with such things and am testing the change now. I'll be rolling out a new version of the plugin very soon (perhaps as soon as tonight).

That's tonight GMT-6:00. :D

I came here to drink milk and kick ass....and I've just finished my milk.

[My Plugins] - [My Forums]

Posted on
Thu Mar 01, 2018 8:52 pm
DaveL17 offline
User avatar
Posts: 5854
Joined: Aug 20, 2013
Location: Chicago, IL, USA

Re: Stumped on troubleshooting after an update to plugin

I've posted an update to the plugin that should address the time zone error. Please let me know it that's not the case.

I came here to drink milk and kick ass....and I've just finished my milk.

[My Plugins] - [My Forums]

Posted on
Fri Mar 02, 2018 12:39 pm
Grognard offline
User avatar
Posts: 41
Joined: May 17, 2011
Location: Seabrook, TX

Re: Stumped on troubleshooting after an update to plugin

Thanks for such a quick turnaround (and I'm relieved it wasn't me doing something dumb). I'll update to the latest version tonight and let you know how it goes.

Posted on
Fri Mar 02, 2018 4:42 pm
DaveL17 offline
User avatar
Posts: 5854
Joined: Aug 20, 2013
Location: Chicago, IL, USA

Re: Stumped on troubleshooting after an update to plugin

Thanks. Please do let me know how it goes.

I came here to drink milk and kick ass....and I've just finished my milk.

[My Plugins] - [My Forums]

Posted on
Sun Mar 04, 2018 6:32 am
Grognard offline
User avatar
Posts: 41
Joined: May 17, 2011
Location: Seabrook, TX

Re: Stumped on troubleshooting after an update to plugin

No error messages since the update. Thanks for all your amazing plugins, and your patient and prompt assistance when folks run in to trouble. As my kids like to say "you da real MVP".

Posted on
Sun Mar 04, 2018 6:57 am
DaveL17 offline
User avatar
Posts: 5854
Joined: Aug 20, 2013
Location: Chicago, IL, USA

Re: Stumped on troubleshooting after an update to plugin

Great news. Thanks for letting me know.

Cheers!

I came here to drink milk and kick ass....and I've just finished my milk.

[My Plugins] - [My Forums]

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest