Page 4 of 4

Re: Honeywell Total Connect Comfort API

PostPosted: Mon Jul 18, 2016 11:53 am
by ar26pt2
Great plugin BTW. I have been using it for about 3 days now.

I am wondering if there is (yet) support for the "circulate" thermostat fan mode? I would like to push a command to set the fan to circulate mode (which some Honeywell thermostats support that basically randomly runs the fan for about 35% of the time).

Thanks again for the plugin. So far working well!

Re: Honeywell Total Connect Comfort API

PostPosted: Wed Jul 27, 2016 12:31 pm
by nlagaros
I'm back everyone! I just posted a new version with some refactored code. Let's please use this as the base to report bugs. Apologies for the inconvenience and the long time out of touch.

howartp wrote:
Per other threads, Nick has been away; he's back now/shortly so will be looking at all the bugs which have surfaced in 0.4.4


Sent from my iPhone using Tapatalk

Re: Honeywell Total Connect Comfort API

PostPosted: Wed Jul 27, 2016 12:37 pm
by howartp
Hooray!

Well, the plugin starts up ok - which is a start! :-)


Sent from my iPhone using Tapatalk

Re: Honeywell Total Connect Comfort API

PostPosted: Wed Jul 27, 2016 12:47 pm
by nlagaros
No support for circulate right now as it is not an option in the built-in thermostat device that I use as a template in Indigo. I have not figured out a clean way to represent this state yet. It's on the list...

ar26pt2 wrote:
Great plugin BTW. I have been using it for about 3 days now.

I am wondering if there is (yet) support for the "circulate" thermostat fan mode? I would like to push a command to set the fan to circulate mode (which some Honeywell thermostats support that basically randomly runs the fan for about 35% of the time).

Thanks again for the plugin. So far working well!

Re: Honeywell Total Connect Comfort API

PostPosted: Fri Sep 09, 2016 5:41 am
by ncwes
Nick,
I am currently running 4.4 with errors in the event log. While trying to upgrade I am unable to view your wordpress site. Can you take a look?
Thanks! Love the plugin.

Re: Honeywell Total Connect Comfort API

PostPosted: Sat May 27, 2017 1:17 pm
by wideglidejrp
Great plugin. I have one small problem. I am continuously getting an error saying "No value found for device: Thermostat - Lower Level Hall, field: fanMode". This particular thermostat controls only baseboard hot water heat. There is no fan. Is there a way I can set the fanMode variable to stop the error messages?

May 27, 2017, 3:11:12 PM

Re: Honeywell Total Connect Comfort API

PostPosted: Fri Jun 30, 2017 2:53 pm
by wideglidejrp
Looing into this further, I can see the problem but not the fix. The fanMode is blank. That is what is producing the error. I tried to set it to Auto or Off, but because the fanAllowedModes is also blank, it says the values of Auto or Off are undefined. Does anyone know how to fix this? The error message below appears in the log every 30 seconds.

Honeywell Error [Fri Jun 30 16:51:10 2017] No value found for device: Thermostat - Lower Level Corner Bedroom, field: fanMode

Re: Honeywell Total Connect Comfort API

PostPosted: Sat Jul 15, 2017 8:13 am
by mpleeds
Hi Nick,
Do you have an alternate site for access to the API, as I am not using the server.app and can not access your wiki page.
Thanks,
Merrill

Re: Honeywell Total Connect Comfort API

PostPosted: Mon Sep 04, 2017 11:46 am
by petematheson
Hi Nick,

I'm still having issues where my plugin just stops working completely until I restart the plugin.
I've currently got it in a broken state if that helps to troubleshoot further.


Sent from my iPhone using Tapatalk

Re: Honeywell Total Connect Comfort API

PostPosted: Mon Sep 04, 2017 4:13 pm
by nlagaros
Any errors at all before it stops working?

petematheson wrote:
Hi Nick,

I'm still having issues where my plugin just stops working completely until I restart the plugin.
I've currently got it in a broken state if that helps to troubleshoot further.


Sent from my iPhone using Tapatalk

Re: Honeywell Total Connect Comfort API

PostPosted: Wed Sep 06, 2017 6:40 am
by petematheson
So there's nothing from the date / time when it stopped - but debugging wasn't enabled.

Restarting the plugin didn't do anything.
Initialising devices didn't do anything.
Only when I selected 'Create evohome devices' did it actually update and get it all working again.

Sep 2017, 13:35:55
Honeywell [Wed Sep 6 13:35:55 2017] Processed plugin preferences.
Reloading plugin "Honeywell 0.5.1"
Stopping plugin "Honeywell 0.5.1" (pid 90576)
Honeywell Debug Method: stopConcurrentThread
Honeywell Debug Method: stopConcurrentThread
Honeywell Debug Stopping device: EV Con: Matheson Manor [1324059]
Honeywell Debug Stopping device: EV Zone: Bathroom
Honeywell Debug Stopping device: EV Zone: Boys Room
Honeywell Debug Stopping device: EV Zone: Dining Room
Honeywell Debug Stopping device: EV Zone: EnSuite
Honeywell Debug Stopping device: EV Zone: Kitchen
Honeywell Debug Stopping device: EV Zone: Living room
Honeywell Debug Stopping device: EV Zone: Main Bedroom
Honeywell Debug Stopping device: EV Zone: Nursery
Stopped plugin "Honeywell 0.5.1"
Starting plugin "Honeywell 0.5.1" (pid 95321)
Started plugin "Honeywell 0.5.1"
Honeywell Your plugin version, v0.5.1, is current.
Honeywell [Wed Sep 6 13:36:18 2017] Authenticated to TCC EMEA API.
Honeywell [Wed Sep 6 13:36:18 2017] Processed plugin preferences.
Honeywell Debug Starting device: EV Con: Matheson Manor [1324059]
Honeywell Debug Starting device: EV Zone: Bathroom
Honeywell Debug Starting device: EV Zone: Boys Room
Honeywell Debug Starting device: EV Zone: Dining Room
Honeywell Debug Starting device: EV Zone: EnSuite
Honeywell Debug Starting device: EV Zone: Kitchen
Honeywell Debug Starting device: EV Zone: Living room
Honeywell Debug Starting device: EV Zone: Main Bedroom
Honeywell Debug Starting device: EV Zone: Nursery
Honeywell Debug Method: runConcurrentThread
Honeywell Debug Running Concurrent Thread
Z-Wave received "Garden Temperature" sensor update to 20.8 °C
Z-Wave received "Garden Humidity" sensor update to 58%
Z-Wave received "Garden Humidity" sensor update to 58%
Z-Wave received "Garden Luminance" sensor update to 995 lux
Z-Wave received "Garden Ultraviolet" sensor update to 0

6 Sep 2017, 13:37:35
Honeywell [Wed Sep 6 13:37:35 2017] Created evohome Location: [1258661] EV Loc: Matheson Manor
Honeywell Initializing thermostat device: EV Loc: Matheson Manor
Honeywell Debug Updating Device: EV Loc: Matheson Manor, State: name, Value: Matheson Manor
Honeywell Debug Updating Device: EV Zone: Living room, State: maxHeatSetpoint, Value: 35.0
Honeywell Debug Updating Device: EV Zone: Living room, State: minHeatSetpoint, Value: 5.0
Honeywell Debug Updating Device: EV Zone: Nursery, State: maxHeatSetpoint, Value: 35.0
Honeywell Debug Updating Device: EV Zone: Nursery, State: minHeatSetpoint, Value: 5.0
Honeywell Debug Updating Device: EV Zone: Boys Room, State: maxHeatSetpoint, Value: 35.0
Honeywell Debug Updating Device: EV Zone: Boys Room, State: minHeatSetpoint, Value: 5.0
Honeywell Debug Updating Device: EV Zone: Main Bedroom, State: maxHeatSetpoint, Value: 35.0
Honeywell Debug Updating Device: EV Zone: Main Bedroom, State: minHeatSetpoint, Value: 5.0
Honeywell Debug Updating Device: EV Zone: Kitchen, State: maxHeatSetpoint, Value: 35.0
Honeywell Debug Updating Device: EV Zone: Kitchen, State: minHeatSetpoint, Value: 5.0
Honeywell Debug Updating Device: EV Zone: Bathroom, State: maxHeatSetpoint, Value: 35.0
Honeywell Debug Updating Device: EV Zone: Bathroom, State: minHeatSetpoint, Value: 5.0
Honeywell Debug Updating Device: EV Zone: EnSuite, State: maxHeatSetpoint, Value: 35.0
Honeywell Debug Updating Device: EV Zone: EnSuite, State: minHeatSetpoint, Value: 5.0
Honeywell Debug Updating Device: EV Zone: Dining Room, State: maxHeatSetpoint, Value: 35.0
Honeywell Debug Updating Device: EV Zone: Dining Room, State: minHeatSetpoint, Value: 5.0
Honeywell Debug Starting device: EV Loc: Matheson Manor
Honeywell Debug Updating Device: EV Con: Matheson Manor [1324059], State: activeFaults, Value: []
Honeywell Debug Updating Device: EV Zone: Living room, State: activeFaults, Value: []
Honeywell Debug Updating Device: EV Zone: Living room, State: temperatureInput1, Value: 19.0
Honeywell Debug Updating Device: EV Zone: Nursery, State: activeFaults, Value: []
Honeywell Debug Updating Device: EV Zone: Nursery, State: temperatureInput1, Value: 19.5
Honeywell Debug Updating Device: EV Zone: Boys Room, State: activeFaults, Value: []
Honeywell Debug Updating Device: EV Zone: Boys Room, State: temperatureInput1, Value: 18.0
Honeywell Debug Updating Device: EV Zone: Main Bedroom, State: activeFaults, Value: []
Honeywell Debug Updating Device: EV Zone: Main Bedroom, State: temperatureInput1, Value: 19.5
Honeywell Debug Updating Device: EV Zone: Kitchen, State: activeFaults, Value: []
Honeywell Debug Updating Device: EV Zone: Kitchen, State: temperatureInput1, Value: 18.0
Honeywell Debug Updating Device: EV Zone: Bathroom, State: activeFaults, Value: []
Honeywell Debug Updating Device: EV Zone: Bathroom, State: temperatureInput1, Value: 18.5
Honeywell Debug Updating Device: EV Zone: EnSuite, State: activeFaults, Value: []
Honeywell Debug Updating Device: EV Zone: EnSuite, State: temperatureInput1, Value: 17.5
Honeywell Debug Updating Device: EV Zone: Dining Room, State: activeFaults, Value: []
Honeywell Debug Updating Device: EV Zone: Dining Room, State: temperatureInput1, Value: 18.5

6 Sep 2017, 13:38:20
Honeywell Debug Updating Device: EV Con: Matheson Manor [1324059], State: activeFaults, Value: []
Honeywell Debug Updating Device: EV Zone: Living room, State: activeFaults, Value: []
Honeywell Debug Updating Device: EV Zone: Nursery, State: activeFaults, Value: []
Honeywell Debug Updating Device: EV Zone: Boys Room, State: activeFaults, Value: []
Honeywell Debug Updating Device: EV Zone: Main Bedroom, State: activeFaults, Value: []
Honeywell Debug Updating Device: EV Zone: Kitchen, State: activeFaults, Value: []
Honeywell Debug Updating Device: EV Zone: Bathroom, State: activeFaults, Value: []
Honeywell Debug Updating Device: EV Zone: EnSuite, State: activeFaults, Value: []
Honeywell Debug Updating Device: EV Zone: Dining Room, State: activeFaults, Value: []

6 Sep 2017, 13:38:50
Honeywell Debug Updating Device: EV Con: Matheson Manor [1324059], State: activeFaults, Value: []
Honeywell Debug Updating Device: EV Zone: Living room, State: activeFaults, Value: []
Honeywell Debug Updating Device: EV Zone: Nursery, State: activeFaults, Value: []
Honeywell Debug Updating Device: EV Zone: Boys Room, State: activeFaults, Value: []
Honeywell Debug Updating Device: EV Zone: Main Bedroom, State: activeFaults, Value: []
Honeywell Debug Updating Device: EV Zone: Kitchen, State: activeFaults, Value: []
Honeywell Debug Updating Device: EV Zone: Bathroom, State: activeFaults, Value: []
Honeywell Debug Updating Device: EV Zone: EnSuite, State: activeFaults, Value: []
Honeywell Debug Updating Device: EV Zone: Dining Room, State: activeFaults, Value: []

6 Sep 2017, 13:39:21
Honeywell Debug Updating Device: EV Con: Matheson Manor [1324059], State: activeFaults, Value: []
Honeywell Debug Updating Device: EV Zone: Living room, State: activeFaults, Value: []
Honeywell Debug Updating Device: EV Zone: Nursery, State: activeFaults, Value: []
Honeywell Debug Updating Device: EV Zone: Boys Room, State: activeFaults, Value: []
Honeywell Debug Updating Device: EV Zone: Main Bedroom, State: activeFaults, Value: []
Honeywell Debug Updating Device: EV Zone: Kitchen, State: activeFaults, Value: []
Honeywell Debug Updating Device: EV Zone: Bathroom, State: activeFaults, Value: []
Honeywell Debug Updating Device: EV Zone: EnSuite, State: activeFaults, Value: []
Honeywell Debug Updating Device: EV Zone: Dining Room, State: activeFaults, Value: []
Autolog Smappee received 'Smappee Usage Monitor' power load reading: 290 W
Autolog Smappee received 'Smappee Usage Monitor' energy total: 41.953 kWh

6 Sep 2017, 13:39:53
Honeywell Debug Updating Device: EV Con: Matheson Manor [1324059], State: activeFaults, Value: []
Honeywell Debug Updating Device: EV Zone: Living room, State: activeFaults, Value: []
Honeywell Debug Updating Device: EV Zone: Nursery, State: activeFaults, Value: []
Honeywell Debug Updating Device: EV Zone: Boys Room, State: activeFaults, Value: []
Honeywell Debug Updating Device: EV Zone: Main Bedroom, State: activeFaults, Value: []
Honeywell Debug Updating Device: EV Zone: Kitchen, State: activeFaults, Value: []
Honeywell Debug Updating Device: EV Zone: Bathroom, State: activeFaults, Value: []
Honeywell Debug Updating Device: EV Zone: EnSuite, State: activeFaults, Value: []
Honeywell Debug Updating Device: EV Zone: Dining Room, State: activeFaults, Value: []
Z-Wave sent "Tumble Dryer" energy status request
Z-Wave sent "Washing Machine" energy status request

Honeywell Total Connect Comfort Mode

PostPosted: Sun Nov 19, 2017 2:04 pm
by wideglidejrp
I have an AppleScript which has the following:

Code: Select all
set hvac mode of device "Thermostat - Dining Room" to heatCoolOn
set fan mode of device "Thermostat - Dining Room" to fanAutoOn


The fan mode command works fine, but the hvac mode command gives me...

Honeywell [Thermostat - Dining Room]: Honeywell Thermostat does not support Auto Heat/Cool mode

Is there an alternative or workaround?

Re: Honeywell Total Connect Comfort API

PostPosted: Sun Sep 08, 2019 1:07 pm
by wideglidejrp
I am using a Python script to set temperature setpoints for various seasons and time of day. It works very well. I am using the Honeywell 6580 WiFi. The one problem is with Auto mode. Doesn't work with Python or using the Honeywell WiFi plugin. When I try to set the system mode to auto using the plugin I get a message saying, "Honeywell Thermostat does not support Auto Heat/Cool mode". The other part of the problem is in setting the setpoints, you have to be in the mode; e.g. to set the heat setpoint, that tstat has to be in heat mode. Likewise for cool. I can work around that by putting the tstat in heat mode, set the heat setpoint, change to cool mode and set the cool setpoint. The concern is if I am away and the weather changes dramatically, I could be in the wrong mode. I must be missing something about the system mode. Any suggestions?