Sonos - The Beginning

Posted on
Mon Apr 25, 2016 3:02 pm
nlagaros offline
Posts: 1626
Joined: Dec 20, 2010

Re: Sonos - The Beginning

I may have asked before, but can you tell me what version of OS X you are running and what your hardware is.

Posted on
Mon Apr 25, 2016 3:45 pm
RAID5 offline
Posts: 86
Joined: Jan 16, 2015
Location: Sweden

Re: Sonos - The Beginning

Mac mini 3,1 (2009) with OS X 10.6.8


/RAID5
Sent from my iPhone with Tapatalk

RAID5 "A happy Swede addicted to automation"

Posted on
Mon Apr 25, 2016 3:56 pm
nlagaros offline
Posts: 1626
Joined: Dec 20, 2010

Re: Sonos - The Beginning

Yikes! Let me see if I can package this library to distribute with the plugin. No promises.

RAID5 wrote:
Mac mini 3,1 (2009) with OS X 10.6.8


/RAID5
Sent from my iPhone with Tapatalk

Posted on
Tue Apr 26, 2016 6:55 am
nlagaros offline
Posts: 1626
Joined: Dec 20, 2010

Re: Sonos - The Beginning

I did a build of Zope for Python 2.6. Let's see if this helps and hopefully no other dependencies that are not part of OS X 10.6.

Download here: https://vulture.lagaros.com/IndigoPlugins/Sonos/Sonos.indigoPlugin_0.9.8.1.zip

nlagaros wrote:
Yikes! Let me see if I can package this library to distribute with the plugin. No promises.

RAID5 wrote:
Mac mini 3,1 (2009) with OS X 10.6.8


/RAID5
Sent from my iPhone with Tapatalk

Posted on
Tue Apr 26, 2016 5:06 pm
RAID5 offline
Posts: 86
Joined: Jan 16, 2015
Location: Sweden

Re: Sonos - The Beginning

Hi!

Thanks! It worked great!
It installed and started like it should, but I still have my little problem with that it stops updating after 5 minutes. It doesn't update information from the SONOS speakers but can still play and pause and so on. I have tried to look in to any software that might open port 1400 as you suggested. I haven´t found anything that might cause this, I really don't have anything else then Indigo installed and software for the APC UPS and WeatherSnoop(will soon be uninstalled) with Indigo. You earlier said that you could see something in the log that might be related the the port, can you direct me what I should look for.

RAID5 "A happy Swede addicted to automation"

Posted on
Wed Apr 27, 2016 4:23 pm
nlagaros offline
Posts: 1626
Joined: Dec 20, 2010

Re: Sonos - The Beginning

Would you turn on all debugging and send or post the log from plugin startup. Thanks.

Posted on
Tue May 03, 2016 5:14 am
shapa offline
Posts: 391
Joined: Sep 08, 2014
Location: Swindon

Re: Sonos - The Beginning

"Traceback (most recent call last):
File "plugin.py", line 189, in actionZP_announcementMP3
File "/Library/Application Support/Perceptive Automation/Indigo 6/Plugins/Sonos.indigoPlugin/Contents/Server Plugin/Sonos.py", line 1812, in actionAnnouncement
UnboundLocalError: local variable 'group_volume' referenced before assignment"

How to fix?

Posted on
Tue May 03, 2016 5:15 am
nlagaros offline
Posts: 1626
Joined: Dec 20, 2010

Re: Sonos - The Beginning

Please turn on debugging and run the action again. Are you getting ZonePlayer state updates?

shapa wrote:
"Traceback (most recent call last):
File "plugin.py", line 189, in actionZP_announcementMP3
File "/Library/Application Support/Perceptive Automation/Indigo 6/Plugins/Sonos.indigoPlugin/Contents/Server Plugin/Sonos.py", line 1812, in actionAnnouncement
UnboundLocalError: local variable 'group_volume' referenced before assignment"

How to fix?

Posted on
Sat May 07, 2016 5:41 am
Londonmark offline
Posts: 378
Joined: Feb 29, 2012

Re: Sonos - The Beginning

Hi Nick,

I'm having trouble with the play toggle - only seems to play rather than toggle. It used to work. Am I missing something?

LM

Posted on
Sat May 07, 2016 6:01 am
Londonmark offline
Posts: 378
Joined: Feb 29, 2012

Re: Sonos - The Beginning

I'm having trouble with the play toggle - only seems to play rather than toggle


False alarm - restarting the plugin has got it working again. Sorry.

Posted on
Mon May 16, 2016 1:43 am
mclass offline
Posts: 225
Joined: May 13, 2015
Location: Melbourne, Australia

Re: Sonos - The Beginning

Like RAID 5, I am experiencing the volume control issue - works great after reloading plugin, then comes to a grinding halt after about 5 minutes.

I am also experiencing the "play toggle" issue others have experienced.

Running Sonos 0.9.8.1, on OSX 10.6.8 running on a Mac Mini 2.1.

Thinking it might be time for a newer machine/software??!! :shock:

mclass

Posted on
Tue Aug 23, 2016 5:18 pm
gsades offline
Posts: 18
Joined: Aug 17, 2016

Re: Sonos - The Beginning

First things first: It's amazing being able to handle Sonos through Indigo. Kudos to the developer!!!

I'm kind of new to home automation. I installed the Sonos plugin and things worked fine for some days. After that, the plugin is not working properly.

The problem I detect is that the plugin is trying to connect to the wrong IPs. When I check the Sonos IPs all are in the range of xxx.xxx.15.11 to xxx.xxx.15.25, but the logs show the plugin looking for them in the range of xxx.xxx.15.110. Weeks before, those IP addresses were correct, but they have changed. I reconfigured the plugin entering a current Sonos IP, reloaded it dozens of times, disabled and enabled it back... now I ran out of ideas.

What should I try next? Is there a way to force the plugin to forget those old IPs and look for the new ones?

My current Sonos setup includes a Playbar with 2 Play:1 as surround speakers, and some Play:1 and Play:5 which have no special configuration.

Thanks for sharing your insights.

-Giovanni.

Posted on
Wed Aug 24, 2016 5:15 am
nlagaros offline
Posts: 1626
Joined: Dec 20, 2010

Re: Sonos - The Beginning

You Sonos ZonePlayers up addresses are likely setup for dynamic up address assignment which is their default. Do you know how to setup static assignments on your DHCP server?

Posted on
Fri Aug 26, 2016 8:36 am
noel1983 offline
Posts: 439
Joined: Oct 17, 2014

Re: Sonos - The Beginning

Hi all,
Previously had this working great but recently it's giving the following:

Traceback (most recent call last):
File "plugin.py", line 162, in actionZP_SonosFavorites
File "/Library/Application Support/Perceptive Automation/Indigo 6/Plugins/Sonos.indigoPlugin/Contents/Server Plugin/Sonos.py", line 1544, in actionDirect
UnboundLocalError: local variable 'l2p' referenced before assignment

Any ideas?

Thanks
Noel

Posted on
Fri Aug 26, 2016 8:39 am
nlagaros offline
Posts: 1626
Joined: Dec 20, 2010

Re: Sonos - The Beginning

Need a bit more information. What version of the plugin are you using? What is the source of the favorite you are trying to play? If you could put the plugin in debug mode and post the log output when you run the action, that would help too. Thanks.

noel1983 wrote:
Hi all,
Previously had this working great but recently it's giving the following:

Traceback (most recent call last):
File "plugin.py", line 162, in actionZP_SonosFavorites
File "/Library/Application Support/Perceptive Automation/Indigo 6/Plugins/Sonos.indigoPlugin/Contents/Server Plugin/Sonos.py", line 1544, in actionDirect
UnboundLocalError: local variable 'l2p' referenced before assignment

Any ideas?

Thanks
Noel

Who is online

Users browsing this forum: No registered users and 2 guests