Artwork file not written

Posted on
Mon Jan 08, 2018 9:23 am
Stoutjesdijk offline
User avatar
Posts: 43
Joined: Dec 21, 2014
Location: The Netherlands

Artwork file not written

Hi all,

The Sonos plugin is not writing any artwork. It works flawlessly otherwise; I can stop, play, go to the next song etc.
I also have no error messages in the log.

Any ideas?

thanks!

Best regards,

Mark

Trying to tie it all together...
| Indigo 7.3 | Plex | Arcam AV9 | LG | Panasonic | Oppo | GlobalCaché | Sonos | Nest |
| Starting a new retrofit of light switches after moving last year |

Posted on
Mon Jan 08, 2018 12:16 pm
roussell offline
User avatar
Posts: 1105
Joined: Aug 18, 2008
Location: Alabama

Re: Artwork file not written

Mine is updating without issue on plugin ver 1.0.9

Make sure you have the correct file URL on the control page definition. It will point to the Perceptive Automation folder and the images subfolder with the Sonos device player device name as the image name: like so (note use of %20 in place of spaces):

Code: Select all
file:///Library/Application%20Support/Perceptive%20Automation/images/Sonos/Master%20Bedroom_art.jpg

I find the easiest way to get the correct URL is to native to the correct folder in Finder, see if the images in that folder are updating correctly, and then drag/drop the image I want into a Safari window which will correctly URLencode the path/filename. Then I just copy/paste that URL into the CP field.

Terry

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest

cron