Adapters Plugin

Posted on
Sun Jun 09, 2019 1:09 pm
DaveL17 offline
User avatar
Posts: 5568
Joined: Aug 20, 2013
Location: Chicago, IL, USA

Re: Adapters Plugin

Not sure what's causing the error, but it's working fine for me. Do your settings resemble these?

Screen Shot 2019-06-09 at 2.05.09 PM.png
Screen Shot 2019-06-09 at 2.05.09 PM.png (85.98 KiB) Viewed 827 times

I came here to drink milk and kick ass....and I've just finished my milk.

[My Plugins] - [My Forums]

Posted on
Sun Jun 09, 2019 2:35 pm
mgolden50 offline
User avatar
Posts: 207
Joined: Jan 29, 2007
Location: Chandler, AZ

Re: Adapters Plugin

Dave, Thanks for the support. I put the parameters you recommended into the adapter. I assume the symbol for degree is option shift 8 on a Mac keyboard.

Adapters Error Error in plugin execution ServerReplacedElem:

Traceback (most recent call last):
File "plugin.py", line 127, in deviceUpdated
File "/Library/Application Support/Perceptive Automation/Indigo 7.3/IndigoPluginHost.app/Contents/Resources/PlugIns/plugin_base.py", line 1179, in deviceUpdated
File "plugin.py", line 110, in deviceStartComm
File "/Library/Application Support/Perceptive Automation/Indigo 7.3/Plugins/Adapters.indigoPlugin/Contents/Server Plugin/sensor_adapter.py", line 25, in __init__
File "/Library/Application Support/Perceptive Automation/Indigo 7.3/Plugins/Adapters.indigoPlugin/Contents/Server Plugin/sensor_adapter.py", line 76, in __init__
KeyError: key formula not found in dict

Mike
Attachments
Screen Shot 2019-06-09 at 1.29.53 PM.jpg
Screen Shot 2019-06-09 at 1.29.53 PM.jpg (79.91 KiB) Viewed 814 times

Posted on
Sun Jun 09, 2019 2:42 pm
mgolden50 offline
User avatar
Posts: 207
Joined: Jan 29, 2007
Location: Chandler, AZ

Re: Adapters Plugin

Dave,
So if these parameters work correctly on your system there must be something wrong with my Indigo setup.

Mike

Posted on
Sun Jun 09, 2019 2:56 pm
mgolden50 offline
User avatar
Posts: 207
Joined: Jan 29, 2007
Location: Chandler, AZ

Re: Adapters Plugin

Hi Again Dave,

So restarting IndigoServer eliminated the errors buy the Adapter plugin now shows 0 degrees even those I'm asking it to subtract 6.8 degrees from the physical device's reported 78.2 degrees.

Could the ° symbol I used is not recognized as a valid unit?

Thx

Mike

Posted on
Sun Jun 09, 2019 3:17 pm
howartp offline
Posts: 4158
Joined: Jan 09, 2014
Location: West Yorkshire, UK

Re: Adapters Plugin

I'm digging in the code.

The error isn't anything you're doing - there appears to be a bug in the code, because "formula" (key formula not found in dict) is not supposed to be in the dict, so it shouldn't be trying to reference it.

I also get 0, and if you stop/start the device you get the error back again...

Dave, is it working for you?

Posted on
Sun Jun 09, 2019 3:19 pm
mgolden50 offline
User avatar
Posts: 207
Joined: Jan 29, 2007
Location: Chandler, AZ

Re: Adapters Plugin

Thanks guys!!!

Posted on
Sun Jun 09, 2019 3:34 pm
howartp offline
Posts: 4158
Joined: Jan 09, 2014
Location: West Yorkshire, UK

Re: Adapters Plugin

Ok, he's got an easily fixable bug.

Download the attached Devices.xml and save it into

\Library\Application Support\Perceptive Automation\Indigo 7.3\Plugins\Adapters.indigoPlugin\Contents\Server Plugin\

(If you're not familiar with plugins, you'll need to right-click Adapters.indigoPlugin and "Show package contents")

Then restart the plugin, delete your adapter device, and recreate it.

Peter
Attachments
Devices.xml
(6.72 KiB) Downloaded 24 times

Posted on
Sun Jun 09, 2019 3:41 pm
howartp offline
Posts: 4158
Joined: Jan 09, 2014
Location: West Yorkshire, UK

Re: Adapters Plugin

Matt/Jay, i'm intending publishing a new Nissan Leaf plugin (also Dusty's).

Dusty has touched his github account twice in the last 18 months, so obviously isn't active anywhere at present.

Can I takeover his plugin(s) - Nissan Leaf and Adapters certainly, to post up this fixed version? Not sure if he has others?

Peter

Posted on
Sun Jun 09, 2019 3:44 pm
howartp offline
Posts: 4158
Joined: Jan 09, 2014
Location: West Yorkshire, UK

Re: Adapters Plugin

(Just looked; the only other plugin is Ecobee - anyone else want to take on that one?)

Peter

Posted on
Sun Jun 09, 2019 5:01 pm
howartp offline
Posts: 4158
Joined: Jan 09, 2014
Location: West Yorkshire, UK

Re: Adapters Plugin

That’s great; I only searched his posts on here, I didn’t actually read them so it might have said that in a reply sonewhere.


Sent from my iPhone using Tapatalk Pro

Posted on
Sun Jun 09, 2019 7:32 pm
DaveL17 offline
User avatar
Posts: 5568
Joined: Aug 20, 2013
Location: Chicago, IL, USA

Re: Adapters Plugin

howartp wrote:
I'm digging in the code.

The error isn't anything you're doing - there appears to be a bug in the code, because "formula" (key formula not found in dict) is not supposed to be in the dict, so it shouldn't be trying to reference it.

I also get 0, and if you stop/start the device you get the error back again...

Dave, is it working for you?

It's working for me without errors, but I can't guarantee that I'm on the latest version of the plugin. It look like the degree symbol is being used in a standard python string format conversion, so it really shouldn't be related to the error. Regardless, it sounds like Peter may be willing to fork the plugin and fix the error for good.

I came here to drink milk and kick ass....and I've just finished my milk.

[My Plugins] - [My Forums]

Posted on
Mon Jun 10, 2019 11:17 am
jay (support) offline
Site Admin
User avatar
Posts: 16345
Joined: Mar 19, 2008
Location: Austin, Texas

Re: Adapters Plugin

howartp wrote:
Can I takeover his plugin(s) - Nissan Leaf and Adapters certainly, to post up this fixed version? Not sure if he has others?


@howartp - I've sent @DustySparkle an email to enquire. I'll let you know when I get a reply. If he's no longer maintaining them, then we'll figure out the best course for getting those moved to the right spots so you can take over maintenance. Thanks for the offer!

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Sat Jun 15, 2019 3:02 am
howartp offline
Posts: 4158
Joined: Jan 09, 2014
Location: West Yorkshire, UK

Re: Adapters Plugin

Any news Jay?


Sent from my iPhone using Tapatalk Pro

Posted on
Sat Jun 15, 2019 9:23 am
jay (support) offline
Site Admin
User avatar
Posts: 16345
Joined: Mar 19, 2008
Location: Austin, Texas

Re: Adapters Plugin

No. If I don't hear by Monday, we'll consider what to do next. The issue is that he used the Apache 2.0 license (rather than a less restrictive license like MIT or Unlicense). That license carries some requirements that are somewhat burdensome, namely section 4b:

You must cause any modified files to carry prominent notices stating that You changed the files


That's a pain to enforce when multiple people are working on the same source. Since we would be distributing the plugin via the store, we would (theoretically) be liable for a variety of things: 1) the License file wouldn't be included in the plugin bundle so it would have the effect of being distributed without the license and 2) if you (or anyone contributing to it) forgot to attribute their changes clearly in the source, then we would be liable for that as well (again because we're distributing it).

This is why the MIT license is SO MUCH BETTER for our purposes and we highly recommend that people use that instead.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Sun Jun 16, 2019 6:58 am
howartp offline
Posts: 4158
Joined: Jan 09, 2014
Location: West Yorkshire, UK

Re: Adapters Plugin

Leaf won’t be a problem as I’m rewriting that with a different base library; I never liked his implementation anyway!


Sent from my iPad using Tapatalk Pro

Who is online

Users browsing this forum: No registered users and 2 guests