TP-Link Plugin v 0.9.3

Posted on
Tue Jun 01, 2021 5:42 am
changeagent offline
User avatar
Posts: 15
Joined: Aug 26, 2015

Re: TP-Link Plugin v 0.9.3

I had been running version 0.2.0 of the plug-in that was working fine with a few HS110 smart plugs. I saw that a new version (0.9.5) was available and tried running it. I received errors. I then enabled version 0.8. Similar error. I tired 0.9.6, too. Errors. In the meantime, version 0.2.0 is back up and running fine for me, but I wanted to provide you with this feedback:

Starting plugin "TP-Link Device 0.2.0" (pid 13249)
Started plugin "TP-Link Device 0.2.0"
TP-Link Device sent "TP-Link Plug" on
TP-Link Device sent "TP-Link Plug" off <-Plug works fine with version 0.2.0

Jun 1, 2021 at 7:18:32 AM
Stopping plugin TP-Link Device (pid 13249)
Stopped plugin TP-Link Device
Upgrading plugin TP-Link Device to newer version 0.8.0 (previous version moved to trash)
Loading plugin "TP-Link Device 0.8.0"
Starting plugin "TP-Link Device 0.8.0" (pid 13263)
TP-Link Device Log level set to info
Started plugin "TP-Link Device 0.8.0"
TP-Link Device Polling started for TP-Link Plug@10.0.1.16.
TP-Link Device Error (tpl_polling.py:run:353): Error attempting to update TP-Link Plug: 'power_mw'. Will try again in 10 seconds
TP-Link Device Error (tpl_polling.py:run:353): Error attempting to update TP-Link Plug: 'power_mw'. Will try again in 10 seconds
TP-Link Device Error (tpl_polling.py:run:353): Error attempting to update TP-Link Plug: 'power_mw'. Will try again in 10 seconds
TP-Link Device Error (tpl_polling.py:run:353): Error attempting to update TP-Link Plug: 'power_mw'. Will try again in 10 seconds
TP-Link Device Error (tpl_polling.py:run:353): Error attempting to update TP-Link Plug: [Errno 57] Socket is not connected. Will try again in 10 seconds
TP-Link Device Error (tpl_polling.py:run:353): Error attempting to update TP-Link Plug: [Errno 57] Socket is not connected. Will try again in 10 seconds
TP-Link Device Error (tpl_polling.py:run:353): Error attempting to update TP-Link Plug: 'power_mw'. Will try again in 10 seconds
TP-Link Device Error (tpl_polling.py:run:353): Error attempting to update TP-Link Plug: 'power_mw'. Will try again in 10 seconds
TP-Link Device Error (tpl_polling.py:run:118): TP-Link Plug connection failed with ([Errno 57] Socket is not connected)
TP-Link Device Error (tpl_polling.py:run:353): Error attempting to update TP-Link Plug: 'system'. Will try again in 10 seconds
TP-Link Device Error (tpl_polling.py:run:118): TP-Link Plug connection failed with ([Errno 57] Socket is not connected)
TP-Link Device Error (tpl_polling.py:run:353): Error attempting to update TP-Link Plug: 'system'. Will try again in 10 seconds
TP-Link Device Error (tpl_polling.py:run:348): Unable to update TP-Link Plug: after 10 attempts. Polling for this device will now shut down. ('power_mw')


Jun 1, 2021 at 7:20:54 AM
Stopping plugin TP-Link Devices (pid 13263)
Stopped plugin TP-Link Devices
Upgrading plugin TP-Link Devices to newer version 0.9.5 (previous version moved to trash)
Loading plugin "TP-Link Devices 0.9.5"
Starting plugin "TP-Link Devices 0.9.5" (pid 13290)
TP-Link Devices Log level set to info
Started plugin "TP-Link Devices 0.9.5"
TP-Link Devices Polling started for TP-Link Plug@10.0.1.16.
TP-Link Devices Error (tpl_relay_poll.py:run:316): Error attempting to update TP-Link Plug: 'power_mw'. Will try again in 10 seconds
TP-Link Devices Error (tpl_relay_poll.py:run:316): Error attempting to update TP-Link Plug: 'power_mw'. Will try again in 10 seconds
TP-Link Devices Error (tpl_relay_poll.py:run:316): Error attempting to update TP-Link Plug: 'power_mw'. Will try again in 10 seconds
TP-Link Devices Error (tpl_relay_poll.py:run:316): Error attempting to update TP-Link Plug: 'power_mw'. Will try again in 10 seconds
TP-Link Devices Error (tpl_relay_poll.py:run:316): Error attempting to update TP-Link Plug: 'power_mw'. Will try again in 10 seconds
TP-Link Devices Error (tpl_relay_poll.py:run:316): Error attempting to update TP-Link Plug: 'power_mw'. Will try again in 10 seconds
TP-Link Devices Error (tpl_relay_poll.py:run:316): Error attempting to update TP-Link Plug: 'power_mw'. Will try again in 10 seconds
TP-Link Devices Error (tpl_relay_poll.py:run:316): Error attempting to update TP-Link Plug: 'power_mw'. Will try again in 10 seconds
TP-Link Devices Error (tpl_relay_poll.py:run:316): Error attempting to update TP-Link Plug: 'power_mw'. Will try again in 10 seconds
TP-Link Devices Error (tpl_relay_poll.py:run:316): Error attempting to update TP-Link Plug: 'power_mw'. Will try again in 10 seconds
TP-Link Devices Error (tpl_relay_poll.py:run:311): Unable to update TP-Link Plug: after 10 attempts. Polling for this device will now shut down. ('power_mw')
TP-Link Devices Polling stopped for TP-Link Plug@10.0.1.16.


Jun 1, 2021 at 7:23:38 AM
Stopping plugin TP-Link Devices (pid 13290)
Stopped plugin TP-Link Devices
Upgrading plugin TP-Link Devices to newer version 0.9.6 (previous version moved to trash)
Loading plugin "TP-Link Devices 0.9.6"
Starting plugin "TP-Link Devices 0.9.6" (pid 13316)
TP-Link Devices Log level set to info
Started plugin "TP-Link Devices 0.9.6"
TP-Link Devices Polling started for TP-Link Plug@10.0.1.16.
TP-Link Devices Error (tpl_relay_poll.py:run:322): Error attempting to update TP-Link Plug: 'power_mw'. Will try again in 10 seconds
TP-Link Devices Error (tpl_relay_poll.py:run:322): Error attempting to update TP-Link Plug: 'power_mw'. Will try again in 10 seconds
TP-Link Devices Error (tpl_relay_poll.py:run:322): Error attempting to update TP-Link Plug: 'power_mw'. Will try again in 10 seconds
TP-Link Devices Error (tpl_relay_poll.py:run:322): Error attempting to update TP-Link Plug: 'power_mw'. Will try again in 10 seconds
TP-Link Devices Error (tpl_relay_poll.py:run:322): Error attempting to update TP-Link Plug: 'power_mw'. Will try again in 10 seconds
TP-Link Devices Error (tpl_relay_poll.py:run:322): Error attempting to update TP-Link Plug: 'power_mw'. Will try again in 10 seconds
TP-Link Devices Error (tpl_relay_poll.py:run:322): Error attempting to update TP-Link Plug: 'power_mw'. Will try again in 10 seconds
TP-Link Devices Error (tpl_relay_poll.py:run:322): Error attempting to update TP-Link Plug: 'power_mw'. Will try again in 10 seconds
TP-Link Devices Error (tpl_relay_poll.py:run:322): Error attempting to update TP-Link Plug: 'power_mw'. Will try again in 10 seconds
TP-Link Devices Error (tpl_relay_poll.py:run:322): Error attempting to update TP-Link Plug: 'power_mw'. Will try again in 10 seconds
TP-Link Devices Error (tpl_relay_poll.py:run:317): Unable to update TP-Link Plug: after 10 attempts. Polling for this device will now shut down. ('power_mw')
TP-Link Devices Polling stopped for TP-Link Plug@10.0.1.16.

Reverted back to 0.2.0 and all is fine...

Posted on
Tue Jun 01, 2021 8:46 am
jtburgess offline
User avatar
Posts: 65
Joined: Jan 17, 2018
Location: NJ

Re: TP-Link Plugin v 0.9.3

Thanks. Something is wrong with the polling.
I’ll take a look and get back to you. ... but I can’t get to it until Thursday.

— john

Posted on
Fri Jun 04, 2021 11:18 am
jtburgess offline
User avatar
Posts: 65
Joined: Jan 17, 2018
Location: NJ

Re: TP-Link Plugin v 0.9.3

The reason 0.2.0 works is that there is no polling.
[Polling is used to detect state changes outside of indigo, e.g. you turned the device on/off by hand, and monitor energy usage.]

You're triggering the same python exception in all newer versions, something about "power_mw" which is one of the energy monitoring attributes.

My guess is that there is some attribute missing from the device state as it was created in 0.2.0.
Or you're trying to monitor energy usage, but the device doesn't actually support that feature.

Please try deleting your device and re-adding it after installing the latest update.
Since no-one else has reported this error, that adds to my suspicion.

Thanks, John

Posted on
Thu Jun 24, 2021 10:54 am
vtmikel offline
Posts: 549
Joined: Aug 31, 2012
Location: Boston, MA

Re: TP-Link Plugin v 0.9.3

John,

Any chance the plugin could support the KL430 LED lights?

I have mine working with Indigo but with a fair amount of hackery.

Mike

Posted on
Fri Jul 09, 2021 4:18 pm
changeagent offline
User avatar
Posts: 15
Joined: Aug 26, 2015

Re: TP-Link Plugin v 0.9.3

That worked! Thank You...

Posted on
Thu Oct 14, 2021 10:08 am
jenwill1 offline
Posts: 158
Joined: Mar 22, 2009
Location: Boerne, Texas

Re: TP-Link Plugin v 0.9.3

I bought a KP400 to use to control an outdoor fountain. I tried to load 0.9.3 on me Indigo v 2021.1 server and it booted Indigo v 7.5 software/server. Is 0.9.3 compatible with v 2021.1 ?

Thanks and look forward to using the plugin.

Will

Posted on
Thu Oct 14, 2021 11:02 am
jtburgess offline
User avatar
Posts: 65
Joined: Jan 17, 2018
Location: NJ

Re: TP-Link Plugin v 0.9.3

It should be, but you should install the latest version, 0.9.8, which I AM using on v2021.1

-- John

Posted on
Thu Oct 14, 2021 11:18 am
jay (support) offline
Site Admin
User avatar
Posts: 17040
Joined: Mar 19, 2008
Location: Austin, Texas

Re: TP-Link Plugin v 0.9.3

The problem is that Big Sur sometimes doesn't do file associations correctly, so rather than use the most recently installed app to open a file (in this case, the plugin), it sometimes launches an older version. The easiest fix is to delete the prior Indigo install (in your case 7.5).

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Thu Oct 14, 2021 3:01 pm
jenwill1 offline
Posts: 158
Joined: Mar 22, 2009
Location: Boerne, Texas

Re: TP-Link Plugin v 0.9.3

That did it, installed 0.9.8. Thanks for the help.

I had to delete all prior versions in the applications folder.

Appreciate the quick response !

Will

Posted on
Mon Oct 18, 2021 9:23 am
jenwill1 offline
Posts: 158
Joined: Mar 22, 2009
Location: Boerne, Texas

Re: TP-Link Plugin v 0.9.3

I received the KP400 yesterday. Breeze to setup. Am using the Indigo to schedule and Apple Bridge to have Siri/Homekit control as well instead of Google/Alexa that comes with their app. Thanks for the plugin !

Will

Who is online

Users browsing this forum: No registered users and 1 guest

cron