Unable to update plugins

Posted on
Sun Feb 13, 2022 12:33 pm
Turribeach offline
Posts: 366
Joined: Feb 06, 2015
Location: London, UK

Unable to update plugins

Hi,

Trying to update some plugins and I get the following error message when I try to double click on them:
Code: Select all
Local Indigo Server needed for this file, folder, or functionality.
Try using the client application installed on the same computer as the server.

image.png
image.png (28.98 KiB) Viewed 478 times


However I am running Indigo client and Server on the same Mac I am trying to install the plugin. I am on MacOs Monterrey 12.2 (21D49) and Indigo 2021.2. Any ideas?

Posted on
Sun Feb 13, 2022 12:58 pm
cuhouse offline
Posts: 103
Joined: Feb 21, 2007
Location: Virginia, USA

Re: Unable to update plugins

Turribeach wrote:
Hi,

Trying to update some plugins and I get the following error message when I try to double click on them:
Code: Select all
Local Indigo Server needed for this file, folder, or functionality.
Try using the client application installed on the same computer as the server.

image.png


However I am running Indigo client and Server on the same Mac I am trying to install the plugin. I am on MacOs Monterrey 12.2 (21D49) and Indigo 2021.2. Any ideas?


I get this same thing after a recent upgrade to Big Sur. You probably also cannot Show the Event Logs Folder?
I have not investigated why it does this but it happens after initial boot and Indigo Server (IS) automatically starts. My work around is to start/stop IS manually after the machine boots.

Hope it works for you.

Indigo 2021.2, Big Sur v11.6.2 , Dedicated late 2014 Mac Mini, PowerLinc 2413U.

Posted on
Sun Feb 13, 2022 1:08 pm
Turribeach offline
Posts: 366
Joined: Feb 06, 2015
Location: London, UK

Re: Unable to update plugins

Thanks! That indeed works around the problem. Jay/Matt any idea how to permanently fix this problem? Not the most critical thing IF you know the work around.

Posted on
Sun Feb 13, 2022 2:08 pm
matt (support) offline
Site Admin
User avatar
Posts: 20964
Joined: Jan 27, 2003
Location: Texas

Re: Unable to update plugins

I'm not sure what is causing this specifically but we'll add it to our bug list to investigate.

Image

Posted on
Sun Feb 13, 2022 2:54 pm
Turribeach offline
Posts: 366
Joined: Feb 06, 2015
Location: London, UK

Re: Unable to update plugins

Just did a reboot to check if I could open the logs and the issue didn't happen. It seems to happen only if you launch the Indigo Client quickly after a boot. I don't have Indigo set to launch at login and it didn't happen for me when I opened it for the first time a few minutes after a reboot.

Posted on
Sun Apr 17, 2022 10:50 am
daveHawk offline
Posts: 27
Joined: Feb 11, 2017

Re: Unable to update plugins

I just upgraded from 7.5 to 2021.2, and cannot upgrade any plugins on the new version. I get an error message as shown below. Consequently the following happens:
1) I get a popup "Server Connection Status" with the standard "Start Local Server" "Connect To Remote Server" options.
2) Clicking on the top portion of the popup, the Mac menu bar displays "Indigo 7.5".
3) Indigo 2021.2 is still running - Mac menu bar confirms this and the new Alexa builtin is shown as part of the plugin choices (I only mention this to confirm that 2021.2 is active).
4) Back to item 1), Server Connection Status: Choosing "Start Local Server" brings up dialogue for Starting/Stoping Local server - the only clickable option is Stop or Cancel - it is the dialouge/popuup for 2021.2.
5) At this point it is mess and I often have to individually kill Indigo processes.

I removed the 2021.2 version and invoked version 7.5; and upgraded some of the plugins within 7.5. I quit 7.5 and then reinstalled 2021.2. I then started 2021.2, and found that the plugins that I upgraded under 7.5, no longer showed that an upgrade was needed, and indeed they operated properly. However, I still had the same problem under 2021.2, in that I could not upgrade the remainig plugins! Does anyone have an idea as to how I can approach this?

Thanks in advance

MacOS Big Sur 11.6
Mac mini 2018 Intel
Attachments
Plugin Update Error.png
Plugin Update Error.png (110.99 KiB) Viewed 192 times

Posted on
Sun Apr 17, 2022 10:58 am
FlyingDiver offline
User avatar
Posts: 5913
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Unable to update plugins

When you go to install the updated plugin, don't double click. Right click and select the correct version of Indigo for the "open with". This is a bug in MacOS that doesn't open the latest version of the application.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Sun Apr 17, 2022 2:12 pm
daveHawk offline
Posts: 27
Joined: Feb 11, 2017

Re: Unable to update plugins (SOLVED)

FlyingDiver,

That fixed it! I don't think I would have ever figured that one out! I can't thank you enough, I spent a lot of time on this problem - you provided a solution in a matter of minutes.

Thanks again.

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest