Indigo 7.4 plugins stopping after a few weeks?

Posted on
Wed Dec 18, 2019 11:54 am
palantir offline
Posts: 69
Joined: Sep 24, 2014

Indigo 7.4 plugins stopping after a few weeks?

Folks,

Does anyone have to cycle their IndigoServer 7.4 every 2-3 weeks?

I have been running Indigo from version 6.1 and never experienced issues with long-term reliability. Since upgrading to 7.4 however, I do need to stop/start my IndigoServer app every 2-3 weeks. I noticed this the first time when I went on holidays for 2 weeks, and my camera alerts (monitoring my front door with SecuritySpy -> Indigo -> PushOver alerts to my phone) had stopped. I no longer was able to remotely access my IndigoServer ("reflector down" message), I could open a VPN session to my house but not access the IndigoServer directly via that route.

I have been studying this more carefully now, and a preliminary conclusion is that after 2-3 weeks, SecuritySpy motion alerts no longer end up in Indigo.

The motion alerts not arriving could be due to SecuritySpy itself, the SecuritySpy plugin, or something in IndigoServer.
Looking further:
- The SecuritySpy app seems to work fine. I can use it, it is recording on Motion and I can see the clips
- Reloading the SecuritySpy plugin in Indigo does not resolve things
- The reflector stopped working, indicating another problem that the SecuritySpy route
- Stopping and Starting the IndigoServer puts things back to normal.

In ActivityMonitor, My OS-X does not show any obvious abnormalities (not low on memory, no high CPU processes etc).

So now I'm a little lost for options where to look next. Is there anyone else who is experiencing similar issues, or any suggestions where to look next?

Many thanks,
Ronald

Posted on
Wed Dec 18, 2019 12:31 pm
jay (support) offline
Site Admin
User avatar
Posts: 16212
Joined: Mar 19, 2008
Location: Austin, Texas

Re: Indigo 7.4 plugins stopping after a few weeks?

No - my production Mac never needs rebooting (nor the Indigo Server bounced) unless I'm updating it:

Code: Select all
APPLEs-Mac-mini:~ admin$ uptime
12:26  up 37 days,  1:44, 2 users, load averages: 3.22 2.94 2.80



And 37 days ago I had to rearrange my computer closet or it would have been approximately twice that long (since I updated to the final 7.4 sometime in early October).

I'm not running Security Spy however. At the time of the incident, did you check Activity Monitor to see if there was any unusual CPU and/or High Memory usage? When you upgraded to 7.4, did you also upgrade macOS versions?

What else did you try when it was in that state (you say the Reflector didn't work, but what else did or did not work)? Schedules? Triggers? Local connections via Indigo Touch (both iOS and Web)?

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Wed Dec 18, 2019 4:32 pm
palantir offline
Posts: 69
Joined: Sep 24, 2014

Re: Indigo 7.4 plugins stopping after a few weeks?

I know, Jay. My experience with Indigo has been outstanding ever since the beginning. Not in the least with its stability. I am in no way pointing any fingers.

jay (support) wrote:
At the time of the incident, did you check Activity Monitor to see if there was any unusual CPU and/or High Memory usage?
RV> Yes I did. Noting abnormal showing. Plenty of memory, CPU normal levels. Mac was responsive in general

When you upgraded to 7.4, did you also upgrade macOS versions?
RV> No. I am running an older MacMini with OS-X HighSierra 10.13.6. Have been running this for ages...

What else did you try when it was in that state (you say the Reflector didn't work, but what else did or did not work)? Schedules? Triggers? Local connections via Indigo Touch (both iOS and Web)?
RV> I'll do a bit more structured trouble-shooting when it happens again. That first time (after being away for 18 days), I could not access my IndigoServer at all. Ping to the server worked. ScreenSharing worked. Indigo client from a remote Mac did not, Indigo client from the server itself did not connect. I don't remember if the iPad was showing my homescreen. The schedules seemed to still be active as the lights were in their expected state when I arrived home, but I cannot be 100% certain of it (they could have been on for days already without me noticing it).

This initial time I somewhat ignored it, given that I just got back home. Shortly thereafter, I realized that my motion notifications stopped working. At that time I could still access the IndigoServer and I cycled the PushOver and SecuritySpy plugins. I then started paying more attention and yesterday the same happened for the third time. Everything seems to work as usual, but I got no triggers from SecuritySpy, and therefore no messages from PushOver, hence my post here.


I have a general suspicion that my plugins start failing one after the other but I could be wrong. Need to do more troubleshooting next time it happens. For now, thanks for your quick response!
Ronald

Posted on
Wed Dec 18, 2019 4:54 pm
jay (support) offline
Site Admin
User avatar
Posts: 16212
Joined: Mar 19, 2008
Location: Austin, Texas

Re: Indigo 7.4 plugins stopping after a few weeks?

We try to isolate plugins as much as possible, but a misbehaving plugin can cause issues. If it happens again and there is a plugin causing trouble, it should show up in the event log. In fact, you might look through your prior log files on the days where it was failing to see what kind of errors were being generated.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Thu Dec 19, 2019 10:22 am
palantir offline
Posts: 69
Joined: Sep 24, 2014

Re: Indigo 7.4 plugins stopping after a few weeks?

Thanks Jay. I'll do that for sure in the coming days!
Ronald

Posted on
Sun Mar 22, 2020 1:57 am
palantir offline
Posts: 69
Joined: Sep 24, 2014

Re: Indigo 7.4 plugins stopping after a few weeks?

So, a similar situation happened again last night at midnight.

Last night, suddenly my reflector no longer worked:
Code: Select all
22 Mar 2020 at 00:01:00
   Deleted old log file "2020-02-22 Events.txt"
   Created new log file (Indigo Server version 7.4.1)
   Schedule                        Weekend

22 Mar 2020 at 00:01:36
   Error                           reflector connection test failed: local server unreachable
   Error                           reflector reconnection scheduled in 5 seconds

22 Mar 2020 at 00:02:11
   Error                           failed to create reflector connection: local server unreachable
   Error                           check your Firewall and Network configurations and try restarting the server
   Error                           reflector reconnection scheduled in 15 minutes



And I now see that error in my logging every 15 minutes. Obviously, my iPads no longer show my control pages. Connecting to a control page (http://192.168.20.30:8176/controlpage?name=Home), from a local webbrowser via the "Show in Browser"button in the Control Pages interface also does not work.

Further checking shows the following:
- IndigoServer has been running for over 29 days (ps -ax -o etime,command -c | grep IndigoServer gives 29-08:35:31).
- No extreme memory or CPU usage in ActivityMonitor
- I've been digging through the Mac OS-X console logging. Lots of messages there but nothing that stands out (to me)...

However: SecuritySpy plugin did not notify Indigo of motion detection anymore. (through a trigger "Cynical SecuritySpy Event - Camera Motion")
So, I reloaded the SecuritySpy plugin, and then motion signalling functioned properly again. This however did not bring the Indigo Touch functionality back.

[UPDATE]
Further testing showed an issue with the PushOver plugin (v1.5.3). When trying to edit the Pushover action in my Motion trigger action, I got the following error:
Code: Select all
   Error (client)                  getConfigUiValuesFromPlugin2() caught exception: PacketTargetNotConnectedError -- plugin Pushover is not enabled
   Error (client)                  getXmlFromPlugin() caught exception: PacketTargetNotConnectedError -- plugin Pushover is not enabled
   Error (client)                  dialogForActionId() caught exception: NSInvalidArgumentException -- *** -[__NSPlaceholderDictionary initWithObjects:forKeys:count:]: attempt to insert nil object from objects[0]


The Pushover plugin WAS enabled though. So I reloaded it and now Pushover works normal again. Traffic to port 8176 still down though.

In summary (not necessarily in this order):
- SecuritySpy plugin stopped working
- Pushover plugin stopped working
- Connections to http://<my-internal-ip-address>:8176 stopped working
- All other functions seem to work fine.

@Jay:
In my set-up, Indigo gets a trigger from SecuritySpy that there is motion in my hallway. The action then is to send a pushover message to my phone.
Could it be that a failing Pushover notification causes an unfinished trigger action, and then the multiple unfinished trigger actions (all initiated by a SecuritySpy trigger) cause SecuritySpy to run low on resources, which eventually also impacts the built-in Indigo webserver? If this is a theoretical possibility, is there any way to debug this?

As per your earlier suggestion, I scanned my logfiles specifically for Pushover errors. I keep mine for 30 days, and there is not a single Pushover log message in any file, so the problem may have been around for a long time already. I have now increased the days to retain logfiles to 90.

Restarted my Indigo server now and things returned to normal. Would appreciate any suggestions for further trouble-shooting...
Ronald

Posted on
Mon Mar 23, 2020 2:04 pm
matt (support) offline
Site Admin
User avatar
Posts: 19964
Joined: Jan 27, 2003
Location: Texas

Re: Indigo 7.4 plugins stopping after a few weeks?

Is there anything earlier in the Event Log (so from March 21st) showing errors or problems? macOS sleep notifications? Anything at all out-of-the-ordinary?

It looks like Indigo WebServer isn't running, and maybe the plugins have stopped as well. Having a single plugin (or rarely the Web Server) crash can happen but I've never seen multiple plugins and the Web server all stop or crash like this. To see what is running the next time the problem surfaces from Terminal do:

Code: Select all
ps -ax | grep ndigo

An example result showing the Indigo Server, Web Server, several plugins running., and the Indigo reflector tunnel (ssh):

Code: Select all
  446 ??        23:27.15 /Library/Application Support/Perceptive Automation/Indigo 7.4/IndigoServer.app/Contents/MacOS/IndigoServer
  456 ??        39:03.99 /Library/Application Support/Perceptive Automation/Indigo 7.4/IndigoPluginHost.app/Contents/MacOS/IndigoPluginHost -p1176 -f.Z-Wave.indigoPlugin
  457 ??        14:33.75 /Library/Application Support/Perceptive Automation/Indigo 7.4/IndigoPluginHost.app/Contents/MacOS/IndigoPluginHost -p1176 -f.INSTEON Commands.indigoPlugin
  458 ??        16:02.17 /Library/Application Support/Perceptive Automation/Indigo 7.4/IndigoPluginHost.app/Contents/MacOS/IndigoPluginHost -p1176 -f.Action Collection.indigoPlugin
  459 ??        13:44.05 /Library/Application Support/Perceptive Automation/Indigo 7.4/IndigoPluginHost.app/Contents/MacOS/IndigoPluginHost -p1176 -fNOAA Weather.indigoPlugin
  460 ??        15:11.42 /Library/Application Support/Perceptive Automation/Indigo 7.4/IndigoPluginHost.app/Contents/MacOS/IndigoPluginHost -p1176 -fiTunes.indigoPlugin
  461 ??        15:05.59 /Library/Application Support/Perceptive Automation/Indigo 7.4/IndigoPluginHost.app/Contents/MacOS/IndigoPluginHost -p1176 -fCynical SecuritySpy.indigoPlugin
  462 ??        15:01.04 /Library/Application Support/Perceptive Automation/Indigo 7.4/IndigoPluginHost.app/Contents/MacOS/IndigoPluginHost -p1176 -findigo pushover.indigoPlugin
  463 ??        21:30.44 python /Library/Application Support/Perceptive Automation/Indigo 7.4/IndigoWebServer/IndigoWebServer.py -i1176 -w8012 -cfn
  478 ??        14:48.34 /Library/Application Support/Perceptive Automation/Indigo 7.4/IndigoPluginHost.app/Contents/MacOS/IndigoPluginHost -p1176 -e_background_nonblocking_
26144 ??         0:00.57 ssh -N -F/Library/Application Support/Perceptive Automation/Indigo 7.4/Preferences/PrismReflector/ssh_config_indigo_v4 -R1234:127.0.0.1:8012 prism@xyz.xyz.xyz.xyz


Your pushover notifications or actions shouldn't be able to impact other plugins or Indigo's Web Server, but at some point here you'll probably just have to start disabling plugins or functionality (SecuritySpy, although note I use it and it has been rock solid for me), etc., just to try to narrow down what might be causing (or at least initiating) the problem. I'm pretty puzzled by this one.

Image

Posted on
Sat Mar 28, 2020 3:28 pm
palantir offline
Posts: 69
Joined: Sep 24, 2014

Re: Indigo 7.4 plugins stopping after a few weeks?

Thanks Matt. Nothing showing in the error logs...

I have taken a sample of the currently running processes. I'll monitor this carefully and next time it happens, I'll take another sample, compare them and report back if I discover anything.

Cheers,
Ronald

Posted on
Mon May 18, 2020 6:28 am
palantir offline
Posts: 69
Joined: Sep 24, 2014

Re: Indigo 7.4 plugins stopping after a few weeks?

Matt,

One hour again, my system showed the same behavior again. There are no error messages whatsoever in the logging, other than then same:

Code: Select all
18 May 2020 at 12:50:45
   Error                           reflector connection test failed: local server unreachable
   Error                           reflector reconnection scheduled in 5 seconds

18 May 2020 at 12:51:20
   Error                           failed to create reflector connection: local server unreachable
   Error                           check your Firewall and Network configurations and try restarting the server
   Error                           reflector reconnection scheduled in 15 minutes


As I wrote last time, I took a snapshot of the running processes in an ok situation. I have done the same just now. 2 processes are missing which definitely should be running:
Code: Select all
  514 ??         0:00.85 ssh -N -F/Library/Application Support/Perceptive Automation/Indigo 7.4/Preferences/PrismReflector/ssh_config_indigo_v4 -R1234:127.0.0.1:8176 prism@166.78.9.120
  776 ??        27:20.96 /Library/Application Support/Perceptive Automation/Indigo 7.4/Plugins/Grafana Home Dashboard.indigoPlugin/Contents/Server Plugin/servers/influxdb/influxd run -config /Library/Application Support/Perceptive Automation/Indigo 7.4/Plugins/Grafana Home Dashboard.indigoPlugin/Contents/Server Plugin/servers/influxdb/influxdb.conf

So that's the reflector and also the Grafana plugin. And indeed, the reflector does not work and neither does my Grafana dashboard (everything else seems to continue to work fine btw). The question now is if the Grafana packages could have killed the reflector, or the other way around... Any thoughts on this?

[EDIT]
After reloading the Grafana plug-in, this part came back alive again.
I did also attempt to run the command "ssh -N -F "/Library... etc" but that did not resolve things. Is there a way to reload only the reflector service?

I will now restart my server. If you have any suggestions to debug this further the next time it happens, I'd appreciate it!

Many thanks,
Ronald

Posted on
Mon May 18, 2020 3:47 pm
matt (support) offline
Site Admin
User avatar
Posts: 19964
Joined: Jan 27, 2003
Location: Texas

Re: Indigo 7.4 plugins stopping after a few weeks?

Hi Ronald,

Is this:

Code: Select all
  514 ??         0:00.85 ssh -N -F/Library/Application Support/Perceptive Automation/Indigo 7.4/Preferences/PrismReflector/ssh_config_indigo_v4 -R1234:127.0.0.1:8176 prism@166.78.9.120
  776 ??        27:20.96 /Library/Application Support/Perceptive Automation/Indigo 7.4/Plugins/Grafana Home Dashboard.indigoPlugin/Contents/Server Plugin/servers/influxdb/influxd run -config /Library/Application Support/Perceptive Automation/Indigo 7.4/Plugins/Grafana Home Dashboard.indigoPlugin/Contents/Server Plugin/servers/influxdb/influxdb.conf

the result of the specific command I mentioned above to run when you saw the problem?

Code: Select all
ps -ax | grep ndigo

If so, then it looks like the Indigo Server itself isn't even running (nor the Indigo Web Server). Was that the case? If so there should have been a crash report written.

If you didn't run that command then please do so the next time the problem occurs. It is how I can tell if the Indigo Web Server is running or not.

Or are you saying the above are the two processes were the only two that had disappeared from your base case? I'd really like to see the full results of the command. If there are specific plugins you want to mask out that is fine, but I'm wanting to see if the web server is running or not.

Image

Posted on
Mon May 18, 2020 3:55 pm
palantir offline
Posts: 69
Joined: Sep 24, 2014

Re: Indigo 7.4 plugins stopping after a few weeks?

Sorry for being unclear Matt. Yes, I did a ps -ax indeed. I did one a few weeks ago, and did one today. I then compared the two, line by line. The two lines I reported today are the two lines missing from today’s output, meaning that these two processes are no longer running.

This is the full result from today's ps-ax:
Code: Select all
[14:06:34] ronald@macmini:~$ps -ax | grep ndigo
  723 ??       609:43.66 /Library/Application Support/Perceptive Automation/Indigo 7.4/IndigoServer.app/Contents/MacOS/IndigoServer
  745 ??        47:54.66 /Library/Application Support/Perceptive Automation/Indigo 7.4/IndigoPluginHost.app/Contents/MacOS/IndigoPluginHost -p1176 -fVirtual Devices.indigoPlugin
  747 ??        30:13.99 /Library/Application Support/Perceptive Automation/Indigo 7.4/IndigoPluginHost.app/Contents/MacOS/IndigoPluginHost -p1176 -f.Action Collection.indigoPlugin
  749 ??       353:23.26 python /Library/Application Support/Perceptive Automation/Indigo 7.4/IndigoWebServer/IndigoWebServer.py -i1176 -w8176 -cfn
  762 ??        36:12.41 /Library/Application Support/Perceptive Automation/Indigo 7.4/IndigoPluginHost.app/Contents/MacOS/IndigoPluginHost -p1176 -ffantasticWeather.indigoPlugin
  764 ??        27:41.51 /Library/Application Support/Perceptive Automation/Indigo 7.4/IndigoPluginHost.app/Contents/MacOS/IndigoPluginHost -p1176 -fPushover.indigoPlugin
  765 ??       422:30.04 /Library/Application Support/Perceptive Automation/Indigo 7.4/IndigoPluginHost.app/Contents/MacOS/IndigoPluginHost -p1176 -fSonos.indigoPlugin
  766 ??        94:05.74 /Library/Application Support/Perceptive Automation/Indigo 7.4/IndigoPluginHost.app/Contents/MacOS/IndigoPluginHost -p1176 -fEPS Scene Toggle.indigoPlugin
  767 ??        24:08.71 /Library/Application Support/Perceptive Automation/Indigo 7.4/IndigoPluginHost.app/Contents/MacOS/IndigoPluginHost -p1176 -fSecuritySpy Image Downloader.indigoPlugin
  768 ??        74:10.26 /Library/Application Support/Perceptive Automation/Indigo 7.4/IndigoPluginHost.app/Contents/MacOS/IndigoPluginHost -p1176 -fGroup-Trigger.indigoPlugin
  769 ??        27:00.18 /Library/Application Support/Perceptive Automation/Indigo 7.4/IndigoPluginHost.app/Contents/MacOS/IndigoPluginHost -p1176 -fCynical SecuritySpy.indigoPlugin
  770 ??        24:55.62 /Library/Application Support/Perceptive Automation/Indigo 7.4/IndigoPluginHost.app/Contents/MacOS/IndigoPluginHost -p1176 -fZwaveSceneController.indigoPlugin
  771 ??        35:31.14 /Library/Application Support/Perceptive Automation/Indigo 7.4/IndigoPluginHost.app/Contents/MacOS/IndigoPluginHost -p1176 -fBeacon.indigoPlugin
  772 ??        43:40.74 /Library/Application Support/Perceptive Automation/Indigo 7.4/IndigoPluginHost.app/Contents/MacOS/IndigoPluginHost -p1176 -fEPS Device Extensions.indigoPlugin
  773 ??        34:05.14 /Library/Application Support/Perceptive Automation/Indigo 7.4/IndigoPluginHost.app/Contents/MacOS/IndigoPluginHost -p1176 -fhomeAway.indigoPlugin
  774 ??        29:52.07 /Library/Application Support/Perceptive Automation/Indigo 7.4/IndigoPluginHost.app/Contents/MacOS/IndigoPluginHost -p1176 -fEPS Smart Dimmer.indigoPlugin
  775 ??        45:02.71 /Library/Application Support/Perceptive Automation/Indigo 7.4/IndigoPluginHost.app/Contents/MacOS/IndigoPluginHost -p1176 -fGroup Change Listener.indigoPlugin
  776 ??       530:38.29 /Library/Application Support/Perceptive Automation/Indigo 7.4/IndigoPluginHost.app/Contents/MacOS/IndigoPluginHost -p1176 -fGrafana Home Dashboard.indigoPlugin
  826 ??        26:20.70 /Library/Application Support/Perceptive Automation/Indigo 7.4/IndigoPluginHost.app/Contents/MacOS/IndigoPluginHost -p1176 -e_background_nonblocking_
 3470 ??         3:06.09 /usr/bin/expect /Library/Application Support/Perceptive Automation/Indigo 7.4/Plugins/uniFiAP.indigoPlugin/Contents/Server Plugin/dictLoop.exp admin <pw_made_invisible> 192.168.20.11 US.v xxxThisIsTheEndTokenxxx 60 10 mca-dump | sed -e 's/^ *//' doNotSendAliveMessage
 3786 ??         2:53.96 /usr/bin/expect /Library/Application Support/Perceptive Automation/Indigo 7.4/Plugins/uniFiAP.indigoPlugin/Contents/Server Plugin/dictLoop.exp admin <pw_made_invisible> 192.168.20.12 US.v xxxThisIsTheEndTokenxxx 60 10 mca-dump | sed -e 's/^ *//' doNotSendAliveMessage
11526 ??        24:58.07 /Library/Application Support/Perceptive Automation/Indigo 7.4/IndigoPluginHost.app/Contents/MacOS/IndigoPluginHost -p1176 -fLEDeffects.indigoPlugin
33981 ??         0:01.64 /usr/bin/expect /Library/Application Support/Perceptive Automation/Indigo 7.4/Plugins/uniFiAP.indigoPlugin/Contents/Server Plugin/execLog.exp admin <pw_made_invisible> 192.168.20.15 BZ.v /usr/bin/tail -F /var/log/messages
36616 ??         0:01.28 /usr/bin/expect /Library/Application Support/Perceptive Automation/Indigo 7.4/Plugins/uniFiAP.indigoPlugin/Contents/Server Plugin/execLog.exp admin <pw_made_invisible> 192.168.20.16 BZ.v /usr/bin/tail -F /var/log/messages
37463 ??        85:53.09 /Library/Application Support/Perceptive Automation/Indigo 7.4/IndigoPluginHost.app/Contents/MacOS/IndigoPluginHost -p1176 -f.Z-Wave.indigoPlugin
70466 ??         0:21.60 /usr/bin/expect /Library/Application Support/Perceptive Automation/Indigo 7.4/Plugins/uniFiAP.indigoPlugin/Contents/Server Plugin/dictLoop.exp admin <pw_made_invisible> 192.168.20.16 BZ.v xxxThisIsTheEndTokenxxx 60 10 mca-dump | sed -e 's/^ *//' /var/log/messages
71474 ??        23:36.63 /Library/Application Support/Perceptive Automation/Indigo 7.4/IndigoPluginHost.app/Contents/MacOS/IndigoPluginHost -p1176 -fTesla Control.indigoPlugin
71779 ??       512:32.65 /Library/Application Support/Perceptive Automation/Indigo 7.4/IndigoPluginHost.app/Contents/MacOS/IndigoPluginHost -p1176 -funiFiAP.indigoPlugin
72344 ??         0:25.51 /usr/bin/expect /Library/Application Support/Perceptive Automation/Indigo 7.4/Plugins/uniFiAP.indigoPlugin/Contents/Server Plugin/dictLoop.exp admin <pw_made_invisible> 192.168.20.15 BZ.v xxxThisIsTheEndTokenxxx 60 10 mca-dump | sed -e 's/^ *//' /var/log/messages
86424 ??         3:49.96 /Library/Application Support/Perceptive Automation/Indigo 7.4/Plugins/Grafana Home Dashboard.indigoPlugin/Contents/Server Plugin/servers/grafana/grafana-server -homepath /Library/Application Support/Perceptive Automation/Indigo 7.4/Plugins/Grafana Home Dashboard.indigoPlugin/Contents/Server Plugin/servers/grafana/ -config /Library/Application Support/Perceptive Automation/Indigo 7.4/Plugins/Grafana Home Dashboard.indigoPlugin/Contents/Server Plugin/servers/grafana/conf/indigo.ini
77779 ttys006    0:00.00 grep ndigo


Does this tell you anyting?

Thanks,
Ronald

Posted on
Wed May 20, 2020 6:58 pm
matt (support) offline
Site Admin
User avatar
Posts: 19964
Joined: Jan 27, 2003
Location: Texas

Re: Indigo 7.4 plugins stopping after a few weeks?

Hi Ronald,

This line is the one I was interested in:
palantir wrote:
749 ?? 353:23.26 python /Library/Application Support/Perceptive Automation/Indigo 7.4/IndigoWebServer/IndigoWebServer.py -i1176 -w8176 -cfn

It is interesting since above you indicated that you could not access Indigo's Web Server (on port 8176). We've had a few reports of that process crashing, which will bring down the Web server and then cause the reflector to fail. However, it looks like in your case that isn't the issue – the Web server is still running. I'd expect you to be able to access it. The next time it happens try the following URL on the Indigo Server Mac itself to see if it works:

http://127.0.0.1:8176

Another thing that might help would be to kill Indigo's web server (in above case that would be killing PID 749), then from the Terminal relaunch it with the following command:

/Library/Application\ Support/Perceptive\ Automation/Indigo\ 7.4/IndigoWebServer/devhelpers/indigowebstart

Then leave the Terminal window open indefinitely. It will then provide more detailed logging information that will hopefully help to trace the source of the problem the next time it occurs. Also try the URL again after relaunching it on your Indigo Server Mac to verify if restarting the Web server helped or not.

Note the reflector process being gone would be expected if the Web server stops working for any reason. Indigo will periodically try to restart the reflector process (as shown in your Event Log snippets), but if it cannot connect to the Web server then the process will be very short lived.

Image

Posted on
Thu May 21, 2020 3:16 pm
palantir offline
Posts: 69
Joined: Sep 24, 2014

Re: Indigo 7.4 plugins stopping after a few weeks?

Thanks for your support on this Matt. Next time it happens I’ll go through these steps and keep a detailed record of my findings.

Cheers,
Ronald


Sent from my iPhone using Tapatalk

Posted on
Fri May 22, 2020 3:33 am
palantir offline
Posts: 69
Joined: Sep 24, 2014

Re: Indigo 7.4 plugins stopping after a few weeks?

Matt,

There may be something that is causing this that I just thought about and wanted to bounce off you.

On my main control page (very old iPad running iOS 9.3.5 - which cannot be updated anymore - and Indigo Touch 24x7) I am showing two video streams of the two camera's covering my front door. Those two images are there using a Refreshing image URL, refreshing every 4 seconds. The images is pulled from my SecuritySpy server which is hosted on the same ManMini as my Indigo server. This iPad is on my side-table, 24x7, resulting in at least 43200 calls per day to the webserver, just refreshing the video stream.

I regularly (every few days) see the iPad frozen, showing a popup that it cannot refresh the page anymore. I then kill Indigo Touch and restart it, almost without thinking. I always felt that my ancient iPad was still serving me well, thus accepting an occasional glitch...

Now that my other issues seem to be in some way related to the Webserver component: could there be a connection me killing Indigo Touch and the Webserver locking up? I can imagine that there could be some open/pending/hanging server-side processes, eventually leading to exhausted webserver resources ?

Curious what your expert opinion is of this!

As always: thanks for your continued support!
Ronald

Page 1 of 1

Who is online

Users browsing this forum: Google Feedfetcher and 2 guests

cron