7.0.x to 7.2.x Issue

Posted on
Sat Oct 06, 2018 7:07 pm
Colorado4Wheeler offline
User avatar
Posts: 2715
Joined: Jul 20, 2009
Location: Colorado

7.0.x to 7.2.x Issue

If I hadn't been installing a new Z-wave lock I would not have noticed this and my house security could had been compromised! Prior to 7.2 the action to lock my doors was Turn On/Turn Off, but after the 7.2 upgrade it broke every instance of that (of which there are many):

Screen Shot 2018-10-06 at 7.04.28 PM.png
Screen Shot 2018-10-06 at 7.04.28 PM.png (15.36 KiB) Viewed 387 times
Screen Shot 2018-10-06 at 7.04.41 PM.png
Screen Shot 2018-10-06 at 7.04.41 PM.png (26.54 KiB) Viewed 387 times


Maybe have some logic that says "if On/Off command for lock device, change to Lock/Unlock"? This issue was a quite disconcerting.

My Modest Contributions to Indigo:

HomeKit Bridge | Device Extensions | Security Manager | LCD Creator | Room-O-Matic | Smart Dimmer | Scene Toggle | Powermiser | Homebridge Buddy

Check Them Out Here

Posted on
Sat Oct 06, 2018 7:17 pm
lanbrown offline
Posts: 624
Joined: Sep 26, 2017

Re: 7.0.x to 7.2.x Issue

Out of curiosity, were these existing devices something that was on the release notes for added support under 7.2?

I did have a few devices I had to resync because they were added as supported in 7.2. I also had a few devices that were already supported and they had to be resynced as well. I have a bunch of GE/Jasco light switches; all the same firmware version and a few had to be resynced. In my case they were quite evident as they were greyed out in Indigo.

Posted on
Sun Oct 07, 2018 8:02 am
jay (support) offline
Site Admin
User avatar
Posts: 14669
Joined: Mar 19, 2008
Location: Austin, Texas

Re: 7.0.x to 7.2.x Issue

I'm confident that the 7.0->7.1 database migration logic did the right thing. We'll have to look to see if that logic got altered accidentally in 7.2.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Sun Oct 07, 2018 9:57 am
jay (support) offline
Site Admin
User avatar
Posts: 14669
Joined: Mar 19, 2008
Location: Austin, Texas

Re: 7.0.x to 7.2.x Issue

Are you sure? I think I was misremembering in my previous comment.

As far as I recall and can source from the documentation, Indigo 7.0 introduced native lock support and always had Lock/Unlock actions. I don't believe our official lock support ever allowed the use of the turn on/off UI actions, though if you were using a bridge device like the Vera those locks were presented as simple relay devices so turn on/off would have worked.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Sun Oct 07, 2018 11:46 am
Colorado4Wheeler offline
User avatar
Posts: 2715
Joined: Jul 20, 2009
Location: Colorado

Re: 7.0.x to 7.2.x Issue

I used On/Off for locks until I upgraded to 7.2. I know for a couple reasons, one is that I just remember doing it, second it's been working fine since lock support was introduced and third I recall thinking a couple months ago when I noticed the Lock/Unlock method that I needed to change all my locks to use that instead.

My Modest Contributions to Indigo:

HomeKit Bridge | Device Extensions | Security Manager | LCD Creator | Room-O-Matic | Smart Dimmer | Scene Toggle | Powermiser | Homebridge Buddy

Check Them Out Here

Posted on
Mon Oct 08, 2018 8:56 am
jay (support) offline
Site Admin
User avatar
Posts: 14669
Joined: Mar 19, 2008
Location: Austin, Texas

Re: 7.0.x to 7.2.x Issue

Hmmm - I just did a clean install of 7.0.4, pared down a database to just a few devices and a Z-Wave lock, and it doesn't show up on the Turn On action:

ss209.png
ss209.png (475.88 KiB) Viewed 237 times


I suppose it's possible that one of the early 7.0 betas used Turn On/Off, but I'm pretty sure that we never shipped a version that allowed that configuration.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Mon Oct 08, 2018 9:21 am
jay (support) offline
Site Admin
User avatar
Posts: 14669
Joined: Mar 19, 2008
Location: Austin, Texas

Re: 7.0.x to 7.2.x Issue

And just to make sure I wasn't jumping ahead to a change, here's the same test from 7.0.1 (the 7.0.0 release on our cloud downloads seems to deliver the 7.0.1 installer so I couldn't test 7.0.0, but I'm quite sure we didn't change the behavior in the 12 days between 7.0.0 and 7.0.1):

ss211.png
ss211.png (450.29 KiB) Viewed 230 times

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Mon Oct 08, 2018 10:04 am
Colorado4Wheeler offline
User avatar
Posts: 2715
Joined: Jul 20, 2009
Location: Colorado

Re: 7.0.x to 7.2.x Issue

Maybe it was beta, but I don't think I set up ALL of that during the beta cycle because I'm still finding places where I used On/Off to lock and unlock a lock which kind of tells me it must have been in place a while. I had a lot set up when Vera was the only way to get a lock working in Indigo and switched it over, but still the locks showed up there under On/Off.

Whatever, I'm not going to install old versions of Indigo to figure it out, I just know that I didn't see this until I upgraded to 7.2 and I was on 7.1.2 prior and it worked fine.

By the way, those DO still work, the On/Off still allow locking and unlocking but if I edit the record I'm forced to hand-change it to lock/unlock.

I suppose it doesn't really matter at this point, you are unable to reproduce the problem and nobody else has reported it so it's not a problem.

My Modest Contributions to Indigo:

HomeKit Bridge | Device Extensions | Security Manager | LCD Creator | Room-O-Matic | Smart Dimmer | Scene Toggle | Powermiser | Homebridge Buddy

Check Them Out Here

Posted on
Mon Oct 08, 2018 10:35 am
jay (support) offline
Site Admin
User avatar
Posts: 14669
Joined: Mar 19, 2008
Location: Austin, Texas

Re: 7.0.x to 7.2.x Issue

Colorado4Wheeler wrote:
By the way, those DO still work, the On/Off still allow locking and unlocking but if I edit the record I'm forced to hand-change it to lock/unlock.


Oh, ok - I thought all your actions were broken/not working given the urgency of your first post. The low-level command to control locks is (apparently) the same basic command that on/off devices use so they would continue to work. Here's my guess: when we added locks, you were using a Vera to control your lock. You just edited the device in Indigo and switched it to a native lock, but didn't edit every/any of your actions, so they continued to work.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Wed Oct 10, 2018 12:23 pm
Colorado4Wheeler offline
User avatar
Posts: 2715
Joined: Jul 20, 2009
Location: Colorado

Re: 7.0.x to 7.2.x Issue

jay (support) wrote:
Oh, ok - I thought all your actions were broken/not working given the urgency of your first post

The ones I fixed were not working but I tested others that were so I don't know what the difference was. The important stuff was fixed when I changed it to lock/unlock. So, in all, it was about 50% that worked and 50% that did not.

My Modest Contributions to Indigo:

HomeKit Bridge | Device Extensions | Security Manager | LCD Creator | Room-O-Matic | Smart Dimmer | Scene Toggle | Powermiser | Homebridge Buddy

Check Them Out Here

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest