Plugin Config Window Not Popping Up

Posted on
Sun Mar 11, 2018 9:43 am
Colorado4Wheeler offline
User avatar
Posts: 2747
Joined: Jul 20, 2009
Location: Colorado

Plugin Config Window Not Popping Up

I've got a bizarre issue that's holding up releasing my plugin and it's that the config window doesn't automatically pop up on a new installation. Pretty much every plugin I've ever installed will pop that config unless there is either already a plugin preference file or there's no PluginConfig.xml.

My plugin does not pop this dialog at all unless I disable Homebridge Buddy. When HBB is disabled it pops up every time.

So my question is how and why is this happening? Is it a bug? My cfBundleIdentifier is different for each plugin, so I cannot imagine what about HBB could possibly prevent the dialog from popping up.

My Modest Contributions to Indigo:

HomeKit Bridge | Device Extensions | Security Manager | LCD Creator | Room-O-Matic | Smart Dimmer | Scene Toggle | Powermiser | Homebridge Buddy

Check Them Out Here

Posted on
Sun Mar 11, 2018 1:27 pm
jay (support) offline
Site Admin
User avatar
Posts: 14872
Joined: Mar 19, 2008
Location: Austin, Texas

Re: Plugin Config Window Not Popping Up

No errors on plugin load? And if not, you're sure that you're not swallowing any exceptions by accident?

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Sun Mar 11, 2018 4:07 pm
Colorado4Wheeler offline
User avatar
Posts: 2747
Joined: Jul 20, 2009
Location: Colorado

Re: Plugin Config Window Not Popping Up

jay (support) wrote:
No errors on plugin load?

Not a single one.

jay (support) wrote:
And if not, you're sure that you're not swallowing any exceptions by accident?

I don't think so because I'm a pretty prolific error trapper, I encapsulate every function in a Try...Except for just that reason, and none of them Pass, they all report the error. Again, it's only when HBB is enabled.

Where in the order of things does that window appear, is it before startup or after? Perhaps that would help me narrow it down if it's in the plugin. I believe all plugin libraries load before startup if I'm not mistaken, is that when the config happens is right before calling startup or right after?

I went through my entire startup routine just to see if I'm doing anything that might ignore an error and it's not, it is also not doing anything with HBB. But, in particular I would expect that since it's only happening with HBB enabled that it would have something to do with either calling or referencing something HBB related which I don't think is happening unless they issue a very specific command in the menu.

I'll try disabling libraries to see what may be the cause but it's quite perplexing.

My Modest Contributions to Indigo:

HomeKit Bridge | Device Extensions | Security Manager | LCD Creator | Room-O-Matic | Smart Dimmer | Scene Toggle | Powermiser | Homebridge Buddy

Check Them Out Here

Posted on
Sun Mar 11, 2018 4:39 pm
Colorado4Wheeler offline
User avatar
Posts: 2747
Joined: Jul 20, 2009
Location: Colorado

Re: Plugin Config Window Not Popping Up

And now I can't get it to break again. Grrrrrr.

My Modest Contributions to Indigo:

HomeKit Bridge | Device Extensions | Security Manager | LCD Creator | Room-O-Matic | Smart Dimmer | Scene Toggle | Powermiser | Homebridge Buddy

Check Them Out Here

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest

cron