Python version conflicts

Posted on
Sun May 31, 2020 5:42 pm
gglockner offline
User avatar
Posts: 25
Joined: Jan 03, 2015

Re: Python version conflicts

Hi Matt, Jay and everyone: Now that Python 2.7 is deprecated, what are the plans to support Python 3.x for scripting?

Posted on
Mon Jun 01, 2020 10:05 am
jay (support) offline
Site Admin
User avatar
Posts: 16815
Joined: Mar 19, 2008
Location: Austin, Texas

Re: Python version conflicts

Note that "not supported" does not mean that it'll immediately break. We know we're going to need to migrate to Python 3, and we're planning how that's going to work. One of the biggest issues is that macOS doesn't come with Python 3 prior to Catalina and with Catalina you still had to install Python 3 separately from the command line developer tools. Also, the majority of our users don't upgrade macOS immediately (which given the quality issues with recent releases is generally a wise decision). So whatever solution we come up with has to work back some number of macOS releases. This will likely mean that we'll have to increase our system requirements (currently it's 10.7 or later) because we will have to ship our own Python 3 install, and the testing requirements are significant for each macOS release we support. The most current Python installers for macOS require Mavericks (10.9) or later for instance.

So, lots of technical issues paired with business decisions.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Thu Mar 25, 2021 9:15 am
Argelix offline
Posts: 10
Joined: Dec 08, 2016

Re: Python version conflicts

I just set up a new Mac mini; one of the first steps was (maybe wrong) to check if python is installed, I got a warning it is version 2.7 and deprecated, I should install python3 from the command line developer tools even offering to do it for me. Done.

Later I installed Indigo and at some point I needed to install paho-mqtt, no pip installed. pip3 was and I could install it, but ofc it isn't being found. "easy_install pip" and all hell broke loose with syntax errors. It is installing pip-21 which doesn't support Py2.7 anymore. After some digging I managed to install pip:

sudo easy_install pip==20.3.4

Maybe this helps somebody until Indigo can leave Python2.7 behind.

Posted on
Thu Mar 25, 2021 9:28 am
FlyingDiver offline
User avatar
Posts: 5335
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Python version conflicts

That's why paho is bundled with the MQTT Connector plugin. Installing it is a pain.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Who is online

Users browsing this forum: No registered users and 1 guest