Browser authentication issue

Posted on
Mon Mar 14, 2022 7:49 am
kennybroh offline
Posts: 530
Joined: Dec 13, 2009
Location: Baltimore

Browser authentication issue

My car has a browser but it apparently doesn’t allow pop-ups so when I try to log in I can’t enter the username or password and get an error message saying I’m not authorized.

Any way to pass that info as part of the URL? Any other workaround?


Sent from my iPhone using Tapatalk

Posted on
Tue Mar 15, 2022 4:15 pm
jay (support) offline
Site Admin
User avatar
Posts: 17643
Joined: Mar 19, 2008
Location: Austin, Texas

Re: iPad Safari won't save Indigo login info

Well, passing it on the URL line with HTTP Basic auth enabled is supposed to work but it appears to have gotten broken. We'll take a look at it for the next release.

This would be with Indigo Touch for Web (Moved it to that forum).

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Wed Mar 16, 2022 9:14 am
kennybroh offline
Posts: 530
Joined: Dec 13, 2009
Location: Baltimore

Re: Browser authentication issue

Thanks

Posted on
Thu Mar 17, 2022 4:42 pm
jltnol offline
Posts: 880
Joined: Oct 15, 2013

Re: Browser authentication issue

FWIW, I've had the same problem with Safari at some point, so just started using a different browser to access Indigo Webpages, there are a LOT to choose from...

Posted on
Mon Apr 11, 2022 3:19 pm
jay (support) offline
Site Admin
User avatar
Posts: 17643
Joined: Mar 19, 2008
Location: Austin, Texas

Re: Browser authentication issue

Apparently, browsers now seem to be disabling this as a security feature. When used from a programmatic library, https://username:password@yourreflector.indigodomo.net/devices.json works. I tested both from python and from curl in a terminal window.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest