"isDaylight" not being updated?

Posted on
Wed Aug 16, 2017 9:37 am
richy240 offline
Posts: 110
Joined: Jul 08, 2012

"isDaylight" not being updated?

I am running Indigo Pro 7.0.3 and I've recently noticed that the "isDaylight" variable is ALWAYS set to false. I don't have any automation that relies on that variable, but I was building something over the weekend and it's not working because it depends on "isDaylight".

Yes, I can easily create another one, or just manipulate that one manually, but I swear its value used to change automatically, no? Am I just crazy?

Posted on
Wed Aug 16, 2017 9:54 am
jay (support) offline
Site Admin
User avatar
Posts: 14868
Joined: Mar 19, 2008
Location: Austin, Texas

Re: "isDaylight" not being updated?

Yes, it should automatically change based on the location you have set on your Mac (or in your Indigo prefs). Make sure both of those are set appropriately. Might want to restart your Mac for good measure.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Sun Aug 20, 2017 7:32 am
richy240 offline
Posts: 110
Joined: Jul 08, 2012

Re: "isDaylight" not being updated?

Resetting the long/lat seemed to work for a bit, but it stopped updating again... Currently it's stuck on true, but I don't know how long it's been that way. I noticed it last night.

Recently I've noticed VERY unstable behavior from Indigo - plugins will fail, my Insteon USB adapter will stop being recognized (reload required to fix; happens completely randomly and like 6 times per day - I've ordered another to see if it's the hardware), some schedules aren't running (including the "isDaylight" problem described above), and I've even seen a schedule run for absolutely no reason (that is, the schedule was not scheduled to run at that time). Has anyone else seen/reported these sort of problems? I have upgraded and downgraded any related plugins, and all plugins that were upgraded recently, and I can't seem to find the source of the problem. I've disabled plugins and reenabled them one at a time, etc. The problem is really hard to nail down because it's so random.

Interestingly, I am not seeing ANY abnormal behavior on the server on which Indigo runs. It also continuously runs Plex, VMware Fusion (with 4 tiny little Ubuntu VMs running various applications/network services), iTunes, Docker, cTivo (downloads content from Tivo, encodes, and adds to Plex library) and more. I have run hardware tests and the like and I am pretty certain there's nothing wrong with the machine itself.

Any ideas? I have no idea when this started, but it seems like it's been going on for a couple weeks. I posted something about it in the Alexa-hue thread elsewhere on this board, and followed that up with a few edits that probably made my post more confusing because the problem seems completely random and absolutely elusive. That plugin is where I started to notice things going awry, since we rely on voice control pretty heavily. Since then it's "expanded" to other parts of the system.

Posted on
Sun Aug 20, 2017 2:11 pm
jay (support) offline
Site Admin
User avatar
Posts: 14868
Joined: Mar 19, 2008
Location: Austin, Texas

Re: "isDaylight" not being updated?

No other reports like this - in fact, it's been many years since we've had any Indigo issues with the basic functionality like you're describing. Despite not seeing other issues, my suspicion is that you've got some systemic issue that's causing issues. You might first want to start by eliminating some of the other things. I'd begin by turning off the VMs. They work at such a low-level that I could definitely see them causing erratic behavior.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Sun Aug 20, 2017 2:17 pm
matt (support) offline
Site Admin
User avatar
Posts: 18727
Joined: Jan 27, 2003
Location: Texas

Re: "isDaylight" not being updated?

Also watch the progress bar area at the bottom-left of the main window. If the Indigo Server is getting hung up (maybe because of an AppleScript or something else) then it might show progress caption text explaining what Indigo is doing that would be a clue as to what is causing the issue.

Image

Posted on
Wed Sep 06, 2017 9:47 pm
richy240 offline
Posts: 110
Joined: Jul 08, 2012

Re: "isDaylight" not being updated?

Yep, I'm an idiot, I figured it out. Took me a while to see it in the logs, but I noticed "Received awake notification from system" this evening. Oddly, this has been my Indigo server for quite some time, almost two years now, so I'm kinda confused as to how Sleep mode was re-enabled.

:oops: :x

Thanks guys.

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 2 guests