UI Problem

Posted on
Mon Sep 06, 2021 12:06 pm
MarcoGT offline
Posts: 825
Joined: Sep 11, 2014
Location: Germany

UI Problem

Hi all,

I am running Indigo 2021.1.1 on an iMac running macOS Monterey (Beta) and sometimes I have this problem.
Moving the panel up/down does not help; restarting the client does not help.
It disappears alone after some time...
I know that macOs Beta is not yet officially supported, but maybe it helps :)
Attachments
ui-problem.png
ui-problem.png (408.37 KiB) Viewed 666 times

Posted on
Mon Sep 06, 2021 1:05 pm
jay (support) offline
Site Admin
User avatar
Posts: 17040
Joined: Mar 19, 2008
Location: Austin, Texas

Re: UI Problem

Yeah, that's a beta issue. I just did some preliminary testing a week or so ago and there were quite a few bugs like that. I really hope Apple fixes them rather than forcing us to work around them but I don't have a lot of hope given that it's already September.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Fri Sep 17, 2021 7:56 pm
srkinard offline
Posts: 308
Joined: Apr 10, 2016
Location: Austin, Texas

Re: UI Problem

jay (support) wrote:
Yeah, that's a beta issue. I just did some preliminary testing a week or so ago and there were quite a few bugs like that. I really hope Apple fixes them rather than forcing us to work around them but I don't have a lot of hope given that it's already September.


Hey Jay...I doubt this will help, but when I sent my laptop off for a new keyboard (yay crappy butterfly mechanism) and got it back, I installed the Monterey Beta (this was during beta 4 time) since my backups were from Beta 3.

When I launched Indigo for the first time, it worked perfectly. No misalignment, no stuck window sizing, etc.

On the second launch of Indigo, the problem appeared. Odd that it only appeared after one launch. The preference files and Application Support folders were migrated back to the machine before I installed and launched it...

Maybe something in the saved window layout or so?

Posted on
Wed Oct 06, 2021 8:42 am
HFTobeason offline
Posts: 289
Joined: Nov 07, 2003

Re: UI Problem

I'm having what appears to be the same issue - only in the Home Window - can't resize it past about halfway down, the detail panel is hiding behind the bottom half, dragging the resize handle results in bizarre UI rendering behavior.

macOS 12.0 Beta (21A5534d)
Indigo Client 2021.1.0
Indigo Server 2021.1.1
MacBook Pro Retina (15-inch, 2016) - yeah, I know, time for a new machine...
Attachments
Screen Shot 2021-10-06 at 07.31.17.jpg
Screen Shot 2021-10-06 at 07.31.17.jpg (265.55 KiB) Viewed 409 times

Posted on
Wed Oct 06, 2021 8:47 am
srkinard offline
Posts: 308
Joined: Apr 10, 2016
Location: Austin, Texas

Re: UI Problem

Since this has been happening through all betas, it's obviously intended by Apple to be a new way of doing things. Matt and Jay will have to fix it in Indigo, which of course won't happen until full release of Monterey so they know the code is finalized. Would be pointless to adapt before then.

I just use my Big Sur machine to do Indigo stuff on for now.

Posted on
Wed Oct 06, 2021 10:05 am
jay (support) offline
Site Admin
User avatar
Posts: 17040
Joined: Mar 19, 2008
Location: Austin, Texas

Re: UI Problem

srkinard wrote:
it's obviously intended by Apple to be a new way of doing things.


Maybe, but we've also seen in past years where broken things (Safari authentication on both macOS and iOS) was broken up until the actual GM release. This is the reason that we wait until the GM release from Apple before trying to chase beta bugs (as you point out). We certainly hope Apple won't be breaking backwards compatibility with macOS 10.12, which is what this is doing at the moment.

And I suppose we should point out what we always do around this time of year: any Mac that performs critical functions for you should NEVER be upgraded to beta OS releases. We usually recommend that users wait to upgrade until a couple of bug fix releases after GM before upgrading critical Macs. This is really important advice as we've seen declining quality of initial macOS releases over the past several years.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Mon Oct 25, 2021 2:05 pm
jay (support) offline
Site Admin
User avatar
Posts: 17040
Joined: Mar 19, 2008
Location: Austin, Texas

Re: UI Problem

I've been unable to reproduce this issue with the shipping version of Monterey. If anyone experiences it again, do the following:

  1. Quit the Mac Client application
  2. Delete the following files:
    Code: Select all
    ~(your user folder)/Library/Preferences/Indigo 2021.1 Client Prefs.indiPref
    ~(your user folder)/Library/Preferences/Indigo 2021.1 Client Settings.indiPref
  3. Restart the client

Hopefully that will solve the issue.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Mon Oct 25, 2021 2:16 pm
HFTobeason offline
Posts: 289
Joined: Nov 07, 2003

Re: UI Problem

Almost... I can get the full list of Devices to show now, by repositioning the divider bar, but there's still some grunge just below the divider:
Attachments
Screen Shot 2021-10-25 at 13.14.59.png
Screen Shot 2021-10-25 at 13.14.59.png (185.12 KiB) Viewed 160 times

Posted on
Mon Oct 25, 2021 2:26 pm
srkinard offline
Posts: 308
Joined: Apr 10, 2016
Location: Austin, Texas

Re: UI Problem

HFTobeason wrote:
Almost... I can get the full list of Devices to show now, by repositioning the divider bar, but there's still some grunge just below the divider:


Same here....the resizing works for the main device view, but the overlapping text below the device list part of the window still occurs for me too like the screenshot HFTobeason posted.

Posted on
Mon Oct 25, 2021 2:43 pm
srkinard offline
Posts: 308
Joined: Apr 10, 2016
Location: Austin, Texas

Re: UI Problem

And once you close Indigo, the problem reappears.

I just re-opened Indigo on my Monterey machine after wiping out the files and back to being unable to resize the device window correctly.

Image

On relaunch the whole bottom section is gray, clicking on an item it stays blank, etc.

Do you need a screen recording of it?

Posted on
Mon Oct 25, 2021 2:47 pm
HFTobeason offline
Posts: 289
Joined: Nov 07, 2003

Re: UI Problem

Re @srkinard's report above - confirmed.

Posted on
Mon Oct 25, 2021 4:09 pm
srkinard offline
Posts: 308
Joined: Apr 10, 2016
Location: Austin, Texas

Re: UI Problem

And I confirm it happens on two different machines.

2016 MBP that was running Big Sur until today
2019 MBP that's been running Monterey since beta 1

Both exhibit exactly the same behavior. Works once when the prefs were deleted and recreated, broken on subsequent launches.
Explains why it worked once around beta 4 when I had wiped and sent my 2019 in for a keyboard repair and it came back. Clean install, launched once then broken since.

Something about the saved preferences it seems....

Posted on
Mon Oct 25, 2021 4:26 pm
jay (support) offline
Site Admin
User avatar
Posts: 17040
Joined: Mar 19, 2008
Location: Austin, Texas

Re: UI Problem

Unfortunately, nothing I can do causes this issue. This is always what I see no matter what resizing of the window or the various split view changes I make. It always behaves the same even across app restarts:

Screen Shot 2021-10-25 at 5.14.02 PM.png
Screen Shot 2021-10-25 at 5.14.02 PM.png (127.22 KiB) Viewed 101 times


So this must be something in your environments which are different from mine. Please answer the following questions:

  1. What Indigo version are you running?
  2. What is the exact macOS version you're using?
  3. Are you are using the client directly on the Mac (no screen sharing)?
  4. Is your server local or are you using the Mac client remotely?
  5. What mac model and how much memory?
  6. Does switching between dark mode and light mode make any difference?
  7. Are you running any kind of UI modification software?
  8. What 3rd party apps are you running that have icons in the menu bar?

I'm also a little unclear on when some things work and when they don't. So, please:

  1. Quit the Mac client
  2. Delete the prefs files
  3. Start back up
  4. Clearly document exactly what does work and what doesn't, and the exact steps you used to illustrate the problem.
  5. Quit the client
  6. Start it back up, and again clearly document exactly what does work and what doesn't, and the exact steps you used to illustrate the problem.

We're going to need you guys to be super clear/concise in explaining how you're seeing it since nothing I can do seems to cause the issue.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Mon Oct 25, 2021 4:31 pm
jay (support) offline
Site Admin
User avatar
Posts: 17040
Joined: Mar 19, 2008
Location: Austin, Texas

Re: UI Problem

And, as almost always happens, I was able to reproduce pretty much exactly after I posted.

It has to do with Window size. If you make your window really big, and leave it big when you quit/restart MC, then the problem happens. If you leave your window fairly small, it doesn't happen.

Anyway, now we can look into it more.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Mon Oct 25, 2021 4:33 pm
jay (support) offline
Site Admin
User avatar
Posts: 17040
Joined: Mar 19, 2008
Location: Austin, Texas

Re: UI Problem

BTW, it definitely has something to do with how the UI prefs are being saved. Deleting the prefs file then restarting does in fact make it stop, but across a restart something gets corrupted.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Who is online

Users browsing this forum: No registered users and 1 guest