Reflector not active

Posted on
Sun Jan 15, 2017 3:02 pm
jheddings offline
User avatar
Posts: 146
Joined: Dec 01, 2013
Location: Denver, CO

Reflector not active

Finally decided to upgrade my Indigo machine to something made this decade. On a fresh install of Indigo 7, I'm having a tough time getting the reflector set back up. This compute has not run Indigo previously, so there is no upgrade. I did copy my Indigo 6 database over, but everything else is right out of the box. When starting the server, it indicates that the reflector is still waiting for activation.

The following shows in the error log:

Code: Select all
 Error                           failed to create reflector connection: reflector not active


I tried running the IndigoPermsFixer and had the following output:

Code: Select all
-- Indigo Folder/File Permission Fixer --
Home User: XXXXX
  ID User: XXXXX
   Folder: /Library/Application Support/Perceptive Automation/Indigo 7
Repairing Indigo folder owner and permissions:
    Original: drwxrwxr-x / XXXXX : admin
         New: drwxrwxr-x / XXXXX : admin
Complete.
Repairing Prism Reflector key file permissions:
chmod: /Library/Application Support/Perceptive Automation/Indigo 7/Preferences/PrismReflector/ssh_config: No such file or directory
Complete.


It looks like something was missing in the reflector directory, so I attempted to reinstall hoping it would replace missing files. Same issue. The PrismReflector directory exists, but the only contents are an SSH key pair.

Any ideas?

Posted on
Sun Jan 15, 2017 3:12 pm
matt (support) offline
Site Admin
User avatar
Posts: 20569
Joined: Jan 27, 2003
Location: Texas

Re: Reflector not active

You just need to re-pair your Mac/Indigo with the reflector service. Follow the Getting Started section here.

If your Indigo Account online shows the reflector is already activated then follow the steps below the Getting Started section to reset it.

Image

Posted on
Sun Jan 15, 2017 3:54 pm
jheddings offline
User avatar
Posts: 146
Joined: Dec 01, 2013
Location: Denver, CO

Re: Reflector not active

Thanks, Matt. Resetting the reflector did the trick. I should have done that before switching Indigo to a new machine.

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest