Cannot access Reflector via cellular network

Posted on
Fri Oct 14, 2022 5:04 pm
blauhaus offline
Posts: 3
Joined: Mar 15, 2018

Cannot access Reflector via cellular network

We took our first real trip since the pandemic started and I realized that I couldn't access Indigo remotely via my reflector. It works fine via wifi & bonjour. I'm not sure what all may be relevant so here are some details.

I'm running Indigo 2021.2 on a 2018 Mac mini. This Mac Mini replaced a failed IMac during my non-travel phase so may not have noticed exactly when issue started. I can't access the old IMac set up, but I'm pretty sure that I transferred successfully to the new Mini because my account says "Indigo 7.0 license upgraded on Feb. 25, 2017 - activated on Mac "Mac mini - Indigo." On this Mini, I'd previously installed Indigo 7, 7.3, 7.4, 7.5.

-My subscription is current.
-My license page on the indigodomo web site shows Activated.
-I tried manually reseting my reflector following the steps on the indigo documentation page; no change.
On the Start Local Server page:
-standard indigo startup
-auto start indigo server on user login
-allow remote access. (user and password; tried resetting password too, just to make sure--no change)
-enable secure internet access via indigo reflector. (activated and I see my reflector address)
-outgoing port: default
-enable Oath and api key authentication
-enable remote indigo client access
-default port numbers (web server 8176, Indigo Server 1176).

When I restart the server, there are no reflector errors; only "reflector" reference in log is:
Reflector starting reflector connection to https://_____.indigodomo.net

When I go to my reflector web address via Safari and log-in, I get a blank generic screen of the control page menus.
On my phone, if I am only connected via cellular, I do not see my Indigo data base.
-iphone running 15.6.1

Where have I gone wrong? (referring to Indigo, not life choices)
Thanks!

Posted on
Sat Oct 15, 2022 2:53 pm
matt (support) offline
Site Admin
User avatar
Posts: 21118
Joined: Jan 27, 2003
Location: Texas

Re: Cannot access Reflector via cellular network

I checked your reflector and was prompted to authenticate when accessing it (which I cannot do since I don't have your credentials). That tells us the reflector is up and working and when accessing it you are accessing the Indigo Server on your Mac. Therefore, I don't think this is a reflector problem.

What do you mean by, "blank generic screen of the control page menus"? If you select Devices is anything shown? Note that you can control which devices and control pages are visible via the Remote Display option in the Main Window (accessible by right-clicking on devices, control pages, or their folders). Is it possible you just don't have that enabled for any Control Pages? If that isn't the problem, then what do you see when you access it (from Safari via the reflector) in Indigo's Event Log window? Any errors?

Image

Posted on
Sun Oct 16, 2022 1:31 pm
bluehouse offline
Posts: 19
Joined: May 04, 2011

Re: Cannot access Reflector via cellular network

Thanks for the quick reply Matt! I don’t know what happened but for some reason, now I can connect via cell network. All I had did since reading your reply was in Indigo, ensure Remote Display was enabled/checked on everything (it was), the open Indigo>Start Local Server menu, and click on my reflector link. From that page this time, I could click on any menu and see all applicable devices, control pages, etc. Same for Indigo Touch via phone with WiFi turned off.

Thanks again. I’ll pay more attention to testing non-Wi-Fi connections occasionally; see if any patterns or causes might be apparent.

James


Sent from my iPhone using Tapatalk

Posted on
Thu Nov 03, 2022 11:15 am
makedrinklas offline
Posts: 106
Joined: Oct 12, 2004

Re: Cannot access Reflector via cellular network

Hi Matt, we are having a similar problem with cell connectivity.

Both from Safari (on the Indigo machine/connected via the network) and via Touch, both respond that the reflector connection is down. The iPhones work from WiFi.

I've temporarily turned off the system firewall and Little Snitch to test and no luck. We've recently updated but everything else seems to be working fine.

AHHHHA. So I changed the Outgoing Reflector port section from Default (now 3) and now it works. Little Snitch asked me to allow and I did so now it appears to be working.

Hope this helps!

Mac OS 12.6
iOS 16.1
Indigo 2022.1

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest