Reflector Server having issues?

Posted on
Fri May 18, 2018 7:54 pm
decahill offline
Posts: 5
Joined: Nov 16, 2009
Location: Arizona

Reflector Server having issues?

I just started to get errors from the Reflector service this afternoon on my Mac and from a Web Browser:

From Indigo:
Error reflector connection test failed: <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>400 Bad Request</title>
</head><body>
<h1>Bad Request</h1>
<p>Your browser sent a request that this server could not understand.<br />
</p>
<p>Additionally, a 400 Bad Request
error was encountered while trying to use an ErrorDocument to handle the request.</p>
</body></html>

Error reflector reconnection scheduled in 2 minutes


From the Browser: "400 Bad Request" screen
Bad Request

Your browser sent a request that this server could not understand.
Additionally, a 400 Bad Request error was encountered while trying to use an ErrorDocument to handle the request.

Are there issues with the Reflector Servers?
Thanks!

Posted on
Fri May 18, 2018 8:21 pm
matt (support) offline
Site Admin
User avatar
Posts: 18622
Joined: Jan 27, 2003
Location: Texas

Re: Reflector Server having issues?

We recently did some server upgrades which is probably causing this (sorry!). I ran into a similar problem with some pages and it turned out it was because the hostname had an underscore in it. That technically isn't allowed and the more recent version of our backend server started enforcing that with a 400 error..

So I'm going to hypothesize that your reflector has an underscore in it. Our Create reflector UI hasn't allowed that in a long time, but if you have an older reflector it might have the underscore. If that is the case then send us an email with the reflector name and we'll get it changed for you.

Image

Posted on
Fri May 18, 2018 8:23 pm
matt (support) offline
Site Admin
User avatar
Posts: 18622
Joined: Jan 27, 2003
Location: Texas

Re: Reflector Server having issues?

Actually with a little sleuthing I think I found your reflector. I changed the underscore to a dash, so restart your Indigo Server and see if that clears up the problem.

Image

Posted on
Fri May 18, 2018 9:08 pm
decahill offline
Posts: 5
Joined: Nov 16, 2009
Location: Arizona

Re: Reflector Server having issues?

Thanks Matt,

You are 100% correct. I've had my reflector for decades (it seems!)

Restarted with the new reflector and all is fine again.

:D

Posted on
Fri Jun 01, 2018 5:02 am
mvignola29 offline
Posts: 34
Joined: Sep 26, 2015

Re: Reflector Server having issues?

I get this error message in the event log repeatedly

un 1, 2018 at 4:39:24 AM
Error reflector connection test failed: unable to connect to server
Error reflector reconnection scheduled in 5 seconds
Reflector restarting reflector connection

This occurs many times each day even though I am able to connect to my system remotely,
Is there a setting that I need to adjust for this test connection


Michael

Posted on
Fri Jun 01, 2018 9:30 am
jay (support) offline
Site Admin
User avatar
Posts: 14669
Joined: Mar 19, 2008
Location: Austin, Texas

Re: Reflector Server having issues?

It means that for some reason Indigo isn't able to talk to the reflector server. This is likely because of some network issue between your Indigo Server Mac and our hosted server: so you local network or router, your ISPs connection to the internet, intermittent DNS issues, etc.

A couple of years ago, I started seeing these sorts of things as well. At first, just once or twice a day, then 4-5 times, then finally once or twice an hour. I also began to notice that all my internet connections seemed to be kinda flakey/slow. Turns out the router port that my house was connected to in Time-Warner's local network box was failing (they moved me to a different port an everything cleared up immediately). So the reflector connection was a bit of a canary in a coal mine that there were issues developing.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Fri Aug 24, 2018 6:03 am
mvignola29 offline
Posts: 34
Joined: Sep 26, 2015

Re: Reflector Server having issues?

I changed my Internet provider and still have the same problem, In using the reflector I am able to access my system remotely with no connection issues, not sure whey the test connection fails when I am able to connect using my iphone or ipad

Posted on
Fri Aug 24, 2018 9:15 am
jay (support) offline
Site Admin
User avatar
Posts: 14669
Joined: Mar 19, 2008
Location: Austin, Texas

Re: Reflector Server having issues?

Are you still using the same router and WAP (if it's separate)?

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Fri Aug 24, 2018 2:38 pm
mvignola29 offline
Posts: 34
Joined: Sep 26, 2015

Re: Reflector Server having issues?

No the router equipment has been replaced. I have a switch that is used to provide more network connections.

Posted on
Fri Aug 24, 2018 3:24 pm
jay (support) offline
Site Admin
User avatar
Posts: 14669
Joined: Mar 19, 2008
Location: Austin, Texas

Re: Reflector Server having issues?

mvignola29 wrote:
No the router equipment has been replaced. I have a switch that is used to provide more network connections.


Is you Indigo Mac on the switch or connected directly to the router?

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Fri Aug 24, 2018 4:07 pm
mvignola29 offline
Posts: 34
Joined: Sep 26, 2015

Re: Reflector Server having issues?

It is directly connect to the router which is also modem that is connected to the IP service.

Posted on
Fri Aug 24, 2018 4:09 pm
mvignola29 offline
Posts: 34
Joined: Sep 26, 2015

Re: Reflector Server having issues?

This is the error message I get many times each day


Aug 24, 2018 at 4:17:36 PM
Error reflector connection test failed: Reflector connection is currently down.
Error reflector reconnection scheduled in 5 seconds
Reflector restarting reflector connection to https://mvignola29.indigodomo.net

Posted on
Sat Aug 25, 2018 10:48 am
matt (support) offline
Site Admin
User avatar
Posts: 18622
Joined: Jan 27, 2003
Location: Texas

Re: Reflector Server having issues?

Are there any other errors shown in the Event Log before that? Is your Mac going to sleep maybe?

That error means the connection test failed. Indigo then rebuilds the connection. Unfortunately, I'm not sure what is causing the problem. Indigo is just doing its best to recovery from the situation.

Image

Posted on
Sat Aug 25, 2018 1:49 pm
kw123 offline
User avatar
Posts: 5840
Joined: May 12, 2013
Location: Dallas, TX

Reflector Server having issues?

I am traveling and have connect issues too

Going through vpn then use itouch to the ip number is fine. Using the named server it does not connect. And also just regular remote connect gives the same error.

The port forwarding was not changed.

I am ok until I am back home but would like to understand why this does not work.

Have restarted indigo server several times.


Sent from my iPhone using Tapatalk

Posted on
Sat Aug 25, 2018 4:21 pm
matt (support) offline
Site Admin
User avatar
Posts: 18622
Joined: Jan 27, 2003
Location: Texas

Re: Reflector Server having issues?

I just checked and your reflector is definitely up and working (at least as of right now it is).
kw123 wrote:
Using the named server it does not connect.

What do you mean exactly by using the named server? How are you connecting or specifying what server Indigo Touch should connect to?
kw123 wrote:
And also just regular remote connect gives the same error.

What do you mean by regular remote connect? Are you referring to the Mac Indigo Client App, Indigo Touch, or using a browser? And how specifically are you trying to have it connect?

Image

Who is online

Users browsing this forum: No registered users and 1 guest