[ANSWERED]Refreshing EvoCam images on Control Pages?

Posted on
Thu Dec 22, 2011 8:05 am
gregjsmith offline
Posts: 881
Joined: Apr 01, 2003
Location: Rio Rancho, NM

[ANSWERED]Refreshing EvoCam images on Control Pages?

Anyone using Evocam with Indigo? I'm looking for ideas on how to use Evocam with Indigo 5.

Posted on
Thu Dec 22, 2011 8:51 am
eme jota ce offline
Posts: 325
Joined: Jul 09, 2009
Location: SW Florida

Re: Evocam anyone

I use both Evocam and Indigo but barely integrate them.

The one exception is that if the house is set to "away" mode and a motion sensor is triggered, Indigo will turn on lights near all the cameras then email me shots taken by Evocam. Evocam constantly saves a refreshed image to a folder, so Indigo just sends whatever image is in the Evocam Archive folder at the moment Indigo turns on the lights.

Posted on
Thu Dec 22, 2011 9:47 am
DomoPat offline
User avatar
Posts: 100
Joined: Jul 17, 2010

Re: Evocam anyone

eme jota ce wrote:
I use both Evocam and Indigo but barely integrate them.


Same here. Too bad we cannot get the the video feed in the control pages.

Posted on
Thu Dec 22, 2011 10:13 am
matt (support) offline
Site Admin
User avatar
Posts: 13646
Joined: Jan 27, 2003
Location: Texas

Re: Evocam anyone

Did you try emailing the EvoCam developer to see if the EC Web server can (or does) provide JPG image snapshots?

Image

Posted on
Thu Dec 22, 2011 10:19 am
gregjsmith offline
Posts: 881
Joined: Apr 01, 2003
Location: Rio Rancho, NM

Re: Evocam anyone

Evocam will output jpgs to where ever you specify. How should I use this?

Posted on
Thu Dec 22, 2011 10:35 am
matt (support) offline
Site Admin
User avatar
Posts: 13646
Joined: Jan 27, 2003
Location: Texas

Re: Evocam anyone

Try this:

1) Have EvoCam output the static JPG image to this folder:

Code: Select all
/Library/Application Support/Perceptive Automation/Indigo 5/IndigoWebServer/static/

2) Inside Control Page Editor create a new control with displays set to Refreshing Image URL.

3) Specify the image size you want for the control (160x120 works well for 2 side-by-side feeds on iPhone in portrait landscape).

4) In the URL edit field create a URL like (example assumes default Indigo Web server port number of 8176):

Code: Select all
file:///Library/Application%20Support/Perceptive%20Automation/Indigo%205/IndigoWebServer/static/EVOCAM_JPG_IMAGE_NAME

Cool Tip: for iPhone retina resolution display have EvoCam save the JPG image with DOUBLE the width/height that you specified for the control in step #3.

5) Set the refresh rate to Continuous or 1 Second.

Image

Posted on
Thu Dec 22, 2011 10:54 am
gregjsmith offline
Posts: 881
Joined: Apr 01, 2003
Location: Rio Rancho, NM

Re: Refreshing EvoCam images on Control Pages?

I had to change the port number from what I had set for my server.

Indigo popped up and asked for my server password from the keychain. It shows the correct image in the control page editor but not on the clients (web or iPhone) and I see an error 401 unauthorized and I can't get Indigo to ask me for the password again (assuming I put the wrong password in).

Posted on
Thu Dec 22, 2011 11:04 am
matt (support) offline
Site Admin
User avatar
Posts: 13646
Joined: Jan 27, 2003
Location: Texas

Re: Refreshing EvoCam images on Control Pages?

I edited step #4 above with an alternative URL to specify in the Control Page editor that should work better.

Image

Posted on
Thu Dec 22, 2011 12:28 pm
DomoPat offline
User avatar
Posts: 100
Joined: Jul 17, 2010

Re: Refreshing EvoCam images on Control Pages?

It works for me, never thought of doing a file URL. I can see the image in the control page on the Mac and iDevices. I use a one minute refresh for now, will do test with faster refreshes during daylight...

Posted on
Fri Dec 23, 2011 1:39 am
DomoPat offline
User avatar
Posts: 100
Joined: Jul 17, 2010

Re: Refreshing EvoCam images on Control Pages?

I contacted Evocam's support and they gave me the info for having the live stream working on a control page. Tested it with Evocam 4 web server and it works as expected:

- enable web server in Evocam
- in the control page set the item to 'refreshing image url'
- the url should be http://1.2.3.4:8080/1/image.jpg instead of http://1.2.3.4/1/stream.html as indicated in Evocam
- set the refresh rate to 'continuous' in the control page
- voilà !

Posted on
Fri Dec 23, 2011 5:11 am
gregjsmith offline
Posts: 881
Joined: Apr 01, 2003
Location: Rio Rancho, NM

Re: Refreshing EvoCam images on Control Pages?

I used the IP address in the address setting of EvoCam (instead of the 1.2.3.4) and it works great.

Posted on
Sat Dec 24, 2011 4:41 am
col offline
Posts: 214
Joined: Jan 08, 2010
Location: UK

Re: Refreshing EvoCam images on Control Pages?

Matt,
I followed your instructions and have Evocam image showing on my control page, but it does not show up on my iPad or iPhone.

Posted on
Sat Dec 24, 2011 9:50 am
matt (support) offline
Site Admin
User avatar
Posts: 13646
Joined: Jan 27, 2003
Location: Texas

Re: Refreshing EvoCam images on Control Pages?

col wrote:
Matt, I followed your instructions and have Evocam image showing on my control page, but it does not show up on my iPad or iPhone.

Are you using Indigo Touch on your iPhone/iPad or Safari? If Indigo Touch, then try force quitting it.

What exact URL are you using?

Have you tried DomoPat's suggested URL above?

Image

Posted on
Sat Dec 24, 2011 10:23 am
col offline
Posts: 214
Joined: Jan 08, 2010
Location: UK

Re: Refreshing EvoCam images on Control Pages?

Thanks Matt,

Using Indigo touch.

Now tried with Domopat's url and working fine

Merry Christmas

Posted on
Tue Jul 23, 2013 5:23 am
dgarozzo offline
Posts: 29
Joined: Jan 08, 2009

Re: Refreshing EvoCam images on Control Pages?

Within Indigo, I can specify a refreshing URL with the format of http://[user]:[pass]@[site]:[port]/[camera number]/image.jpg, and in the Control Page, it will display the image, but when I go to view that either in a browser or in Indigo Touch, the image does not appear. It appears to be giving me a 401 unauthorized error.

Who is online

Users browsing this forum: No registered users and 0 guests