Find my iDevices!

Posted on
Sat Oct 01, 2011 2:46 am
nlagaros offline
Posts: 816
Joined: Dec 20, 2010

Re: Find my iDevices!

I have installed v1.02 of the plugin. For some reason I am getting HTTP Error's when starting it up. I've got some of the the debug dump below. I'm not quite sure why it think it is adding an "overridden" unit to the device list. My two phones have been configured in MobileMe and I don't recall this behavior with the prior plugin.

It is actually going out and locating both phones properly. The battery status is incorrect for both also. As I had before, no map on the web page, just the table with each phone's data.

Code: Select all
  Find My IDevices Debug          Debug Mode is On (Only recommended for Testing Purposes)
  Find My IDevices Debug          Version Check Server reports 1.011 is available.
  Find My IDevices Debug              Registering 1854101101 (Fence - Home)
  Find My IDevices Debug              Adding a Fence
  Find My IDevices Debug              Registering 43750962 (Marie's iPhone)
  Find My IDevices Debug          Adding Overridden Unit to Device List
  Find My IDevices Error          exception in deviceStartComm(Marie's iPhone): HTTP Error 401: Unauthorized
  Find My IDevices Debug              Registering 837299346 (Nick's iPhone)
  Find My IDevices Debug          Adding Overridden Unit to Device List
  Find My IDevices Error          exception in deviceStartComm(Nick's iPhone): HTTP Error 401: Unauthorized
  Find My IDevices Debug          Running Concurrent Thread
  Find My IDevices                   Retrieving location data
  ....
  Find My IDevices                   Finished retrieving location data
  Find My IDevices Debug          Sleep Time - Sat Oct  1 04:35:56 2011

Posted on
Sat Oct 01, 2011 2:58 am
nlagaros offline
Posts: 816
Joined: Dec 20, 2010

Re: Find my iDevices!

I also get the following exceptions each time I reload the plugin:

Code: Select all
  Reloading plugin "Find My IDevices 1.02"
  Stopping plugin "Find My IDevices 1.02" (pid 29414)
  Find My IDevices Error          exception in deviceStopComm(Fence - Home): list.remove(x): x not in list
  Find My IDevices Error          exception in deviceStopComm(Marie's iPhone): list.remove(x): x not in list
  Find My IDevices Error          exception in deviceStopComm(Nick's iPhone): list.remove(x): x not in list


I did recreate the two iPhone devices. The fence device was left from the previous installation.

Posted on
Sat Oct 01, 2011 5:24 am
bschollnick2 offline
Posts: 1250
Joined: Oct 17, 2004
Location: Rochester, Ny

Re: Find my iDevices!

nlagaros wrote:
I also get the following exceptions each time I reload the plugin:

Code: Select all
  Reloading plugin "Find My IDevices 1.02"
  Stopping plugin "Find My IDevices 1.02" (pid 29414)
  Find My IDevices Error          exception in deviceStopComm(Fence - Home): list.remove(x): x not in list
  Find My IDevices Error          exception in deviceStopComm(Marie's iPhone): list.remove(x): x not in list
  Find My IDevices Error          exception in deviceStopComm(Nick's iPhone): list.remove(x): x not in list


I did recreate the two iPhone devices. The fence device was left from the previous installation.


I'll take another look at that. I don't recall seeing that when I was testing the change... It's mainly cosmetic.

------
My Plugins for Indigo (v4, v5, and v6) - http://bit.ly/U8XxPG

Security Script for v4 - http://bit.ly/QTgclf
for v5 - http://bit.ly/T6WBKu

Support Forum(s) - http://www.perceptiveautomation.com/userforum/viewforum.php?f=33

Posted on
Sun Oct 02, 2011 8:37 am
loafbread offline
Posts: 111
Joined: May 25, 2009

Re: Find my iDevices!

This is very nice. I am just trying it out. So far I like it.
Thanks

Posted on
Sun Oct 02, 2011 10:19 am
bschollnick2 offline
Posts: 1250
Joined: Oct 17, 2004
Location: Rochester, Ny

Re: Find my iDevices!

loafbread wrote:
This is very nice. I am just trying it out. So far I like it.
Thanks


Your quite welcome...

------
My Plugins for Indigo (v4, v5, and v6) - http://bit.ly/U8XxPG

Security Script for v4 - http://bit.ly/QTgclf
for v5 - http://bit.ly/T6WBKu

Support Forum(s) - http://www.perceptiveautomation.com/userforum/viewforum.php?f=33

Posted on
Sun Oct 02, 2011 3:18 pm
bschollnick2 offline
Posts: 1250
Joined: Oct 17, 2004
Location: Rochester, Ny

Re: Find my iDevices!

nlagaros wrote:
I have installed v1.02 of the plugin. For some reason I am getting HTTP Error's when starting it up. I've got some of the the debug dump below. I'm not quite sure why it think it is adding an "overridden" unit to the device list. My two phones have been configured in MobileMe and I don't recall this behavior with the prior plugin.

It is actually going out and locating both phones properly. The battery status is incorrect for both also. As I had before, no map on the web page, just the table with each phone's data.

Code: Select all
  Find My IDevices Debug          Debug Mode is On (Only recommended for Testing Purposes)
  Find My IDevices Debug          Version Check Server reports 1.011 is available.
  Find My IDevices Debug              Registering 1854101101 (Fence - Home)
  Find My IDevices Debug              Adding a Fence
  Find My IDevices Debug              Registering 43750962 (Marie's iPhone)
  Find My IDevices Debug          Adding Overridden Unit to Device List
  Find My IDevices Error          exception in deviceStartComm(Marie's iPhone): HTTP Error 401: Unauthorized
  Find My IDevices Debug              Registering 837299346 (Nick's iPhone)
  Find My IDevices Debug          Adding Overridden Unit to Device List
  Find My IDevices Error          exception in deviceStartComm(Nick's iPhone): HTTP Error 401: Unauthorized
  Find My IDevices Debug          Running Concurrent Thread
  Find My IDevices                   Retrieving location data
  ....
  Find My IDevices                   Finished retrieving location data
  Find My IDevices Debug          Sleep Time - Sat Oct  1 04:35:56 2011


Are those two devices using alternative MobileMe logins?

------
My Plugins for Indigo (v4, v5, and v6) - http://bit.ly/U8XxPG

Security Script for v4 - http://bit.ly/QTgclf
for v5 - http://bit.ly/T6WBKu

Support Forum(s) - http://www.perceptiveautomation.com/userforum/viewforum.php?f=33

Posted on
Sun Oct 02, 2011 3:22 pm
nlagaros offline
Posts: 816
Joined: Dec 20, 2010

Re: Find my iDevices!

They are using the same account - same login. Strange I was not getting that error with the prior version and the plugin is reporting correct coordinates for both phones.

Posted on
Sun Oct 02, 2011 4:12 pm
hammer32 offline
Posts: 66
Joined: May 13, 2006
Location: Copperas Cove, TX

Re: Find my iDevices!

I've been out of the loop for a couple of months and just downloaded the new plugin. I've edited all of my devices to change them to X10 devices and back to Find my iDevices plugin items, restarted Indigo a few times, but this is what my log shows:

Code: Select all
 Reloading plugin "Find My IDevices 1.02"
  Stopping plugin "Find My IDevices 1.02" (pid 1128)
  Plugin "Find My IDevices" disconnected
  Starting plugin "Find My IDevices 1.02"
  Plugin "Find My IDevices" connected
  Plugin "Find My IDevices 1.02" started
  Find My IDevices                Find My iDevice Plugin Loaded...
  Find My IDevices Error          exception in deviceStartComm(Alarm Clock iPhone Map): 'key com.schollnick.indigoplugin.FindMyiDevices not found in dict'
  Find My IDevices Error          exception in deviceStartComm(Andrea iPhone Map): HTTP Error 401: Unauthorized
  Find My IDevices Error          exception in deviceStartComm(iPad 2): HTTP Error 401: Unauthorized
  Find My IDevices Error          exception in deviceStartComm(Owen's iPhone 3GS 1 Map): HTTP Error 401: Unauthorized
  Find My IDevices Error          exception in deviceStartComm(Owen's iPhone 3GS 2 Map): HTTP Error 401: Unauthorized
  Find My IDevices Error          exception in deviceStartComm(Sean iPhone Map): HTTP Error 401: Unauthorized
  Find My IDevices                   Retrieving location data
  Find My IDevices Error          Error in plugin execution runConcurrentThread:

Traceback (most recent call last):
  File "plugin.py", line 511, in runConcurrentThread
  File "plugin.py", line 447, in run_search_for_idevices
  File "plugin.py", line 359, in fetch_updated_MobileMe_Locations
  File "plugin.py", line 231, in find_device_in_Indigo_database
<type 'exceptions.KeyError'>: key com.schollnick.indigoplugin.FindMyiDevices not found in dict

  Find My IDevices Error          plugin runConcurrentThread function returned or failed; will attempt again in 10 seconds

Posted on
Sun Oct 02, 2011 5:07 pm
bschollnick2 offline
Posts: 1250
Joined: Oct 17, 2004
Location: Rochester, Ny

Re: Find my iDevices!

hammer32 wrote:
I've been out of the loop for a couple of months and just downloaded the new plugin. I've edited all of my devices to change them to X10 devices and back to Find my iDevices plugin items, restarted Indigo a few times, but this is what my log shows:

Code: Select all
 Reloading plugin "Find My IDevices 1.02"
  Stopping plugin "Find My IDevices 1.02" (pid 1128)
  Plugin "Find My IDevices" disconnected
  Starting plugin "Find My IDevices 1.02"
  Plugin "Find My IDevices" connected
  Plugin "Find My IDevices 1.02" started
  Find My IDevices                Find My iDevice Plugin Loaded...
  Find My IDevices Error          exception in deviceStartComm(Alarm Clock iPhone Map): 'key com.schollnick.indigoplugin.FindMyiDevices not found in dict'
  Find My IDevices Error          exception in deviceStartComm(Andrea iPhone Map): HTTP Error 401: Unauthorized
  Find My IDevices Error          exception in deviceStartComm(iPad 2): HTTP Error 401: Unauthorized
  Find My IDevices Error          exception in deviceStartComm(Owen's iPhone 3GS 1 Map): HTTP Error 401: Unauthorized
  Find My IDevices Error          exception in deviceStartComm(Owen's iPhone 3GS 2 Map): HTTP Error 401: Unauthorized
  Find My IDevices Error          exception in deviceStartComm(Sean iPhone Map): HTTP Error 401: Unauthorized
  Find My IDevices                   Retrieving location data
  Find My IDevices Error          Error in plugin execution runConcurrentThread:

Traceback (most recent call last):
  File "plugin.py", line 511, in runConcurrentThread
  File "plugin.py", line 447, in run_search_for_idevices
  File "plugin.py", line 359, in fetch_updated_MobileMe_Locations
  File "plugin.py", line 231, in find_device_in_Indigo_database
<type 'exceptions.KeyError'>: key com.schollnick.indigoplugin.FindMyiDevices not found in dict

  Find My IDevices Error          plugin runConcurrentThread function returned or failed; will attempt again in 10 seconds


Unless you are using alternative MobileMe logins, it's an cosmetic error... But I'm confused, since I can't duplicate this over here... Can you turn on debug logging, and send me a copy of the log at Benjamin AT schollnick DOT net?

- Benjamin

------
My Plugins for Indigo (v4, v5, and v6) - http://bit.ly/U8XxPG

Security Script for v4 - http://bit.ly/QTgclf
for v5 - http://bit.ly/T6WBKu

Support Forum(s) - http://www.perceptiveautomation.com/userforum/viewforum.php?f=33

Posted on
Mon Oct 03, 2011 5:10 pm
bschollnick2 offline
Posts: 1250
Joined: Oct 17, 2004
Location: Rochester, Ny

Re: Find my iDevices!

bschollnick2 wrote:
hammer32 wrote:
I've been out of the loop for a couple of months and just downloaded the new plugin. I've edited all of my devices to change them to X10 devices and back to Find my iDevices plugin items, restarted Indigo a few times, but this is what my log shows:

Code: Select all
 Reloading plugin "Find My IDevices 1.02"
  Stopping plugin "Find My IDevices 1.02" (pid 1128)
  Plugin "Find My IDevices" disconnected
  Starting plugin "Find My IDevices 1.02"
  Plugin "Find My IDevices" connected
  Plugin "Find My IDevices 1.02" started
  Find My IDevices                Find My iDevice Plugin Loaded...
  Find My IDevices Error          exception in deviceStartComm(Alarm Clock iPhone Map): 'key com.schollnick.indigoplugin.FindMyiDevices not found in dict'
  Find My IDevices Error          exception in deviceStartComm(Andrea iPhone Map): HTTP Error 401: Unauthorized
  Find My IDevices Error          exception in deviceStartComm(iPad 2): HTTP Error 401: Unauthorized
  Find My IDevices Error          exception in deviceStartComm(Owen's iPhone 3GS 1 Map): HTTP Error 401: Unauthorized
  Find My IDevices Error          exception in deviceStartComm(Owen's iPhone 3GS 2 Map): HTTP Error 401: Unauthorized
  Find My IDevices Error          exception in deviceStartComm(Sean iPhone Map): HTTP Error 401: Unauthorized
  Find My IDevices                   Retrieving location data
  Find My IDevices Error          Error in plugin execution runConcurrentThread:

Traceback (most recent call last):
  File "plugin.py", line 511, in runConcurrentThread
  File "plugin.py", line 447, in run_search_for_idevices
  File "plugin.py", line 359, in fetch_updated_MobileMe_Locations
  File "plugin.py", line 231, in find_device_in_Indigo_database
<type 'exceptions.KeyError'>: key com.schollnick.indigoplugin.FindMyiDevices not found in dict

  Find My IDevices Error          plugin runConcurrentThread function returned or failed; will attempt again in 10 seconds


Unless you are using alternative MobileMe logins, it's an cosmetic error... But I'm confused, since I can't duplicate this over here... Can you turn on debug logging, and send me a copy of the log at Benjamin AT schollnick DOT net?


I have an early beta, that could be tested if you wish... The major difference is that the device logic has been completely rewritten, and simplified.

------
My Plugins for Indigo (v4, v5, and v6) - http://bit.ly/U8XxPG

Security Script for v4 - http://bit.ly/QTgclf
for v5 - http://bit.ly/T6WBKu

Support Forum(s) - http://www.perceptiveautomation.com/userforum/viewforum.php?f=33

Posted on
Thu Oct 06, 2011 8:07 pm
bschollnick2 offline
Posts: 1250
Joined: Oct 17, 2004
Location: Rochester, Ny

Re: Find my iDevices! v1.10 Beta

Folks,

There have been a few people that have had device issues with Find My iPhone. I have rewritten the Device loading process in Find my iPhone, and I am making it available as a public beta...

v1.10 Changes
⁃ v1.10 Public Release
⁃ Rewrite the login system, and device tracking code to try to simplify the code.
⁃ Removed some legacy code (MobileMe_Account List, etc) to simplify code maintainability

http://dl.dropbox.com/u/241415/Find%20M ... 0v1.10.zip

------
My Plugins for Indigo (v4, v5, and v6) - http://bit.ly/U8XxPG

Security Script for v4 - http://bit.ly/QTgclf
for v5 - http://bit.ly/T6WBKu

Support Forum(s) - http://www.perceptiveautomation.com/userforum/viewforum.php?f=33

Posted on
Fri Oct 07, 2011 10:20 am
nlagaros offline
Posts: 816
Joined: Dec 20, 2010

Re: Find my iDevices!

I loaded the plugin. It seems to work fine. I don't see the errors I was in the prior version. The web page is not working. Here is the dump from Indigo:

Code: Select all
Traceback (most recent call last):
  File "/Library/Application Support/Perceptive Automation/Indigo 5/IndigoWebServer/cherrypy/_cprequest.py", line 609, in respond
    cherrypy.response.body = self.handler()
  File "/Library/Application Support/Perceptive Automation/Indigo 5/IndigoWebServer/cherrypy/_cpdispatch.py", line 25, in __call__
    return self.callable(*self.args, **self.kwargs)
  File "/Library/Application Support/Perceptive Automation/Indigo 5/IndigoWebServer/plugins/Find-My-iDevices/reqhandler.py", line 92, in index
    tmpl.insert_map_js = self.create_new_webpage (bottle  )
  File "/Library/Application Support/Perceptive Automation/Indigo 5/IndigoWebServer/plugins/Find-My-iDevices/reqhandler.py", line 150, in create_new_webpage
    cntr_lat, cntr_long = self.center_of_zone ( fence )
  File "/Library/Application Support/Perceptive Automation/Indigo 5/IndigoWebServer/plugins/Find-My-iDevices/reqhandler.py", line 114, in center_of_zone
    lat1, long1 = fence[0]
TypeError: 'int' object is not iterable

Posted on
Fri Oct 07, 2011 11:12 am
bschollnick2 offline
Posts: 1250
Joined: Oct 17, 2004
Location: Rochester, Ny

Re: Find my iDevices!

nlagaros wrote:
I loaded the plugin. It seems to work fine. I don't see the errors I was in the prior version. The web page is not working. Here is the dump from Indigo:

Code: Select all
Traceback (most recent call last):
  File "/Library/Application Support/Perceptive Automation/Indigo 5/IndigoWebServer/cherrypy/_cprequest.py", line 609, in respond
    cherrypy.response.body = self.handler()
  File "/Library/Application Support/Perceptive Automation/Indigo 5/IndigoWebServer/cherrypy/_cpdispatch.py", line 25, in __call__
    return self.callable(*self.args, **self.kwargs)
  File "/Library/Application Support/Perceptive Automation/Indigo 5/IndigoWebServer/plugins/Find-My-iDevices/reqhandler.py", line 92, in index
    tmpl.insert_map_js = self.create_new_webpage (bottle  )
  File "/Library/Application Support/Perceptive Automation/Indigo 5/IndigoWebServer/plugins/Find-My-iDevices/reqhandler.py", line 150, in create_new_webpage
    cntr_lat, cntr_long = self.center_of_zone ( fence )
  File "/Library/Application Support/Perceptive Automation/Indigo 5/IndigoWebServer/plugins/Find-My-iDevices/reqhandler.py", line 114, in center_of_zone
    lat1, long1 = fence[0]
TypeError: 'int' object is not iterable


I'll take a look, I didn't make any changes that should have affected the web page portion, but it's possible that I missed something...

------
My Plugins for Indigo (v4, v5, and v6) - http://bit.ly/U8XxPG

Security Script for v4 - http://bit.ly/QTgclf
for v5 - http://bit.ly/T6WBKu

Support Forum(s) - http://www.perceptiveautomation.com/userforum/viewforum.php?f=33

Posted on
Fri Oct 07, 2011 5:18 pm
bschollnick2 offline
Posts: 1250
Joined: Oct 17, 2004
Location: Rochester, Ny

Re: Find my iDevices!

bschollnick2 wrote:
I'll take a look, I didn't make any changes that should have affected the web page portion, but it's possible that I missed something...


I missed a section in the fence code for the web page...

Here's the updated Zip...
http://dl.dropbox.com/u/241415/Find%20M ... v1.10a.zip

------
My Plugins for Indigo (v4, v5, and v6) - http://bit.ly/U8XxPG

Security Script for v4 - http://bit.ly/QTgclf
for v5 - http://bit.ly/T6WBKu

Support Forum(s) - http://www.perceptiveautomation.com/userforum/viewforum.php?f=33

Posted on
Fri Oct 07, 2011 5:42 pm
nlagaros offline
Posts: 816
Joined: Dec 20, 2010

Re: Find my iDevices!

The web page works again. For some reason I do not see the map, the table populate fine. I'm sure it is just me and some setting I have wrong.

Page 5 of 27 1, 2, 3, 4, 5, 6, 7, 8 ... 27

Who is online

Users browsing this forum: No registered users and 1 guest