Virtual Sprinkler issue

Posted on
Thu May 11, 2017 9:08 am
jenkins007 offline
Posts: 87
Joined: Nov 08, 2006
Location: Seguin, TX

Virtual Sprinkler issue

I am running Indigo 7.0.3 on an older mac that can't be upgraded, so I know the OS is very stable. I am a long time user (since version 2/3), and have had multiple sparkler controllers for a long time. On my control page I have buttons for each one of the sprinkler valves (12 in all). I knew there was a risk if someone turned on 2 valves at the same time, so I decided last week to use the embedded virtual sprinkler feature. Please note, that the control page has worked fine for years with the buttons pointing to the individual sprinkler controllers (although I did have to put up a status request schedule to update the sprinkler buttons on the control page many years ago (I wonder if I still need that?).

Last week, I adjusted the control page to point to the virtual sprinkler instead of the individual irrigation controllers (EZ Rain and EZ Flora). Each button on the control page displays "Device State" for the virtual controller and points to the specific valve for that button. The server action points to the virtual sprinkler and the specific valve. Everything good so far.

When I push the button for a specific valve it works as expected and turns on that sprinkler circuit. However, when the schedule completes and the valve turns off, the control page does not update, but still shows the sprinkler is turned on. And since I have 1 button for the sprinkler on/off status for overall sprinkler status, both buttons are green showing the sprinkler is on, but in reality, Indigo knows it is off (when I look at the virtual device state in the devices Indigo shows "Schedule: -- no schedule running --" as well as each controller's State shows "all zones off"). I also have an irrigation status schedule and after it runs a status request (Request full status update), the control page still shows the valve is turned on.

Please note that in the last 2 weeks one of the sprinkler controllers died. I should have the replacement on Monday. Still, that shouldn't cause this issue. Also note that on the status update request, performing it on the individual sprinkler controller that is defective returns an error of "Irrigation Orchard" valve status request; send failed (no acknowledgment)". On the virtual sprinkler, there is no error. It certainly would be nice to get that error to know there could be an issue as in defective controller!!!

Thanks,
Matthew

Posted on
Thu May 18, 2017 9:47 pm
matt (support) offline
Site Admin
User avatar
Posts: 17642
Joined: Jan 27, 2003
Location: Texas

Re: Virtual Sprinkler issue

Hi Matthew,

I just tried to reproduce the problem here, but I'm not seeing the behavior. I created a Virtual Sprinkler device that linked 2 real sprinkler controllers, then I created a Control Page and added Device State icon/image controls for each zone on the virtual sprinkler controller. That is, each control icon was set to mirror a unique zone in the virtual sprinkler device (not in the physical devices pointed to by the virtual device). I then setup a sprinkler schedule to run through the different zones. The Control Page updated correctly for each zone, and showed all zones were off once the schedule was complete.

Can you think of what is different about my setup compared to yours? Also, copy/paste the Event Log window contents showing what is logged when the problem occurs. Perhaps there is a clue in there.

Image

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest