Upgrading to Indigo 7 - Need to Install Python 2.7?

Posted on
Tue Sep 12, 2017 6:06 pm
ckeyes888 offline
Posts: 1838
Joined: Nov 26, 2009
Location: Kalispell, MT

Upgrading to Indigo 7 - Need to Install Python 2.7?

Pretty thoroughly confused at this point about upgrading to 7.
I'm running 10.7.5 which I believe has Python 2.6 installed.
From what I can gather here Indigo 7 needs Python 2.7. I assume I need to install 2.7 somehow?

Was hoping to install Pillow to use the Security Camera plugin but that seems to need 2.7 installed as well.

Any help appreciated!

Thanks,

Carl

Posted on
Tue Sep 12, 2017 6:44 pm
Different Computers online
User avatar
Posts: 1331
Joined: Jan 02, 2016
Location: East Coast

Re: Upgrading to Indigo 7 - Need to Install Python 2.7?

not quite the answer you're looking for, but if you're running 10.7.5 because of hardware limitations, I think you'll find that Security Camera is too much for your hardware. I ran it on a 2009 Mac Mini and it struggled.

Refugee from SmartThings and so happy to be on Indigo now.
Sierra on an i5 running Harmony Hub, Hue, Security Camera, DomoPad, EPS Device Extensions EPS Smart Dimmer, MatplotLib, Plex, Scale Adapters, uniFiAP, Wunderground.

Posted on
Tue Sep 12, 2017 6:49 pm
ckeyes888 offline
Posts: 1838
Joined: Nov 26, 2009
Location: Kalispell, MT

Re: Upgrading to Indigo 7 - Need to Install Python 2.7?

I'm currently running 4 cams in SecuritySpy with no issue if that's any indication.
I'm just hoping to move one of my SS cams, that doesn't use preset positions, to the plugin
to avoid having to upgrade my SS license beyond the 4 cam limit.

Thanks,

Carl

Posted on
Tue Sep 12, 2017 7:04 pm
bkmar1192 offline
Posts: 269
Joined: Sep 12, 2015

Re: Upgrading to Indigo 7 - Need to Install Python 2.7?

I have a new version of Security Camera that is almost ready for production. It has some major performance improvements and better motion sensing. I have one more bug to squash and am hoping to release this weekend.

As for installing pillow on 2.7. That is an area of python that I am not very proficient with. I'll see what I can figure out tonight but hopefully one of the other members has a better answer.


Sent from my iPhone using Tapatalk

Posted on
Wed Sep 13, 2017 7:06 am
matt (support) offline
Site Admin
User avatar
Posts: 18006
Joined: Jan 27, 2003
Location: Texas

Re: Upgrading to Indigo 7 - Need to Install Python 2.7?

Hi Carl,

macOS 10.7.5 actually has Python 2.7.1 included, so Indigo 7 will run on it.

Image

Posted on
Wed Sep 13, 2017 1:43 pm
ckeyes888 offline
Posts: 1838
Joined: Nov 26, 2009
Location: Kalispell, MT

Re: Upgrading to Indigo 7 - Need to Install Python 2.7?

Good to know.

Thanks,

Carl

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 3 guests