7.0.3.Update issues

Posted on
Thu May 11, 2017 10:20 pm
alpitmaster offline
Posts: 7
Joined: Apr 08, 2017

7.0.3.Update issues

I obviously need adult supervision. When restarted Indigo tonight, I got a dialog box telling me that 7.0.3 is available, I clicked the download button, which took me to the Software Downloads page, where I clicked on the big green button to download. I didn't read at the time that it said "Download Indigo 7 v7.0." Once the bouncing arrow indicated that the update was in my downloads folder, I proceeded to open "Indigo.dmg," which was at the top of the downloads list. I then ran the installer, and after installation, it told me that my database file was missing or corrupt. It then gave me the option to start a new file or select an existing one. My database was in the list, so I chose it.

All 60 of my devices, plus my triggers, schedules, and action groups appear to be there, but the devices all came up red. I think that means I need to resync them, but before doing so, I checked the version of the software and discovered I actually have v7.0.2. I checked the software downloads page, where I discovered that the green download button says v 7.0. But I cannot find any option to download 7.0.3.

Can you tell me where to get 7.0.3, and after I get it loaded, should I then re-sync all my devices?

Posted on
Fri May 12, 2017 8:17 am
matt (support) offline
Site Admin
User avatar
Posts: 18068
Joined: Jan 27, 2003
Location: Texas

Re: 7.0.3.Update issues

The download page doesn't include the "dot release" version in the title, just the major and minor numbers (it goes major.minor.dot), so that Indigo 7.0 download is actually 7.0.3. I just downloaded it to verify that it is correct.

Try restarting your Mac, re-downloading 7.0.3 (using the same main download link), and re-running the installer. Does that help?

Regarding the devices being red – check the Event Log window for details on what errors Indigo is reporting (and copy/paste those into a reply). But first I'd recommend the reboot and reinstall to see if that clears up the problem.

Image

Posted on
Fri May 12, 2017 11:55 am
alpitmaster offline
Posts: 7
Joined: Apr 08, 2017

Re: 7.0.3.Update issues

Thanks for the prompt reply, Matt. When I started the Mac reboot, this morning, I got a message that said Indigo.dmg was downloading. I had attempted that download some 13-14 hours earlier, so it was obviously hung. That would explain why, when I ran the indigo.dmg that was at the top of my downloads, I reinstalled 7.0.2.

I now have 7.0.3 installed. Again, it didn't automatically connect to my database, but gave me a choice between that sample database and my database WMSLights. When I chose WMSLights, it connected to the database. As happened last night, all devices are red, but the database is now called WMSLights 4. Last night, after my update attempt, it was WMSLights 3.

Again, many thanks for your help. BTW, this level of support is one of the many reasons I had no problem with your new subscription plan, last year. Wishing you guys success!

George

I have attached a screenshot of my current database folder.

Here is my event log:

May 12, 2017, 12:20:48 PM
Starting Indigo Server version 7.0.3 (Mac OS X 10.10.3)
Loading attachments
"device target attachment.scpt" script loaded
"group target attachment.scpt" script loaded
"growl attachment.scpt" script loaded
"iTunes attachment.scpt" script loaded
"scenes attachment.scpt" script loaded
"time stamp attachment.scpt" script loaded
Loading database "/Library/Application Support/Perceptive Automation/Indigo 7/Databases/WMSLights 3.indiDb"
Error XML Parse Error: no element found
Error On character 0 of line number 1.
Error failed to load database file
Newer version of plugin "Timers and Pesters.indigoPlugin" v2.0.2 installed -- moving older version 2.0.1 to trash
Moving duplicate plugin ".Action Collection.indigoPlugin" v2.0.4 to trash
Moving plugin ".Action Collection.indigoPlugin" to enabled plugins folder
Moving plugin "Timers and Pesters.indigoPlugin" to enabled plugins folder
Loading plugin "Action Collection 2.0.4"
Starting plugin "Action Collection 2.0.4" (pid 2668)
Loading plugin "Messages 0.1.1"
Starting plugin "Messages 0.1.1" (pid 2669)
Loading plugin "Timers and Pesters 2.0.2"
Starting plugin "Timers and Pesters 2.0.2" (pid 2670)
Found disabled interface "INSTEON Commands 2.0.10"
Found disabled interface "Z-Wave 2.0.68"
Found disabled plugin "Airfoil Pro 1.0.7"
Found disabled plugin "Airfoil 1.1.11"
Found disabled plugin "DIRECTV DVR Control 1.1.0"
Found disabled plugin "EasyDAQ Relay Card 2.0.3"
Found disabled plugin "Global Property Manager 2.0"
Found disabled plugin "Growl 2.0.2"
Found disabled plugin "iCal Alarm Processor 2.0.1"
Found disabled plugin "iTunes 2.0.4"
Found disabled plugin "NOAA Weather 2.0.1"
Found disabled plugin "SQL Logger 2.0.5"
Found disabled plugin "Vera Bridge 1.0.8"
Found disabled interface "Virtual Devices 2.0.4"
Found disabled plugin "WeatherSnoop 2.1.2"
Bonjour registered "Indigo - No Database Selected"
Indigo Cocoa client connected
Started plugin "Timers and Pesters 2.0.2"
Started plugin "Action Collection 2.0.4"
Started plugin "Messages 0.1.1"
WebServer client connected
WebServer started on port 8176 -- digest authentication enabled

May 12, 2017, 12:21:49 PM
Stopping plugin "Action Collection 2.0.4" (pid 2668)
Stopping plugin "Timers and Pesters 2.0.2" (pid 2670)
Stopping plugin "Messages 0.1.1" (pid 2669)
Stopped plugin "Action Collection 2.0.4"
Stopped plugin "Timers and Pesters 2.0.2"
Stopped plugin "Messages 0.1.1"
Loading database "/Library/Application Support/Perceptive Automation/Indigo 6/Databases/WMSLights.indiDb"
Database file was in old Indigo 6 folder
Saving converted database file "/Library/Application Support/Perceptive Automation/Indigo 7/Databases/WMSLights 4.indiDb"
Switching to database "WMSLights 4"
Loading plugin "Action Collection 2.0.4"
Starting plugin "Action Collection 2.0.4" (pid 2712)
Loading plugin "Messages 0.1.1"
Starting plugin "Messages 0.1.1" (pid 2713)
Loading plugin "Timers and Pesters 2.0.2"
Starting plugin "Timers and Pesters 2.0.2" (pid 2714)
Found disabled interface "INSTEON Commands 2.0.10"
Found disabled interface "Z-Wave 2.0.68"
Found disabled plugin "Airfoil Pro 1.0.7"
Found disabled plugin "Airfoil 1.1.11"
Found disabled plugin "DIRECTV DVR Control 1.1.0"
Found disabled plugin "EasyDAQ Relay Card 2.0.3"
Found disabled plugin "Global Property Manager 2.0"
Found disabled plugin "Growl 2.0.2"
Found disabled plugin "iCal Alarm Processor 2.0.1"
Found disabled plugin "iTunes 2.0.4"
Found disabled plugin "NOAA Weather 2.0.1"
Found disabled plugin "SQL Logger 2.0.5"
Found disabled plugin "Vera Bridge 1.0.8"
Found disabled interface "Virtual Devices 2.0.4"
Found disabled plugin "WeatherSnoop 2.1.2"

May 12, 2017, 12:21:51 PM
Error XML Parse Error: no element found
Error On character 0 of line number 1.
Error XML Parse Error: no element found
Error On character 0 of line number 1.
Error XML Parse Error: no element found
Error On character 0 of line number 1.
Started plugin "Messages 0.1.1"
Started plugin "Action Collection 2.0.4"
Started plugin "Timers and Pesters 2.0.2"

May 12, 2017, 12:21:51 PM
Error XML Parse Error: no element found
Error On character 0 of line number 1.
Error XML Parse Error: no element found
Error On character 0 of line number 1.
Error XML Parse Error: no element found
Error On character 0 of line number 1.
Started plugin "Messages 0.1.1"
Started plugin "Action Collection 2.0.4"
Started plugin "Timers and Pesters 2.0.2"
Bonjour unregistered previous server name
Bonjour registered "Indigo - WMSLights 4"
Attachments
Screen Shot 2017-05-12 at 12.44.31 PM.png
Screen Shot 2017-05-12 at 12.44.31 PM.png (214.95 KiB) Viewed 990 times

Posted on
Sun Jul 02, 2017 8:39 am
RedYuriPrime offline
Posts: 43
Joined: Oct 14, 2014
Location: Oxford

Re: 7.0.3.Update issues

Hi,

I'm also having a substantial problem updating to 7.03, moving from 7.02.

Half my network of devices shows as greyed out, and don't respond. Struggling to understand the logic of which do and don't work, as some devices which are apparently the same have behaved differently - guess this could be version or software numbers. More worrying, after having re-synced a few, but having problemsre-syncing others, I decided to restart the mac and indigo - result is that at least half of the devices I had just resynced needed resyncing again .Tried another MAC restart, and some of the re-synced devicesagain failed to be recognised on restart. This essentially means the system isn't stable on 7.03 - a powercut will cause it to lose these devices again.

Anyone else seen this? Only option seems to try to move back to 7.02 - not done this before! I guess I delete Indigo, install from an older download and revert to a backup of the database.

However that leaves me in something of a hole for future updates. Question is, are there any other tests I should do before reverting?

Somewhat frustrated, :?
Geoff

###############################
The startup log looks like:
2 Jul 2017 15:01:48
Starting Indigo Server version 7.0.3 (Mac OS X 10.10.5)
Loading attachments
"device target attachment.scpt" script loaded
"group target attachment.scpt" script loaded
"growl attachment.scpt" script loaded
"iTunes attachment.scpt" script loaded
"scenes attachment.scpt" script loaded
"time stamp attachment.scpt" script loaded
Loading database "/Users/..."
Loading plugin "Action Collection 2.0.4"
Starting plugin "Action Collection 2.0.4" (pid 335)
Loading interface "Z-Wave 2.0.68"
Starting interface "Z-Wave 2.0.68" (pid 336)
Loading plugin "Better Email 7.1.0"
Starting plugin "Better Email 7.1.0" (pid 337)
Loading plugin "EPS - Control Page Keypad 1.12"
Starting plugin "EPS - Control Page Keypad 1.12" (pid 338)
Loading plugin "fingscan 4.17.5"
Starting plugin "fingscan 4.17.5" (pid 339)
Loading plugin "Matplotlib 0.4.08"
Starting plugin "Matplotlib 0.4.08" (pid 340)
Loading plugin "NEST Home 2.0.50"
Starting plugin "NEST Home 2.0.50" (pid 341)
Loading plugin "Timers and Pesters 2.0.2"
Starting plugin "Timers and Pesters 2.0.2" (pid 342)
Loading plugin "utilities 1.6.1"
Starting plugin "utilities 1.6.1" (pid 343)
Found disabled interface "INSTEON Commands 2.0.10"
Found disabled plugin "Airfoil Pro 1.0.7"
Found disabled plugin "Airfoil 1.1.14"
Found disabled plugin "Cynical SecuritySpy 2.1.0"
Found disabled plugin "DIRECTV DVR Control 1.1.1"
Found disabled plugin "EasyDAQ Relay Card 2.0.3"
Found disabled plugin "Global Property Manager 2.0"
Found disabled plugin "Growl 2.0.2"
Found disabled plugin "iCal Alarm Processor 2.0.1"
Found disabled plugin "iTunes 2.0.4"
Found disabled plugin "NOAA Weather 2.0.1"
Found disabled plugin "Sonos 0.8.13"
Found disabled plugin "SQL Logger 2.0.5"
Found disabled plugin "Vera Bridge 1.0.10"
Found disabled interface "Virtual Devices 2.0.4"
Found disabled plugin "WeatherSnoop 2.1.2"
Bonjour registered "Indigo - ..."
Indigo Cocoa client connected
Reflector starting reflector connection to https://....indigodomo.net
Started plugin "utilities 1.6.1"
Started plugin "Timers and Pesters 2.0.2"
Started plugin "fingscan 4.17.5"
fingscan FINGSCAN--V 4-17-5 initializing will take ~ 2 minutes...
fingscan killing ping jobs: all
Started plugin "Action Collection 2.0.4"
utilities initialized
utilities Utilities plugin initialized, ==> select action form plugin menu
Started plugin "NEST Home 2.0.50"
NEST Home ** Data Tracking Online **
fingscan leaving WiFi parameters at default, not configured in 'fingscan/Configure...'
fingscan indigo variables initialized
fingscan getting password
fingscan get password done
Started plugin "EPS - Control Page Keypad 1.12"
Started plugin "Better Email 7.1.0"
Better Email Starting Better Email
NEST Home Error versionCheck: There was an error parsing the server's version file.
Started interface "Z-Wave 2.0.68"
Z-Wave connected to Z-Wave 3.95 static controller interface on /dev/cu.usbmodem1411 (firmware 1.00)
Z-Wave found module included in controller with no matching device (missing or disabled): 010 - Relay Power Switch
Z-Wave found module included in controller with no matching device (missing or disabled): 019 - Relay Switch
WebServer client connected
Z-Wave found module included in controller with no matching device (missing or disabled): 027 - Thermostat
WebServer started on port 8176 -- digest authentication enabled
Z-Wave found module included in controller with no matching device (missing or disabled): 031 - Setpoint Thermostat
Z-Wave found module included in controller with no matching device (missing or disabled): 032 - Setpoint Thermostat
Z-Wave found module included in controller with no matching device (missing or disabled): 034 - General Thermostat (v2)
Z-Wave found module included in controller with no matching device (missing or disabled): 035 - Setpoint Thermostat
Z-Wave found module included in controller with no matching device (missing or disabled): 040 - Setpoint Thermostat
Z-Wave found module included in controller with no matching device (missing or disabled): 041 - General Thermostat (v2)
Z-Wave found module included in controller with no matching device (missing or disabled): 042 - Setpoint Thermostat
Z-Wave found module included in controller with no matching device (missing or disabled): 043 - Setpoint Thermostat
Z-Wave found module included in controller with no matching device (missing or disabled): 044 - General Thermostat (v2)
Z-Wave found module included in controller with no matching device (missing or disabled): 045 - General Thermostat (v2)
Z-Wave found module included in controller with no matching device (missing or disabled): 046 - Notification Sensor
Z-Wave found module included in controller with no matching device (missing or disabled): 047 - Binary Sensor (routing)
Z-Wave found module included in controller with no matching device (missing or disabled): 048 - Binary Sensor (routing)
Z-Wave found module included in controller with no matching device (missing or disabled): 049 - Binary Sensor (routing)
Z-Wave found module included in controller with no matching device (missing or disabled): 050 - Binary Sensor (routing)
Z-Wave found module included in controller with no matching device (missing or disabled): 051 - Binary Sensor (routing)
Z-Wave found module included in controller with no matching device (missing or disabled): 052 - Notification Sensor
Z-Wave found module included in controller with no matching device (missing or disabled): 053 - Binary Sensor (routing)
Z-Wave found module included in controller with no matching device (missing or disabled): 055 - Notification Sensor
Z-Wave found module included in controller with no matching device (missing or disabled): 056 - Relay Power Switch
Z-Wave found module included in controller with no matching device (missing or disabled): 057 - Portable Remote Controller
Z-Wave found module included in controller with no matching device (missing or disabled): 058 - Alarm Sensor (routing)
Z-Wave found module included in controller with no matching device (missing or disabled): 059 - Binary Sensor (routing)
Z-Wave found module included in controller with no matching device (missing or disabled): 060 - Binary Sensor (routing)
Z-Wave found module included in controller with no matching device (missing or disabled): 067 - Binary Sensor (routing)
Z-Wave found module included in controller with no matching device (missing or disabled): 068 - Sensor Alarm
Z-Wave found module included in controller with no matching device (missing or disabled): 069 - Sensor Alarm
Z-Wave found module included in controller with no matching device (missing or disabled): 071 - Notification Sensor
Z-Wave found module included in controller with no matching device (missing or disabled): 072 - Multilevel Sensor (routing)
Z-Wave found module included in controller with no matching device (missing or disabled): 073 - Multilevel Sensor (routing)
Z-Wave found module included in controller with no matching device (missing or disabled): 074 - Setpoint Thermostat
Z-Wave found module included in controller with no matching device (missing or disabled): 080 - Relay Power Switch
Z-Wave found module included in controller with no matching device (missing or disabled): 083 - Binary Sensor (routing)
Z-Wave found module included in controller with no matching device (missing or disabled): 084 - Notification Sensor
Z-Wave found module included in controller with no matching device (missing or disabled): 085 - Setpoint Thermostat
Z-Wave found module included in controller with no matching device (missing or disabled): 086 - Setpoint Thermostat
Z-Wave found module included in controller with no matching device (missing or disabled): 088 - Setpoint Thermostat
Z-Wave found module included in controller with no matching device (missing or disabled): 089 - Dimmable Power Switch
Z-Wave found module included in controller with no matching device (missing or disabled): 090 - Notification Sensor
Z-Wave found module included in controller with no matching device (missing or disabled): 091 - Relay Power Switch
Z-Wave found module included in controller with no matching device (missing or disabled): 092 - Relay Power Switch
Z-Wave found module included in controller with no matching device (missing or disabled): 093 - Binary Sensor (routing)
Z-Wave found module included in controller with no matching device (missing or disabled): 094 - Notification Sensor
Z-Wave found module included in controller with no matching device (missing or disabled): 095 - Notification Sensor
Z-Wave found module included in controller with no matching device (missing or disabled): 097 - Relay Power Switch
Z-Wave found module included in controller with no matching device (missing or disabled): 098 - Notification Sensor
Z-Wave found module included in controller with no matching device (missing or disabled): 100 - Setpoint Thermostat
Z-Wave found module included in controller with no matching device (missing or disabled): 101 - Setpoint Thermostat
Z-Wave found module included in controller with no matching device (missing or disabled): 102 - Notification Sensor
Z-Wave found module included in controller with no matching device (missing or disabled): 103 - Notification Sensor
Z-Wave found module included in controller with no matching device (missing or disabled): 104 - Notification Sensor
Z-Wave found module included in controller with no matching device (missing or disabled): 107 - Relay Power Switch
Z-Wave found module included in controller with no matching device (missing or disabled): 109 - Siren
Z-Wave found module included in controller with no matching device (missing or disabled): 110 - Binary Sensor (routing)
Z-Wave found module included in controller with no matching device (missing or disabled): 114 - Portable Remote Controller
Z-Wave found module included in controller with no matching device (missing or disabled): 115 - Siren
Z-Wave found module included in controller with no matching device (missing or disabled): 067 - Binary Sensor (routing)
Z-Wave found module included in controller with no matching device (missing or disabled): 068 - Sensor Alarm
Z-Wave found module included in controller with no matching device (missing or disabled): 069 - Sensor Alarm
Z-Wave found module included in controller with no matching device (missing or disabled): 071 - Notification Sensor
Z-Wave found module included in controller with no matching device (missing or disabled): 072 - Multilevel Sensor (routing)
Z-Wave found module included in controller with no matching device (missing or disabled): 073 - Multilevel Sensor (routing)
Z-Wave found module included in controller with no matching device (missing or disabled): 074 - Setpoint Thermostat
Z-Wave found module included in controller with no matching device (missing or disabled): 080 - Relay Power Switch
Z-Wave found module included in controller with no matching device (missing or disabled): 083 - Binary Sensor (routing)
Z-Wave found module included in controller with no matching device (missing or disabled): 084 - Notification Sensor
Z-Wave found module included in controller with no matching device (missing or disabled): 085 - Setpoint Thermostat
Z-Wave found module included in controller with no matching device (missing or disabled): 086 - Setpoint Thermostat
Z-Wave found module included in controller with no matching device (missing or disabled): 088 - Setpoint Thermostat
Z-Wave found module included in controller with no matching device (missing or disabled): 089 - Dimmable Power Switch
Z-Wave found module included in controller with no matching device (missing or disabled): 090 - Notification Sensor
Z-Wave found module included in controller with no matching device (missing or disabled): 091 - Relay Power Switch
Z-Wave found module included in controller with no matching device (missing or disabled): 092 - Relay Power Switch
Z-Wave found module included in controller with no matching device (missing or disabled): 093 - Binary Sensor (routing)
Z-Wave found module included in controller with no matching device (missing or disabled): 094 - Notification Sensor
Z-Wave found module included in controller with no matching device (missing or disabled): 095 - Notification Sensor
Z-Wave found module included in controller with no matching device (missing or disabled): 097 - Relay Power Switch
Z-Wave found module included in controller with no matching device (missing or disabled): 098 - Notification Sensor
Z-Wave found module included in controller with no matching device (missing or disabled): 100 - Setpoint Thermostat
Z-Wave found module included in controller with no matching device (missing or disabled): 101 - Setpoint Thermostat
Z-Wave found module included in controller with no matching device (missing or disabled): 102 - Notification Sensor
Z-Wave found module included in controller with no matching device (missing or disabled): 103 - Notification Sensor
Z-Wave found module included in controller with no matching device (missing or disabled): 104 - Notification Sensor
Z-Wave found module included in controller with no matching device (missing or disabled): 107 - Relay Power Switch
Z-Wave found module included in controller with no matching device (missing or disabled): 109 - Siren
Z-Wave found module included in controller with no matching device (missing or disabled): 110 - Binary Sensor (routing)
Z-Wave found module included in controller with no matching device (missing or disabled): 114 - Portable Remote Controller
Z-Wave found module included in controller with no matching device (missing or disabled): 115 - Siren
fingscan loaded indigo data
fingscan network info: inet 192.168.0.219 netmask 0xffffff00 broadcast 192.168.0.255
fingscan ifind plugin: com.corporatechameleon.iFindplugBeta
fingscan FING initializing
Started plugin "Matplotlib 0.4.08"

Z-wave system with 80+ devices, Indigo7 on a dedicated MacMini
Controlling lighting, heating, hotwater, security; but still a lot to learn ... :shock:

Posted on
Sun Jul 02, 2017 12:00 pm
matt (support) offline
Site Admin
User avatar
Posts: 18068
Joined: Jan 27, 2003
Location: Texas

Re: 7.0.3.Update issues

We haven't had other reports of problems and 7.0.3 has been available for several months, so I think it is just coincidental that the problem occurred after the update. The problem probably started because the Z-Wave controller was in a bad state or glitching at the same time the Indigo Server was started (that is, had you just restarted 7.0.2 at the same time the result would have been the same).

The log you included above is showing that the Z-Wave Controller has several included nodes in it and that no enabled Indigo devices are found that match those nodes. What isn't shown in that log (but is probably in the Event Log from when 7.0.3 first started) is that the Z-Wave Controller returned (because it was possibly in a bad state) to Indigo that it didn't have any nodes included, or the nodes included had bad information that didn't match your Indigo devices. When that occurs Indigo assumes that you've plugged in a different Z-Stick, the Z-Stick is malfunctioning, or you have manually excluded/included modules in the Z-Stick. In that case what is reported to be in the Z-Stick doesn't make the profile information for the devices in Indigo, so Indigo has no choice but to disable communication with those devices. Now the Event Log above looks like valid node information is probably being returned, so you need to manually tell Indigo to enable communication with the devices again. One way to do that is to re-sync them, but you can instead just right-click on them and choose them menu item to re-enable Indigo communication. Still somewhat of a pain since you have to do it for each device (we need to improve that), but better than having to re-sync.

Image

Posted on
Sun Jul 02, 2017 12:03 pm
jay (support) offline
Site Admin
User avatar
Posts: 13354
Joined: Mar 19, 2008
Location: Austin, Texas

Re: 7.0.3.Update issues

You can also just click the Comm Enabled checkbox in the Devices list. That's probably faster than right-click and menu select.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Sun Jul 02, 2017 9:53 pm
howartp offline
Posts: 2902
Joined: Jan 09, 2014
Location: West Yorkshire, UK

Re: 7.0.3.Update issues

jay (support) wrote:
You can also just click the Comm Enabled checkbox in the Devices list. That's probably faster than right-click and menu select.

Ditto :-)


Sent from my iPhone using Tapatalk Pro

Posted on
Fri Jul 14, 2017 2:19 am
RedYuriPrime offline
Posts: 43
Joined: Oct 14, 2014
Location: Oxford

Re: 7.0.3.Update issues

Just an update. Re-enabling comms by ticking the box solved the problem for the channels I had not already tried to re-synch, and was a very quick process.
The issue has re-occurred once since, and without the mac or indigo obviously having done a restart (when indigo should email me, if nothing else) but half the devices dropped out of communication, I think essentially the same selection. Obviously not an ideal situation.

This mac had a melt down a few months ago (another thread) and I am not sure that it is behaving entirely correctly, and this may be an underlying driver. In fairness I now couple of copies of indigo running for different applications (all licensed I hasten to add - recalling a thread where this turned out to be not the case!), and none of the others have ever given this problem. As soon as I can set it up I plan to move this indigo installation onto a new mac, and then rebuild the basic installation on the mac from ground zero, however with my day job interfering this could take a couple of weeks.

Still interested to hear if anyone else has had this problem. If not, it really does suggest the Mac itself is contributing.

Geoff.

Z-wave system with 80+ devices, Indigo7 on a dedicated MacMini
Controlling lighting, heating, hotwater, security; but still a lot to learn ... :shock:

Posted on
Fri Aug 11, 2017 3:11 am
RedYuriPrime offline
Posts: 43
Joined: Oct 14, 2014
Location: Oxford

Re: 7.0.3.Update issues

Had the same problem occur with a different groups of devices. Also had a number of power cuts etc :roll: so guess it could be occurring during the restarts. Before cahnging the MAC it seems sensible to explore options to detect, and if possible correct the problem automatically.

From the documentation I came up with the code (trialling on just two devices):

Code: Select all
for sensor in ["Bedroom2_Main_Light","RoomStat_Lounge"]:
   dev=indigo.devices[sensor]
   indigo.device.enable(dev, value=True)
   dev.replaceOnServer()

This has no impact, so I guess it is the wrong device property.
Is there a python readable device property relating to the device Comms status, can it be written to, and what is the device. enable property being referenced above if it is not the comms?

Geoff

Z-wave system with 80+ devices, Indigo7 on a dedicated MacMini
Controlling lighting, heating, hotwater, security; but still a lot to learn ... :shock:

Posted on
Fri Aug 11, 2017 8:28 am
jay (support) offline
Site Admin
User avatar
Posts: 13354
Joined: Mar 19, 2008
Location: Austin, Texas

Re: 7.0.3.Update issues

The line:

Code: Select all
indigo.device.enable(dev, value=True)


is the correct command to enable a device (you don't need the last line, it's not doing anything). If it's not working, it's because the the device enable is failing for some reason. What shows in the event log when the script runs?

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest