The RFXCOM Plugin - Quickstart (text under development)

Posted on
Thu May 12, 2016 2:00 pm
Frakke offline
Posts: 63
Joined: May 05, 2016

Re: The RFXCOM Plugin - Quickstart (text under development)

b_weijenberg wrote:
Frakke wrote:
Hi All,

I added the RFXCOM plugin and setup the transceiver.
But how can I add a device and it's knowing which channel he needs to send?

I've got some like these:
[url]http://www.elro.eu/uploads/products/manual/AB440RA_Manual.pdf
[/url]
So, I click on new device,, Type: RFXCOM, Model: ELRO Appliance.
Then it's asking me for the Module Address? Where can I find this?

Or do I need to use this another way?
Thanks!

Regards!


See chapter 7.3 in the RFXtrx User Guide how to configure the switch settings in the AB400.
http://www.rfxcom.com/WebRoot/StoreNL2/Shops/78165469/MediaGallery/Downloads/RFXtrx_User_Guide.pdf


Hi I really don't see how I need to configure this?
This is my remote (see image attached)
Attachments
image1.JPG
image1.JPG (64.01 KiB) Viewed 1578 times

Posted on
Sun May 15, 2016 1:48 pm
Frakke offline
Posts: 63
Joined: May 05, 2016

Re: The RFXCOM Plugin - Quickstart (text under development)

Hi All,

Got it to work, with support of RFXCOM!
So, you need to see to the switch, nog the remote.
When you have a look at this switch, you see:
1 2 3 4 5 A B C D E
1 0 1 0 1 0 1 0 0 0

When you go and look this up:

1 2 3 4 <== switches
HC==========
A 0 0 0 0
B 0 0 0 1
C 0 0 1 0
D 0 0 1 1
E 0 1 0 0
F 0 1 0 1
G 0 1 1 0
H 0 1 1 1
I 1 0 0 0
J 1 0 0 1
K 1 0 1 0
L 1 0 1 1
M 1 1 0 0
N 1 1 0 1
O 1 1 1 0
P 1 1 1 1

The first 4 digits, you see: it's house code: "K"
After these 4 you check the following:

5 A B C D E 5 A B C D E <== switches
5 6 7 8 9 10 5 6 7 8 9 10 <== OR switches
DC==================DC=============
1 0 0 0 0 0 0 33 0 0 0 0 0 1
2 0 0 0 1 0 0 34 0 0 0 1 0 1
3 0 0 1 0 0 0 35 0 0 1 0 0 1
4 0 0 1 1 0 0 36 0 0 1 1 0 1
5 0 1 0 0 0 0 37 0 1 0 0 0 1
6 0 1 0 1 0 0 38 0 1 0 1 0 1
7 0 1 1 0 0 0 39 0 1 1 0 0 1
8 0 1 1 1 0 0 40 0 1 1 1 0 1
9 1 0 0 0 0 0 41 1 0 0 0 0 1
10 1 0 0 1 0 0 42 1 0 0 1 0 1
11 1 0 1 0 0 0 43 1 0 1 0 0 1
12 1 0 1 1 0 0 44 1 0 1 1 0 1
13 1 1 0 0 0 0 45 1 1 0 0 0 1
14 1 1 0 1 0 0 46 1 1 0 1 0 1
15 1 1 1 0 0 0 47 1 1 1 0 0 1
16 1 1 1 1 0 0 48 1 1 1 1 0 1
17 0 0 0 0 1 0 49 0 0 0 0 1 1
18 0 0 0 1 1 0 50 0 0 0 1 1 1
19 0 0 1 0 1 0 51 0 0 1 0 1 1
20 0 0 1 1 1 0 52 0 0 1 1 1 1
21 0 1 0 0 1 0 53 0 1 0 0 1 1
22 0 1 0 1 1 0 54 0 1 0 1 1 1
23 0 1 1 0 1 0 55 0 1 1 0 1 1
24 0 1 1 1 1 0 56 0 1 1 1 1 1
25 1 0 0 0 1 0 57 1 0 0 0 1 1
26 1 0 0 1 1 0 58 1 0 0 1 1 1
27 1 0 1 0 1 0 59 1 0 1 0 1 1
28 1 0 1 1 1 0 60 1 0 1 1 1 1
29 1 1 0 0 1 0 61 1 1 0 0 1 1
30 1 1 0 1 1 0 62 1 1 0 1 1 1
31 1 1 1 0 1 0 63 1 1 1 0 1 1
32 1 1 1 1 1 0 64 1 1 1 1 1 1

The rest of the digits: "1 0 1 0 0 0" --> "11"
So when you add a new Elro Appliance, the module address is "K11"

Regards
Attachments
IMG_0157.JPG
IMG_0157.JPG (52.86 KiB) Viewed 1523 times

Who is online

Users browsing this forum: No registered users and 2 guests