No value update (interface freeze)

Posted on
Wed May 31, 2017 2:36 pm
marcel langelaan offline
Posts: 12
Joined: May 12, 2017

Re: No value update (interface freeze)

Hi Matt,

Discussed this freeze issue with Bert (please for mor details contact him).
Bij selecting a RFXcom sensor (temp) its necessary to fill in the ID code (see attachment => ID 48).
There is no possibility in the setup of the RFXcom interface to select within this ID 48 the temp/voltage/A-D part of the sensor.
It seems that the result can be that the right subID is selected (seems Random), but can also be that one of the other SUBID's is selected resulting in no update.
Latest results in no update of temp (because temp is not selected)

I have made a second sensor with the same ID => this one is updated and the other one not.

Please advice how to short this out.
Attachments
rfreceiver - rfxmeter.jpg
rfreceiver - rfxmeter.jpg (350.92 KiB) Viewed 548 times

Posted on
Thu Jun 01, 2017 9:53 pm
matt (support) offline
Site Admin
User avatar
Posts: 17658
Joined: Jan 27, 2003
Location: Texas

Re: No value update (interface freeze)

I believe I have Marcel's bug fixed in version 2.1.1 which is available here.

Image

Posted on
Mon Jun 05, 2017 1:03 pm
marcel langelaan offline
Posts: 12
Joined: May 12, 2017

Re: No value update (interface freeze)

Hi Matt,

Removed all sensors and added again.
This is the result, all sensors have the TEMP value 0.0

RFXCOM Debug processing: 7 112 0 108 16 8 177 80 (07 70 00 6C 10 08 B1 50)
RFXCOM Debug RFXSensor 16 with subtype 0 and value 2225
RFXCOM Debug Data1: 7 112 0 108 16 8 177 80
RFXCOM Debug RFXSensor 16 in list
RFXCOM Debug UpdateMinMax state temperature value 0
RFXCOM Debug lastUpdated empty so must be new day.
RFXCOM Debug Setting display value to Temp, temp=0
RFXCOM Debug ++++++++++++++
RFXCOM Debug processing: 7 112 2 109 16 1 243 80 (07 70 02 6D 10 01 F3 50)
RFXCOM Debug RFXSensor 16 with subtype 2 and value 499
RFXCOM Debug Data1: 7 112 2 109 16 1 243 80
RFXCOM Debug RFXSensor 16 in list
RFXCOM Debug ++++++++++++++
RFXCOM Debug processing: 7 112 1 110 16 0 17 80 (07 70 01 6E 10 00 11 50)
RFXCOM Debug RFXSensor 16 with subtype 1 and value 17
RFXCOM Debug Data1: 7 112 1 110 16 0 17 80
RFXCOM Debug RFXSensor 16 in list
RFXCOM Debug RFXSensor read values: value=17 temperature=0.0 (C)
RFXCOM Debug Setting display value to Temp, temp=0


RFXCOM Debug processing: 7 112 1 164 24 0 21 64 (07 70 01 A4 18 00 15 40)
RFXCOM Debug RFXSensor 24 with subtype 1 and value 21
RFXCOM Debug Data1: 7 112 1 164 24 0 21 64
RFXCOM Debug RFXSensor 24 in list
RFXCOM Debug RFXSensor read values: value=21 temperature=0.0 (C)
RFXCOM Debug Setting display value to Temp, temp=0

Posted on
Wed Jun 07, 2017 9:21 am
matt (support) offline
Site Admin
User avatar
Posts: 17658
Joined: Jan 27, 2003
Location: Texas

Re: No value update (interface freeze)

Thanks for the feedback. I will look at this in more detail over the next few days.

Image

Posted on
Thu Jun 08, 2017 1:28 am
b_weijenberg offline
Posts: 154
Joined: Jun 14, 2006

Re: No value update (interface freeze)

Note that only subtype 0 is a temperature sensor. (22.25 C)

Subtype 2 is the supply voltage of the RFXSensor (4.99 Volt)
Subtype 1 is the A/D sensor (0.17 and 0.21 Volt)

Posted on
Sat Jun 10, 2017 5:51 pm
matt (support) offline
Site Admin
User avatar
Posts: 17658
Joined: Jan 27, 2003
Location: Texas

Re: No value update (interface freeze)

Hi Marcel,

I've posted another updated version for you to try. Let me know how it works for you.

Image

Who is online

Users browsing this forum: No registered users and 2 guests