Rfxcom has stopped receiving

Posted on
Sun Feb 14, 2016 2:12 am
Londonmark offline
Posts: 277
Joined: Feb 29, 2012

Rfxcom has stopped receiving

Hi

I'm guessing I have a hardware problem but just wanted to get a second opinion from the community. I've been happily using an Rfxcom transceiver for four or five years and it picks up signals from Oregon sensors and lightwaveRF PIRs/ remotes / wireless switches (the ones that *do* send out a signal). Suddenly it's stopped receiving signals but still sends them. There's no sign in the plugin of anything being wrong. Thoughts? Time for a new unit? I've obviously restarted everything and disconnected etc.

Thanks guys

Posted on
Sun Feb 14, 2016 7:09 am
Londonmark offline
Posts: 277
Joined: Feb 29, 2012

Re: Rfxcom has stopped receiving

What's really weird is that sensors do still work if in close proximity to the antenna that I've attached to the rfx. I've had this setup for ages and changed nothing. Why would the receive range of the RFX suddenly shrink massively?

Posted on
Sun Feb 14, 2016 3:19 pm
DomoPat offline
User avatar
Posts: 163
Joined: Jul 17, 2010
Location: Toulouse, France

Re: Rfxcom has stopped receiving

My RFXCom lost communication twice:
- first time I had to reboot the Mini: I tried many things including disconnecting/reconnecting the RFX, the USB Hub, etc... and after a reboot 'just in case' the RFX started receiving and sending signals again.
- second time was more tricky: reception was random like it is for you. After a lot of head scratching, I noticed the problems started around the same time as an X10 PIR sensor stopped working. Removing the batteries from that PIR solved the problem, suddenly the RFXCom worked 100% like it should. It looks like the almost dead battery where putting the PIR in a bad state and probably flooding the RF signals all around him.
It happened again a few years later, with the same PIR, and again with low batteries, but that time I found quickly in my notes what to check and what to do !

I know it is not easy, but you could try to remove batteries from the devices in your setup to make sure it si not an RF pollution due to a defective module.

Posted on
Sun Feb 14, 2016 3:46 pm
Londonmark offline
Posts: 277
Joined: Feb 29, 2012

Re: Rfxcom has stopped receiving

Thanks! Will go round replacing batteries and see if that works. Certainly looks as if I have an RF interference problem and makes sense if it's a device that transmits on 433 MHz causing it.

Posted on
Sun Feb 14, 2016 5:11 pm
durosity offline
User avatar
Posts: 3109
Joined: May 10, 2012
Location: Newcastle Upon Tyne, Ye Ol' England.

Re: Rfxcom has stopped receiving

I also once had a weird one where even although the prefs only showed a couple of receiving protocols enabled, when I opened it in the rfxcom manager it showed them all as ticked, so naturally some were conflicting with others. Simply unticking all of them then re-ticking the relevant ones fixed the issue.


Sent from my iPad using Tapatalk

Computer says no.

Posted on
Tue Feb 16, 2016 2:37 am
b_weijenberg offline
Posts: 156
Joined: Jun 14, 2006

Re: Rfxcom has stopped receiving

It is probably RF interference.
Most cases I have seen was a X10 MS13 motion sensor with an almost empty battery. This device starts transmitting RF noise when the battery voltage becomes below a certain level.
Another possibility is an outside weather sensor filled with water.

To check the RFXtrx433E test it with a sensor on another location using a Windows system and RFXmngr.

Posted on
Sat Feb 27, 2016 1:54 pm
Londonmark offline
Posts: 277
Joined: Feb 29, 2012

Re: Rfxcom has stopped receiving

I've been round changing batteries in everything but still no luck. I've also listened for interference using a radio that tunes to 433.92 MHz but couldn't hear any. I'm beginning to think it must be a fault with the RFXCOM. The Lightwaverf wireless switches and PIRs talk as they should to the lightwaverf modules suggesting that the modules are receiving ok and the RFXCOM transmits signals perfectly well. Unfortunately I don't have access to a Windows machine to run rfx manager. Would it run in Wine?

Posted on
Wed Mar 23, 2016 11:24 am
Londonmark offline
Posts: 277
Joined: Feb 29, 2012

Re: Rfxcom has stopped receiving

Quick update on this:
- I upgraded the firmware using a Windows emulator on my Mac - it made no difference
- I borrowed a spectrum analyser to test for interference - I found an external hard drive making a lot of noise in a nearby frequency, but switching it off made no difference
- I got in touch with UK Automation (the shop that I had bought the unit from three years ago) - and they kindly passed my enquiry to Bert at RFXCOM.

Bert was fantastic (replying even though he was on holiday). I sent my unit back to him in the Netherlands and he confirmed that it had gone "deaf", repaired it for free and quickly sent it back to me. My system is now back up and running.

Many thanks Bert!

LM

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest