Strange trigger behavior

Posted on
Tue Jan 09, 2018 2:37 pm
gt3mike offline
Posts: 8
Joined: Dec 31, 2017

Strange trigger behavior

(Apologies if this isn't the right place to post this.)

I have a trigger set up to take an action based on a keypad button press. The ID of the keypad is 3 and the ID of the button is 7.

I see log messages such as the one below letting me know that the trigger ISN'T firing when other system events occur.

Jan 9, 2018 at 1:21:40 PM
Trigger Nest Home -> RR2 Timeclock Home
Lutron RRA2/Caséta Sending Raw Command: "#TIMECLOCK,17,1,3"
Lutron RRA2/Caséta Debug Sending network command: #TIMECLOCK,17,1,3
Lutron RRA2/Caséta Debug Received a TimeClock message: GNET> ~TIMECLOCK,17,1,3
Lutron RRA2/Caséta Debug Trigger RR2 House Off - Sonos Stop (825620404), Type: keypadButtonPress does not have eventNumber
Lutron RRA2/Caséta Debug Skipping Trigger RR2 House Off - Sonos Stop (825620404), wrong type: keypadButtonPress

Lutron RRA2/Caséta Debug Received a Device message: ~DEVICE,33,94,9,0
Lutron RRA2/Caséta Debug Received a Device message: ~DEVICE,33,95,9,1


But when I actually push the keypad button, nothing shows up in the log at all regarding the trigger

Jan 9, 2018 at 1:22:11 PM
Lutron RRA2/Caséta Debug Received a Device message: ~DEVICE,3,7,3
Lutron RRA2/Caséta Debug Received an Output message: ~OUTPUT,20,1,0.00
|
|
Lutron RRA2/Caséta Debug Received an Output message: ~OUTPUT,69,30,1,0.00


Trigger setup is below. Condition is set to "always" and Actions sends a stop to Sonos (action tested and seems to work fine).

What am I missing?

Thanks,
Mike
Attachments
trigger.png
trigger.png (150.41 KiB) Viewed 90 times

Posted on
Tue Jan 09, 2018 5:47 pm
gt3mike offline
Posts: 8
Joined: Dec 31, 2017

Re: Strange trigger behavior

OK, I think I figured this out. I hadn't created a device in Indigo for the keypad button I was using for the trigger. I didn't think this was necessary since the trigger dialog asked for the device and component IDs. I'll keep playing with this to make sure I'm right that it is working 100%.

If there is a doc that spells out this kind of thing, if someone can please point me to it that would be great!

Thanks,
Mike

Jan 9, 2018 at 4:43:19 PM
Lutron RRA2/Caséta Debug Received a Device message: ~DEVICE,3,7,3
Lutron RRA2/Caséta Debug Received a keypad button/LED status message: ~DEVICE,3,7,3
Lutron RRA2/Caséta Debug Received a Keypad Button press message, checking triggers: ~DEVICE,3,7,3
Lutron RRA2/Caséta Debug Executing Trigger RR2 House Off - Sonos Stop (825620404), keypad button: 3, 7
Trigger RR2 House Off - Sonos Stop
Sonos ZonePlayer: Sonos Kitchen, Stop

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest