Key ID not found in database

Posted on
Wed Aug 30, 2017 9:29 am
polycron offline
Posts: 96
Joined: Jan 08, 2006

Key ID not found in database

I just ran into an issue with the new 3.05 version. I had an insteon switch go bad and it had to be replaced. I tossed a zwave switch in its place. The original switch was setup in the Alexa-Hue-Bridge and now when I go in to edit the devices, no items are found in the Published Alexa Devices list. Additionally, I get the following error in my logs:

Code: Select all
   Alexa-Hue Bridge Error          Error in plugin execution GetUiDynamicList:

Traceback (most recent call last):
  File "plugin.py", line 1373, in publishedAlexaDevicesList
KeyError: key id 407388196 not found in database


I'm assuming that the 407388196 is my old switch but I can not confirm that. Is there a way I can remove that from the bridge database? Or is it possible to trap for that error and automatically clean up the database for missing items?

Jeff

Posted on
Wed Aug 30, 2017 10:57 am
autolog offline
Posts: 2025
Joined: Sep 10, 2013
Location: West Sussex

Re: Key ID not found in database

polycron wrote:
... Is there a way I can remove that from the bridge database? Or is it possible to trap for that error and automatically clean up the database for missing items?


Answers: No, Yes and Yes :D

The plugin should obviously handle this situation (the same probably goes for deleted Actions). :oops:

I'll work on a fix - might take 24 hours. :)

Posted on
Thu Aug 31, 2017 1:17 pm
autolog offline
Posts: 2025
Joined: Sep 10, 2013
Location: West Sussex

Re: Key ID not found in database

I have uploaded an interim version that hopefully will resolve the problem: 3.0.6 Release - Requires Indigo 7
V 3.0.6 is marked as Pre-release so won't show up under the normal update checks.

Let me know if this resolves the issue?

I still have a bit more tidying up to do and I will be doing that in 3.0.7. :)

Posted on
Fri Sep 01, 2017 5:19 am
autolog offline
Posts: 2025
Joined: Sep 10, 2013
Location: West Sussex

Re: Key ID not found in database

Version 3.0.7 (see announcement) which completes the fix for this problem. :)

Posted on
Fri Sep 01, 2017 10:06 am
polycron offline
Posts: 96
Joined: Jan 08, 2006

Re: Key ID not found in database

This worked perfectly on my system and resolved my issues.

Jeff

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 2 guests