Upgrading to NodeJS version 6

Posted on
Mon Dec 12, 2016 9:43 pm
dnomode offline
Posts: 279
Joined: Apr 12, 2008
Location: Huntington Beach

Re: Upgrading to NodeJS version 6

Colorado4Wheeler wrote:
Look at the first post in this thread, you need to uninstall everything.

Dang Dude… I tried all that. I also used:

sudo uninstall npm @ 10.01.100
sudo uninstall npm2 @ 10.01.100
sudo uninstall nodejs @ 10.01.100
sudo uninstall nodejs4 @ 10.01.100
sudo uninstall nodejs6 @ 10.01.100
sudo port uninstall npm2
sudo port uninstall nodejs4

Still every time I try sudo port install npm3 I get the following:
Code: Select all
Edmonds-Mac-mini:~ edmond$ sudo port install npm3
--->  Computing dependencies for npm3
--->  Activating npm3 @3.10.9_0
Error: org.macports.activate for port npm3 returned: Image error: /opt/local/bin/npm is being used by the active npm port.  Please deactivate this port first, or use 'port -f activate npm3' to force the activation.
Please see the log file for port npm3 for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_npm3/npm3/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port npm3 failed
Edmonds-Mac-mini:~ edmond$


:?

What you think...
Last edited by dnomode on Mon Dec 12, 2016 10:21 pm, edited 1 time in total.

Posted on
Mon Dec 12, 2016 10:18 pm
webdeck offline
Posts: 359
Joined: May 07, 2005

Re: Upgrading to NodeJS version 6

What does sudo port installed output?

Posted on
Mon Dec 12, 2016 10:20 pm
dnomode offline
Posts: 279
Joined: Apr 12, 2008
Location: Huntington Beach

Re: Upgrading to NodeJS version 6

Here it is…
Code: Select all
Edmonds-Mac-mini:~ edmond$ sudo port installed
Password:
The following ports are currently installed:
  bzip2 @1.0.6_0 (active)
  db48 @4.8.30_4 (active)
  expat @2.1.0_0
  expat @2.2.0_0 (active)
  gettext @0.19.7_0
  gettext @0.19.8.1_0 (active)
  icu @55.1_0 (active)
  libedit @20150325-3.1_0
  libedit @20160903-3.1_1 (active)
  libiconv @1.14_0 (active)
  ncurses @6.0_0 (active)
  nodejs @4.2.6_0+python27+ssl
  nodejs6 @6.9.1_0 (active)
  npm @2.14.16_0 (active)
  npm3 @3.10.9_0
  openssl @1.0.2f_0
  openssl @1.0.2j_0 (active)
  python2_select @0.0_1
  python2_select @0.0_2 (active)
  python27 @2.7.11_0
  python27 @2.7.12_2 (active)
  python_select @0.3_6
  python_select @0.3_7 (active)
  sqlite3 @3.10.2_0
  sqlite3 @3.15.2_2 (active)
  zlib @1.2.8_0 (active)
Edmonds-Mac-mini:~ edmond$

Posted on
Mon Dec 12, 2016 10:24 pm
webdeck offline
Posts: 359
Joined: May 07, 2005

Re: Upgrading to NodeJS version 6

Try:
Code: Select all
sudo port uninstall inactive
sudo port uninstall npm
sudo port install npm3

Posted on
Mon Dec 12, 2016 10:30 pm
dnomode offline
Posts: 279
Joined: Apr 12, 2008
Location: Huntington Beach

Re: Upgrading to NodeJS version 6

I get this:
Code: Select all
Edmonds-Mac-mini:~ edmond$ sudo port uninstall inactive
Password:
--->  Unable to uninstall nodejs @4.2.6_0+python27+ssl, the following ports depend on it:
--->     npm @2.14.16_0
Error: org.macports.uninstall for port nodejs returned: Please uninstall the ports that depend on nodejs first.
Please see the log file for port nodejs for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_registry_portfiles_nodejs-4.2.6_0_c3c3118390d45d4dba15c695e423c0f03dd7077be708c64f4a8442b0b25f78b2-7658/nodejs/main.log
Warning: Failed to execute portfile from registry for nodejs @4.2.6_0+python27+ssl
--->  Unable to uninstall nodejs @4.2.6_0+python27+ssl, the following ports depend on it:
--->     npm @2.14.16_0
Error: port uninstall failed: Please uninstall the ports that depend on nodejs first.
Edmonds-Mac-mini:~ edmond$

Posted on
Mon Dec 12, 2016 10:31 pm
webdeck offline
Posts: 359
Joined: May 07, 2005

Re: Upgrading to NodeJS version 6

Do the other two lines then try the first line again.

Posted on
Mon Dec 12, 2016 10:35 pm
dnomode offline
Posts: 279
Joined: Apr 12, 2008
Location: Huntington Beach

Re: Upgrading to NodeJS version 6

so I tried sudo port uninstall npm and that worked. Then sudo port uninstall inactive and that seemed to work. Then got error running sudo port install npm3

Code: Select all
Edmonds-Mac-mini:~ edmond$ sudo port uninstall npm
--->  Deactivating npm @2.14.16_0
--->  Cleaning npm
--->  Uninstalling npm @2.14.16_0
--->  Cleaning npm
Edmonds-Mac-mini:~ edmond$ sudo port uninstall inactive
--->  Uninstalling nodejs @4.2.6_0+python27+ssl
--->  Cleaning nodejs
--->  Uninstalling python27 @2.7.11_0
--->  Cleaning python27
--->  Uninstalling gettext @0.19.7_0
--->  Cleaning gettext
--->  Uninstalling expat @2.1.0_0
--->  Cleaning expat
--->  Uninstalling sqlite3 @3.10.2_0
--->  Cleaning sqlite3
--->  Uninstalling libedit @20150325-3.1_0
--->  Cleaning libedit
--->  Uninstalling npm3 @3.10.9_0
--->  Cleaning npm3
--->  Uninstalling openssl @1.0.2f_0
--->  Cleaning openssl
--->  Uninstalling python2_select @0.0_1
--->  Cleaning python2_select
--->  Uninstalling python_select @0.3_6
--->  Cleaning python_select
Edmonds-Mac-mini:~ edmond$ sudo port uninstall npm
Edmonds-Mac-mini:~ edmond$ sudo port install npm3
--->  Computing dependencies for npm3
--->  Installing npm3 @3.10.9_0
Error: org.macports.install for port npm3 returned: no destroot found at: /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_npm3/npm3/work/destroot
Please see the log file for port npm3 for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_npm3/npm3/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port npm3 failed
Edmonds-Mac-mini:~ edmond$

Posted on
Mon Dec 12, 2016 10:39 pm
webdeck offline
Posts: 359
Joined: May 07, 2005

Re: Upgrading to NodeJS version 6

Haven't seen that one before, but google search says to clean it and try again, so:
Code: Select all
sudo port clean npm3
sudo port install npm3

Posted on
Mon Dec 12, 2016 10:44 pm
dnomode offline
Posts: 279
Joined: Apr 12, 2008
Location: Huntington Beach

Re: Upgrading to NodeJS version 6

BINGO…

That worked. thanks.

Now I ran
Code: Select all
sudo npm install -g homebridge
sudo npm install -g homebridge-indigo
Everything seemed to install good. Should HB be running now? How do I confirm that Its running correctly?

Edmond

Posted on
Mon Dec 12, 2016 10:48 pm
webdeck offline
Posts: 359
Joined: May 07, 2005

Re: Upgrading to NodeJS version 6

It doesn't run automatically. You have it installed. You can either run it manually on the command line, or configure it to run as a service.

Posted on
Mon Dec 12, 2016 10:52 pm
dnomode offline
Posts: 279
Joined: Apr 12, 2008
Location: Huntington Beach

Re: Upgrading to NodeJS version 6

I had it running automatically with Indigo 6. Do I need to re-enable it?

I tried this:
Code: Select all
launchctl load -w ~/Library/LaunchAgents/com.webdeck.homebridge.plist
and got this
Code: Select all
Edmonds-Mac-mini:~ edmond$ launchctl load -w ~/Library/LaunchAgents/com.webdeck.homebridge.plist
com.webdeck.homebridge: Already loaded
Edmonds-Mac-mini:~ edmond$

Posted on
Mon Dec 12, 2016 10:53 pm
webdeck offline
Posts: 359
Joined: May 07, 2005

Re: Upgrading to NodeJS version 6

You should do an unload followed by a load to restart it.

Posted on
Mon Dec 12, 2016 10:55 pm
dnomode offline
Posts: 279
Joined: Apr 12, 2008
Location: Huntington Beach

Re: Upgrading to NodeJS version 6

Ok, then restart the computer?


Sent from my iPhone using Tapatalk

Posted on
Mon Dec 12, 2016 10:56 pm
MarcoGT offline
Posts: 504
Joined: Sep 11, 2014
Location: Germany

Re: Upgrading to NodeJS version 6

Restart should not be necessary

Posted on
Mon Dec 12, 2016 10:59 pm
webdeck offline
Posts: 359
Joined: May 07, 2005

Re: Upgrading to NodeJS version 6

Shouldn't need to restart your computer.

Who is online

Users browsing this forum: No registered users and 2 guests