Available devices only if I use Homebridge :-D

Posted on
Thu Sep 29, 2016 12:06 am
jmortizsilva offline
Posts: 9
Joined: Sep 10, 2014

Available devices only if I use Homebridge :-D

Hello everyone,

I'm configuring access from the Home app from my iPhone and my devices are only available if I use Homebridge D in Terminal.

I followed all the steps to use launchctl and although does not give me any errors, neither seems to work, my devices will not be available on my iPhone.

What I do is the following:

1. write "Homebridge D" in Terminal and intro pulse. Right now I can perfectly access to my devices from the House and manage iPhone application with Siri.
2. write Control + C "in Terminal to close the window. Naturally, the devices are no longer available.
3. write "launchctl load -w ~ / Library / LaunchAgents / com.webdeck.homebridge.plist" in terminal and do not receive any message, so I guess there is no error. Right now my devices continue without being available on the iPhone app.

This is the code of the com.webdeck.homebridge.plist file:

Code: Select all
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
   <key>KeepAlive</key>
   <true/>
   <key>Label</key>
   <string>com.webdeck.homebridge</string>
   <key>ProgramArguments</key>
   <array>
      <string>/Users/anasanchezrabanal/.homebridge/runhomebridge</string>
   </array>
</dict>
</plist>


And this is de code of de runhomebridge file:
Code: Select all
#!/bin/sh
export PATH=/usr/local/bin:/opt/local/bin:$PATH
sleep 60
exec homebridge >~/Library/Logs/homebridge.log 2>&1


I can't send the log because I can't find this, its not create.

Can you think you may be going on?

Sorry for my english.

Page 1 of 1

Who is online

Users browsing this forum: roussell and 1 guest