Devices leaving a geofence but not moving

Posted on
Sun Jul 17, 2016 8:45 am
jalves offline
Posts: 403
Joined: Jun 16, 2013

Devices leaving a geofence but not moving

Anybody have difficulty with iFindStuff reporting a device has left the geofence (in my case the home geofence) yet the device is still sitting on the shelf, plugged in, unmoved for the past 12 hours. I get this occasionally and wonder if there is a solution. I'm using the default parameters for the device.

Running Indigo 7.1.1 on a headless Mac Mini (late 2012), 2.3 GHz I7, 16G memory, 1TB 7200 RPM spinning drive, OS X 10.13.2
Jeff

Posted on
Mon Jul 18, 2016 8:13 am
Chameleon offline
Posts: 611
Joined: Oct 04, 2014

Re: Devices leaving a geofence but not moving

jalves wrote:
Anybody have difficulty with iFindStuff reporting a device has left the geofence (in my case the home geofence) yet the device is still sitting on the shelf, plugged in, unmoved for the past 12 hours. I get this occasionally and wonder if there is a solution. I'm using the default parameters for the device.

Jeff

It's probably the accuracy of the Apple FindMyPhone application it uses. I get the same issue occasionally when it reports that my mobile is outside and about 50 m down the street.

There are a couple of things you can do to resolve it:

1. Check the reporting. You can plot the historical data for a device over 24 hours and you will be able to see on the Google Map where Apple thinks the device has been. You'll probably find it drifting throughout the day - not by much but enough to go outside your Geofence.

2. After doing (1) or just on spec - increase the Geofence size in the iFindStuff Geofence device from say 50-100m.

That should resolve it. If it doesn't let me know and I'll investigate further.

Regards

Mike

Posted on
Mon Jul 18, 2016 9:16 am
TOPS offline
User avatar
Posts: 169
Joined: Jun 17, 2015
Location: London, England

Re: Devices leaving a geofence but not moving

Hi Guys,

Sorry to Hijack the post but all I seem to be getting is the dreaded "to many queries for one day" argggh...how can we rectify this problem??

Cheers,

Dave

Posted on
Mon Jul 18, 2016 7:20 pm
mattggarland offline
Posts: 49
Joined: Jan 06, 2013

Re: Devices leaving a geofence but not moving

I never did much work on this but I thought about a hybrid ping system. Something like

device leaves home geofence
Indigo tries a ping on iPhone ip
If response, ignore and wait for next location update before acting...

A shell script should do it but I'd need to google my way through something


Sent from my iPhone using Tapatalk

Posted on
Fri Jul 22, 2016 3:42 am
Chameleon offline
Posts: 611
Joined: Oct 04, 2014

Re: Devices leaving a geofence but not moving

mattggarland wrote:
I never did much work on this but I thought about a hybrid ping system. Something like

device leaves home geofence
Indigo tries a ping on iPhone ip
If response, ignore and wait for next location update before acting...

A shell script should do it but I'd need to google my way through something


Sent from my iPhone using Tapatalk


Matt

I think that you could use the link that iFindStuff has with FINGSCAN. The configuration allows you to ping devices in the home geofence for better results. I think that there's a post here that explains what Karl added to make it work... Let me know how you get on...

http://forums.indigodomo.com/viewtopic.php?f=181&t=14943

Regards

Mike

Posted on
Fri Jul 22, 2016 3:43 am
Chameleon offline
Posts: 611
Joined: Oct 04, 2014

Re: Devices leaving a geofence but not moving

TOPS wrote:
Hi Guys,

Sorry to Hijack the post but all I seem to be getting is the dreaded "to many queries for one day" argggh...how can we rectify this problem??

Cheers,

Dave


Dave

I've sent you an mail for some more information...

Mike

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest