Autolog LIFX Controller Discussion

Posted on
Mon Mar 13, 2017 11:29 am
Nidocamen offline
Posts: 19
Joined: Oct 18, 2011

Re: Autolog LIFX Controller Discussion

autolog wrote:
Hi Joe,
I haven't really got time to delve into the code of the previous version. :(

There were a number of problems with the previous code; especially after LIFX changed the way their iOS App worked (allowing the user to change saturation). That is why in my LIFX 4.x versions I changed to using the LIFXLAN library. I have just tested your settings with the new version of the plugin and it appears to work OK.

I assume you haven't upgraded to Indigo 7? If you have, then I recommend that you upgrade to version 4 of the plugin which I am supporting. :)

Sorry to not be able to help but it would take too much time to sort it out. :|


No worries on the previous version, I figured as much. I haven't updated to 7 yet due to a temporary budget challenge but am planning on it relatively soon. I also wanted to wait a bit, since it seems that many of the plugins I use have to be upgraded to 7-compatible versions and I wanted to let any of the bug fixes roll out :-)

So the new LIFX 4 plugin supports setting the saturation as well as the other attributes?

Thanks!

Posted on
Mon Mar 13, 2017 11:55 am
autolog offline
Posts: 1600
Joined: Sep 10, 2013
Location: West Sussex

Re: Autolog LIFX Controller Discussion

Nidocamen wrote:
... So the new LIFX 4 plugin supports setting the saturation as well as the other attributes? ...

Yes it does. :)

You can read the README.PDF documentation for the latest version (4.0.5) here: https://github.com/autolog/LIFX_Controller/releases

Hope that helps. :)

Posted on
Thu Mar 30, 2017 9:23 am
mollynittany offline
Posts: 1
Joined: Mar 30, 2017

Re: Autolog LIFX Controller Discussion

Having this problem with my Lifx Z strips using 4.0.5 on Indigo 7. Doesn't make sense to me

From the Event Log

Mar 30, 2017, 11:19:49 AM
LIFX Unable to process "TurnOn" for "Overhead 1" as device not connected
LIFX LIFX Device 'Overhead 3' re-connected at 192.168.1.146 [d0:73:d5:14:ab:36] using Port 56700
LIFX LIFX Device 'Overhead 3' started.
LIFX LIFX Device 'Overhead 1' re-connected at 192.168.1.135 [d0:73:d5:14:9a:2a] using Port 56700
LIFX LIFX Device 'Overhead 1' started.
LIFX LIFX Device 'Overhead 2' re-connected at 192.168.1.132 [d0:73:d5:14:92:8d] using Port 56700
LIFX LIFX Device 'Overhead 2' started.
LIFX Unable to process "TurnOn" for "Overhead 1" as device not connected

Any suggestions would be greatly appreciated.

Posted on
Thu Mar 30, 2017 9:34 am
autolog offline
Posts: 1600
Joined: Sep 10, 2013
Location: West Sussex

Re: Autolog LIFX Controller Discussion

Do you have any other LIFX bulbs being controlled by the plugin?

Who is online

Users browsing this forum: No registered users and 1 guest

cron