iPad and new iPhone lose part of touch via reflector.

Posted on
Sat Oct 07, 2017 10:56 pm
BlueMOH offline
Posts: 6
Joined: Sep 25, 2017

iPad and new iPhone lose part of touch via reflector.

Hey everyone - thanks for the help last time but now it's on to other things!,
Over the last few weeks I have been having "remote in" issue via my iPad and now new iPhone (moved from android as that phone failed one too many times). I can't be for sure as to how long and I believe my previous firewall issues have subsided I posted about below (on or off this time make no difference).
I am running a headless Mac Mini if it matters.

The strange part is Touch works great on the local network and the strange part is it works partly "on reflector".
By that I mean I can remote access the logs, via touch, and they are current to the point showing the time I currently connected and my current IP but I get "interface error" and my devices list is not up to date. I have checked that all my plug ins are current as is Indigo. Restarted the server as well as the Mini. Even went so far as to restart my network.
The other noted item is I now have two "My House" , one with a (2) after it - can't delete as they both show up again.
I have manually added the web link for the reflector and have tried to use it with no further luck - in a browser it pulls my devices - not current - and does not work?
I have to enter the server information, name and password, each time I try to connect or change between server links - inside the app, is this right?.

I am almost positive I am doing something wrong or have overlooked a setting - maybe messed things up muddling around.
Any ideas or suggestions would be greatly appreciated Thank you.

Ken

Posted on
Sun Oct 08, 2017 10:43 am
matt (support) offline
Site Admin
User avatar
Posts: 17840
Joined: Jan 27, 2003
Location: Texas

Re: iPad and new iPhone lose part of touch via reflector.

Hi Ken,

This occurs if you have another Mac that is running the Indigo Server. It doesn't have the interface (hence the interface error) and its devices are older since you aren't actually using it. So follow these steps to uninstall Indigo from the other Mac. Once you do that (and restart that Mac) you should be able to delete that server entry from Indigo Touch and it will no longer magically reappear.

Image

Posted on
Sun Oct 08, 2017 8:03 pm
BlueMOH offline
Posts: 6
Joined: Sep 25, 2017

Re: iPad and new iPhone lose part of touch via reflector.

Matt,

Thank you for the info - I tried it and it made no difference. I have had Indigo only installed on my laptop and now the Mini. I shutdown the laptop and the double server still shows. Though now the server can not come up on the laptop by accident, so less chance for future mess ups.
To me that means I goofed something up on the Mini or it's having a "moment" as these are my only two Macs. Things were working really well up till recently and for the life of me I can not correlate if it started after an update or after something I did.
I stopped and restarted the server so as to watch the log for anything that would seem out of place and the errors below showed up;

Starting Indigo Server version 7.0.3 (Mac OS X 10.12.6)
Loading attachments
"device target attachment.scpt" script loaded
"group target attachment.scpt" script loaded
"growl attachment.scpt" script loaded
"iTunes attachment.scpt" script loaded
"scenes attachment.scpt" script loaded
"time stamp attachment.scpt" script loaded
Loading database "/Library/Application Support/Perceptive Automation/Indigo 7/Databases/My House.indiDb"
Error XML Parse Error: not well-formed (invalid token)
Error On character 61 of line number 21.
Error XML Parse Error: not well-formed (invalid token)
Error On character 61 of line number 21.
Error XML Parse Error: not well-formed (invalid token)
Error On character 61 of line number 21.[/color]
Loading plugin "Action Collection 2.0.4"
Starting plugin "Action Collection 2.0.4" (pid 52584)
Loading interface "INSTEON Commands 2.0.10"
Starting interface "INSTEON Commands 2.0.10" (pid 52585)
Loading interface "Z-Wave 2.0.68"
Starting interface "Z-Wave 2.0.68" (pid 52586)
Loading plugin "Dimmer Extender 1.1.1"
Starting plugin "Dimmer Extender 1.1.1" (pid 52587)
Loading plugin "Domotics Pad Mobile Client 2.1.1"
Starting plugin "Domotics Pad Mobile Client 2.1.1" (pid 52588)
Loading plugin "EPS - Smart Dimmer 1.0.0"
Starting plugin "EPS - Smart Dimmer 1.0.0" (pid 52589)
Loading plugin "Growl 2.0.2"
Starting plugin "Growl 2.0.2" (pid 52590)
Loading plugin "iCal Alarm Processor 2.0.1"
Starting plugin "iCal Alarm Processor 2.0.1" (pid 52591)
Loading plugin "MyQ 7.1.8"
Starting plugin "MyQ 7.1.8" (pid 52592)
Loading plugin "Smart Devices 1.2.5"
Starting plugin "Smart Devices 1.2.5" (pid 52593)
Loading plugin "SQL Logger 2.0.5"
Starting plugin "SQL Logger 2.0.5" (pid 52594)
Loading plugin "Timers and Pesters 2.0.2"
Starting plugin "Timers and Pesters 2.0.2" (pid 52595)
Loading plugin "User Scripts 1.0.0"
Loading interface "Virtual Devices 2.0.4"
Starting interface "Virtual Devices 2.0.4" (pid 52596)
Error XML Parse Error: not well-formed (invalid token)
Error On character 61 of line number 21.
Found disabled plugin "Acme Future Home C-Panel System 1.2.0"
Found disabled plugin "Airfoil Pro 1.0.7"
Found disabled plugin "Airfoil 1.1.14"
Found disabled plugin "DIRECTV DVR Control 1.1.1"
Found disabled plugin "EasyDAQ Relay Card 2.0.3"
Found disabled plugin "EPS - Alarm Clock 1.1.1"
Found disabled plugin "Global Property Manager 2.0"
Found disabled plugin "iTunes 2.0.4"
Found disabled plugin "NOAA Weather 2.0.1"
Found disabled plugin "TiVo Network Remote Plugin 1.4.19"
Found disabled plugin "Vera Bridge 1.0.10"
Found disabled plugin "WeatherSnoop 2.1.2"
Bonjour registered "Indigo - My House"
Indigo Cocoa client connected
Started plugin "Action Collection 2.0.4"
Started plugin "Growl 2.0.2"
Started plugin "EPS - Smart Dimmer 1.0.0"
Started plugin "Dimmer Extender 1.1.1"
Started plugin "SQL Logger 2.0.5"
Started interface "Virtual Devices 2.0.4"
Reflector starting reflector connection to https:/....................indigodomo.net
Started plugin "Timers and Pesters 2.0.2"
Started interface "INSTEON Commands 2.0.10"
Started plugin "iCal Alarm Processor 2.0.1"
Smart Devices debug disabled
Started plugin "Smart Devices 1.2.5"
Started plugin "MyQ 7.1.8"
MyQ Starting MyQ
MyQ Checking for updates...
Started plugin "Domotics Pad Mobile Client 2.1.1"
Domotics Pad Mobile Client Checking for updates...
WebServer client connected
WebServer started on port 8176 -- digest authentication enabled
WebServer loaded plugin "Android Client Helper Plugin"
Started interface "Z-Wave 2.0.68"
MyQ No updates are available
Domotics Pad Mobile Client No updates are available

Oct 8, 2017, 7:36:19 PM
Connected to PowerLinc 2448A7 rev2 interface on port usbserial-A6033826
PowerLinc address 31.19.35, firmware version 3.10

With this information can someone perchance tell me if I have an issue that I caused or a direction to go hunting in?
On the plus side my double server seems to have gone for now - I don't know why it didn't clear up on the reboot yesterday.
I will monitor over the next few weeks.

The only other thing I miss from my android phone are the 'Push' notifications. Anyway to trigger such a thing in Touch for iOS?

If this problem/post has changed enough and needs to be in another forum, please let me know!

Thank you again for the help,
Ken

Posted on
Mon Oct 09, 2017 12:20 pm
matt (support) offline
Site Admin
User avatar
Posts: 17840
Joined: Jan 27, 2003
Location: Texas

Re: iPad and new iPhone lose part of touch via reflector.

Hi Ken,

I'm confused. You said in your reply above the double server still shows, but then towards the end of the post you said the double server is now gone.

What specifically is the problem right now? I am positive the double-server is because you had 2 copies of Indigo Server running (on two different Macs). It looks like you also have some XML errors in your log, so it is possible your database has become corrupt. If that is the case then email us your database file so we can take a look at it.

Image

Posted on
Mon Oct 09, 2017 10:14 pm
BlueMOH offline
Posts: 6
Joined: Sep 25, 2017

Re: iPad and new iPhone lose part of touch via reflector.

Matt,
Sorry for the confusion but yes I had the duel servers showing after I cleaned out and completely shut down my laptop. The server is on my Mini.
I did not boot the laptop and checked my servers in Touch (iPhone and iPad) - both still showed both servers.

I then went into the Mini Indigo 7 server and shut down the server and then started it up again to get the log posted and the servers listing went back to my usual one "My House". (I got a phone call and came back to working on this about 15 minutes later (checking the server listing and reading log)) - laptop had been off for over 30 minutes by this time.
I had already rebooted the Mini the day before, so this confused me as well. I figured the Mini and Indigo was OK after that.
So as of this post, things are working OK again after multiple reboots. I will be paying closer attention in the coming weeks as time allows.

I will gladly send the database to you - thank you for the assistance there - Best way to do this?

Thank you for the help so far - you got me to clean out to help prevent future issues,
Ken

Posted on
Tue Oct 10, 2017 11:13 am
matt (support) offline
Site Admin
User avatar
Posts: 17840
Joined: Jan 27, 2003
Location: Texas

Re: iPad and new iPhone lose part of touch via reflector.

Hi Ken,

If you still see those XML errors when starting the Indigo Server then send the database to support AT indigodomo DOT com.

Image

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest